Jump to content

Xcache admin panel 500 internal server error

Recommended Posts


I was install xcache under apache suphp and it seems to load it without any problems as i can see using php -v

When i copy from untared folder the admin directory to my public_html i got 500 internal error (i have setup my password as md5)

Any ideas how can i fix it?

Thank you

Link to comment
Share on other sites

[quote name='ASTRAPI' date='28 November 2009 - 10:04 AM' timestamp='1259402669' post='1883015']
In my whm when i change the suphp i have an option for cgi only and nothing related to fcgi .....

After you choose which PHP version you want to compile you need to scroll to the bottom and click "Exhaustive Options List".

From there un-check suPHP and then check "Mod FCGID" and "Fastcgi" (first is under Apache, second is under PHP). Then at the end of the build choose fasgcgi as the way PHP connects to Apache. cPanel automatically uses suExec to set each account to use their user, so there is no need for suPHP.

If you do not have it make sure that cPanel is up to date. I'm using v11.24.5. There are several options like "Update Server Software", "Update System Software", and "Upgrade to Latest Version" (you'd run the latest version update last).

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...