Jump to content

Error setting IPB with Wordpress

Ulisse Savi

Recommended Posts

I need to use Invision Power Board with Wordpress. I downloaded miniorange-oauth-20-server plugin and OAuth Login, after installing Invision Power Board. I followed the instructions I found here: https://invisioncommunity.com/4guides/how-to-use-ips-community-suite/social-sign-in/43-and-above/wordpress-r304/. I set up WordPress on the add client entry, getting a Client ID and a Secret Client. After that I went to the Invision Board administration panel and clicked Create New. Here after choosing WordPress and having correctly filled all the settings including Client ID and Client Secret that I had found on WordPress, writing “Save”, I got the error:
The provider is not responding as expected Check the application settings are correct and you have registered the correct Redirect URI.
SSL: certificate subject name ‘Plesk’ does not match target host name ‘pets-99.com’ “where pets-99.com is the site where I have installed WordPress and IPB ..
Has anyone got the same error and how did he solve it? Can someone help me ?

Link to comment
Share on other sites

I chose the self-signed certificate option and I repeated the Invision Login & Registration procedure but I got another error, this:
The application settings provided are not correct. .

This is the self-signed certificate:
Bits: 4096
Country: Italy
State or province: Piacenza
Location (city): Piacenza
Organization name (company): Meta-99.com
Organization department or division name
Domain name: www.pets-99.com
Email: root@condor2859.startdedicated.com

And this is the setting for the Login & Registration panel:


Allow Admin CP logins?
When a user signs in for the first time

Create an account
If necessary, the user will be prompted to provide a display name and email address. The validation method will be applied to the login handler in which case it is considered to be validated.

Reject the sign in
If you have disabled registration on your community or have age restrictions.

The user will be prompted to link the accounts as if they had done so from their Account Settings page, regardless of what this is set to.
Wordpress Settings
Follow the Wordpress Login guide to obtain these details. The Authorized Redirect URI to use is http://www.pets-99.com/invision/oauth/callback/
Client Identifier REQUIRED : Secret...

Client Secret REQUIRED : Secret...
Wordpress URL REQUIRED https://www.pets-99.com/

Link to comment
Share on other sites

No, both IPS and WordPress need to both have HTTPS URLs for the SSO OAuth single sign on to work. You do not want a self signed certificate because visitors will get red browser warnings when visiting your website:


Get SSL setup so you have green padlock setup on your whole website (IPS and WordPress). If you’re not sure how to do this, check with your hosting company.

Link to comment
Share on other sites

I have not setting in the Miniorange OAUTH PlugIn, a part the voice OAUTH Clients, that i send like allegated. I post also the Plesk Hosting Settting page divide in up and down, and the setting of Invision Login & Registration. I have not settting in OAUTH plugin because i followed this link https://invisioncommunity.com/4guides/how-to-use-ips-community-suite/social-sign-in/43-and-above/wordpress-r304/ and i had stopped to follow the instruction when i had the error : "The provider is not responding as expected. Check the application settings are correct and you have registered the correct Redirect URI. SSL: certificate subject name 'Plesk' does not match target host name 'www.pets-99.com'" The error can be caused because i have installed Invision and Wordpress in the link http://www.pets-99.com/ but in the Invision Login & Registration , to avoid error i have write at the voice  Wordpress URL the link  https://www.pets-99.com/ .s

Plesk Hosting Setting Up.png

Plesk Hosting Setting Down.png

OAuth Clients Wordpress Mini Orange Server.png

Invision Login & Registration Handler.png

Invision Login & Registration Details Up.png

Invision Login & Registration Details Down.png

Invision Login & Registration Create New.png

Link to comment
Share on other sites

I send all pages in the miniorange setup. The voice "click here" in the General Setting link to the page of Licensing Plans. The ultimate 3 pages are the links included in the voice "How to Setup?"

OAuth Clients Wordpress Mini Orange Server.png

General Setting Wordpress Mini Orange Server.png

How To Setup Wordpress Mini Orange Server.png

Licensing Plans Wordpress Mini Orange Server.png

httpwww.pets-99.com_wp-content_plugins_miniorange-oauth-20-server_web_moserver_authorize Wordpress Mini Orange Server.png

httpwww.pets-99.comwp-content_plugins_miniorange-oauth-20-server_web_moserver_token Wordpress Mini Orange Server.png

httpwww.pets-99.com_wp-content_plugins_miniorange-oauth-20-server_web_moserver_resource  Wordpress Mini Orange Server.png

I have installed WordPress in http://www.pets-99.com/ and Invision Board in http://www.pets-99.com/invision/. I can not configure Login & Registration with the right installation link of wordpress http://www.pets-99.com/ because if i write this link Invision send me an error. It accept only https://www.pets-99.com/ . Login & Registration panel accept only https://www.pets-99.com/ . Is this the problem ? I made an error installing wordpress and invision under the site http://www.pets-99.com/ and not in the site https://www.pets-99.com/ . Is it the cause of certificate error ? Exist a system to configure the wordpress site from http://www.pets-99.com/ to https://www.pets-99.com/or i have to delete all installations and create a new installaion in https://www.pets-99.com/ . What is the sytem to configure the setting in wordpress with the url https://www.pets-99.com/ or i have to restart all installation. Is it sufficient change some file type wp-config.php or not ? And what files i have to change to have the correct installation fromhttp://www.pets-99.com/ to https://www.pets-99.com/ ?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...