Jump to content

UTF8 convertion errors


Recommended Posts

Hello ! :)

I've tried converting to utf8mb4 through SSH. It was fast at the beginning, then when it came to the posts table (7 Gb big), it looked liked the converter freezed at 9% (but mysql was still doing the job it seemed- I ran a top to check).

Minutes later, I got this error message :


Error: Error while sending QUERY packet. PID=135174
File: /system/Db/Db.php
Line: 244

I typed again php cli.php and I got this message :


You have a conversion session unfinished. The session was last updated on Tue 26 January 2016 and has processed 245 tables (48%) so far.

[c] Enter 'c' to continue
[x] Enter 'x' to reset and start the conversion again.


I chose to continue. It freezed again. So I restarted the conversion again.

It took 56 minutes to complete...

I restarted it and got the same error, but the conversion was faster (28 minutes).


I visited my test web site and it seemed ok, except that I got question marks (?) where I am supposed to get a é or a è in some places (translated words which are part ot the French language pack).


I will try again, after optimizing MySQL and Apache/PHP. Can you give me pieces of advice about this ?


Thank you ! :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...