Jump to content

Can't change default theme


Recommended Posts



Hi all,

I've a little problem on my forum.

Last week I have downloaded the files to make the upgrade to the Version and than uploaded... unfortunately I haven't see that my php Version is lower than the one that I need.

Problem? Not really... just rename the folders and upload the backups one.


Until here all fine.


Now, today, my idea was to make a little modification on my css template (just replace a little font color).

I make the change, and suddenly my forum has no more CSS (I mean: withe page, no more formatting structure,...) on the modified skin.



This skin (TexWillerForumSkin) was my default skin.

I decide to put the "Default" skin back as default so that TexWillerForumSkin wasn't a problem for the users.

On my Admin CP pannel I see the "default" Icon/laber near the Default skin and no more near TexWillerForumSkin; fine!

But no... on the forum the default skin is still near TexWillerForumSkin and not near Default.

And, it's impossible to delete my TexWillerForumSkin because on my AdminCP, even if the "default"-label is near the skin named Default, for the system my default skin still here too the TexWillerForumSkin.



I've looking into the logs:

Sat, 12 Dec 2015 10:21:02 +0000 (Severity: 2) - http://my_site/my_admin_folder/?adsess=ok2e0fs64f09nk67a65rj6j2q7&app=core&module=customization&controller=themes&do=form&id=2
#0 /var/www/my_site/html/system/Theme/Theme.php(1665): IPS\File\_FileSystem->contents()
#1 /var/www/my_site/html/system/Node/Controller.php(336): IPS\_Theme->saveForm(Array)
#2 [internal function]: IPS\Node\_Controller->form()
#3 /var/www/my_site/html/system/Dispatcher/Controller.php(85): call_user_func(Array)
#4 /var/www/my_site/html/system/Node/Controller.php(63): IPS\Dispatcher\_Controller->execute()
#5 /var/www/my_site/html/system/Dispatcher/Dispatcher.php(129): IPS\Node\_Controller->execute()
#6 /var/www/my_site/html/my_admin_folder/index.php(13): IPS\_Dispatcher->run()
#7 {main}


I've tried to reload my backups files but I still with the problem... Impossible to change the default skin, impossible to delete my TexWillerForumSkin skin,...

Any idea?

Link to comment
Share on other sites

6 minutes ago, TexFanatico said:


I have also set directly through the DB the Default skin as members skin.

Check the members preferences (admincp >> members >> members >> far right of member name click the pencil icon >> preferences tab) to see what skin/theme is being used

Link to comment
Share on other sites

The users are correctly set with the Default skin but my problem is on the AdminCP.

I can't set Default as default  (a guest would still see the forum with the corrupted skin) and I can't delete the corrupted skin because she still "blocked" as default.


If I would take of the default value I got:

EX0 Something went wrong. Please try again.


The Default skin take the default label but she didn't maintain the default value.

Link to comment
Share on other sites

Already tried but I still with the same problem.


Some "little progress"


I have lost, I don't know where... the sync between the template and my css.


If I look my source code, when I use my TexWillerForumSkin I see that the css files take a path like this one:




I don't know why, but this path contain the name of my OLD css.

Now I have take my old css files and replace into the folder and "finally" my formatting site is back (so the guest can see a good forum without a first bad impact :thumbsup:)

Anyway I still with the impossibility to switch the default value between the skins.



As I've seen:

- if I change something into my css files trough the AdminCP, on the server the name would change, but than my template didn't update the value and he still looking for the old one.



Perhaps the two thinks have the same reason... I start to think that I need to make a global re-install to be sure to have a good folders/files structure. I'm pretty sure that through the different updates I've contaminate in some way this structure.



Link to comment
Share on other sites




Ok... it was a really stupid problem :)

I don't know why, but my applications and datastore folders was no more writable; set them as writable has solved the problem. TWF_emo_craniate.gif

Note: next time start to check through the support tool "System check" :ph34r:


Anyway, thank you for your time



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...