Jump to content

Enabling SSL


AdamW16
 Share

Recommended Posts

I'd like to use SSL for my whole IPB (4.1) installation.  First I enabled the 'https for admin logins' option in the admin panel, but this resulted in a redirect loop.  After disabling that option, I tried to replace http with https in 'base_url' in conf_global.php, but this also gave me a redirect loop.  Is there something else that needs to be changed?

Thanks!

Link to comment
Share on other sites

2 hours ago, AdamW16 said:

I'd like to use SSL for my whole IPB (4.1) installation.  First I enabled the 'https for admin logins' option in the admin panel, but this resulted in a redirect loop.  After disabling that option, I tried to replace http with https in 'base_url' in conf_global.php, but this also gave me a redirect loop.  Is there something else that needs to be changed?

I'm going to assume you installed the SSL for your HTTP server to use.  Odds are it's via cPanel, since apparently most of the IPS admins use Apache with panels and not nginx configured via shell access (guess it's to complicated).  In either case, for the site to be fully SSL the HTTP server has to talk over port 443 and be configured to use the  certificate.

Edited by T. D. Perry
Link to comment
Share on other sites

5 hours ago, Ausy said:

You just change the base_url as you did before but then clear the cache by going to acp - support - something isnt working.

Also if you allow remote images enable " Serve images from local server?" in acp - posting - general.

Thanks- that worked!  It turns out that I had also created a https URL whitelist in my apache configuration, so I needed to add the url to my IPB installation there.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...