Jump to content

MISSING_APP_DATA


b0re
 Share

Recommended Posts

Hay,

Just ran the latest update and got - 

MISSING_APP_DATA 
/var/www/vhosts/xxxxxxx.co.uk/httpdocs/applications/core/sources/Setup/Upgrade.php::698

Retry and continue did not work.

When i login to the admin, the update option has gone.  I am not sure now if an update has been applied.

I have a backup and the forum is offline.

Thanks

ar/www/vhosts/tacticaladvance.co.uk/httpdocs/applications/core/sources/Setup/Upgrade.php::698

Link to comment
Share on other sites

I got this error and fixed it.

Basically, once you download the upgrade package from the ACP, if you're running RC7a where there was no Chat (for what I know anyway), the upgrade package includes Chat. So when the upgrader is looping through apps to upgrade, it sees Chat's UPGRADE files but not the files it needs to run Chat, so I just downloaded Chat from the Client Area and uploaded those files to /applications/chat/ and clicked "Retry?" on the upgrader and it continued the upgrade. :)

Not sure if this is a bug or unintented user behaviour but that's how I fixed it anyway. 

If you need the technical info, the upgrader looks for /application.json in each of the applications directories.

			if( file_exists( \IPS\ROOT_PATH . '/applications/' . $app . '/data/application.json' ) )

If it can't find one it throws the missing_app_data error.

				try
				{
					\IPS\Log::i( LOG_ERR )->write( "Error: Missing app data", 'upgrade_error' );
				}
				catch( \RuntimeException $e ){}
				throw new \LogicException( 'MISSING_APP_DATA' );

As the delta upgrade package only contains those files necessary for the upgrade, rather than the entire suite, the error is thrown when upgrading from RC7a to 4.0.0 becauseI personally didn't have the Chat (I don't think it was available as an RC) application files, and thus, no application.json.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...