Jump to content

RPG-support

Members
  • Posts

    2,742
  • Joined

 Content Type 

Profiles

Downloads

IPS4 Providers

Release Notes

IPS4 Guides

IPS4 Developer Documentation

Invision Community Blog

Forums

Store

Posts posted by RPG-support

  1. Confirmed bug report here, this issue is pretty complex and can't be solved with patches. Fix will be included in v3.0.2 but I'll need to spend quite a bit of time making sure there is backwards compatibility. As I'll likely need to store the extra videos differently.


    I tested by adding the title in Russian language. It was also not working by adding in English and then changing the title to Russian.
  2. Confirmed bug, patch below. Once it's fixed in v3.0.2, it will use the charset you set in your settings instead.

    Open admin/applications_addon/other/videos/sources/mediaPlugins/youtube.php

    Find:

            require_once( IPS_KERNEL_PATH . 'class_xml.php' );
            $xml = new class_xml();

    Replace With:


            # Get xml class
            require_once( IPS_KERNEL_PATH . 'class_xml.php' );
            $xml = new class_xml();
            $xml->doc_type = "UTF-8";

    Save.


    I have changed in the same way here:
    admin/applications_addon/other/videos/sources/mediaPlugins/youtubeshort.php
    admin/applications_addon/other/videos/sources/mediaPlugins/vimeo.php
    admin/applications_addon/other/videos/sources/mediaPlugins/youtube.php

    The problem has gone now.

    I do not know if something similar should be done for the:
    vine.php
    twitchtv.php
    justintv.php
    facebook.php
  3. Sorry just to clarify, it's always been adding the video but now since the edit it's redirecting to the video page?


    Yes, I see the added video page and can play the video now.

    I do not see the video itself sometimes after submit. After refreshing the page (Ctrl + F5) the video is appearing. But this is not always. And I think that this is my server or browser issue. But you can think about this also. I am using Chrome and adding the links from YouTube generally.
  4. no sites make use of torrents unless they are specifically set up as a P2P file sharing community.

    That's not true at all. I can think of religious organizations, educational organizations, home video/audio/electronic books users ( (w00t) ) and more that use torrents. Torrents are widely understood concepts - everyone wants to share the content or write some thoughts. Present IPS products simply miss this idea and pushing users to use out of date conceptions, like IP.Gallery and IP.Donwloads and this out of date apps. are not advanced in the functionality. So, I did not see any IPS products based comunity where this applications are popular. You have IP.Board empire as this is the only product which is still popular. But as I said above the time of the general forum concept is somewhere in the 2005-2007s - it's not a bad idea, it's just dying.

    ;)
  5. f you don't believe me, go through the Terms of Service pages of some popular shared hosting websites.


    You may find a lot of VDS with no such limitations in Ukraine, Russia, China, Pakistan, etc. China, for example, do not have copyright laws at all.

    IPS products are resources intensive and generally are not usable on shared hostings.
  6. Thank you for all yours non-positive replies.

    Virtually no sites make use of torrents unless they are specifically set up as a P2P file sharing community.


    No sites make use of IP.Gallery unless they are the paintings/photos galleries. No site make use of IP.Blog unless they are blogs. Etc. But you are selling all this addons.

    I will wait the market push you to produce something new.

    People visit torrent-trackers more than simple forums.

    Make the posibility to modify the IP.Board to make it the dedicated torrent tracker and you will sell more. Simple forums are dying. Give the second life to your products which all have new code but all based on very old ideas.

    I still have positive mood and want IP.Torrents. ;)

  7. Obsolete because there is the 2013 year and there are torrents. If you want some statistics of popularity, visit the PB.

    I am sure I will not hire anyone. I will check if there are out of box solutions.

    May be IPS do not want to be associated with torrents since there are many pirates nowadays. But old solutions are not working any more. We are waiting torrent tracker from IPS.

  8. By the way, Ivan! I've just purchased your translation and installed it successfully, but I experience charset issue when importing (quick add) videos from YouTube. Just get '??????' chars instead of russian chars. Any idea how to fix?

    I am confirming this bug of the product. This is not the issue of the language pack.

    I has not noticed this before because I am not using quick adding.

    Testing video is attached.

    PS. Seams to be that author may want to investigate the program code for possibility of this issue in other places. It should be checked everywhere where it is possible to improt or manualy add non-latin characters

    20130812_1827_42.zip

  9. By the way, Ivan! I've just purchased your translation and installed it successfully, but I experience charset issue when importing (quick add) videos from YouTube. Just get '??????' chars instead of russian chars. Any idea how to fix?


    1) You need to have the data base connection in utf-8:

    conf_global.php
    $INFO['sql_charset'] = 'utf8';

    2) You need to have data base in utf8_general_ci

    6GcDd.jpg

    AND db tables content in UTF-8.

    To be sure that the data base tables content in UTF-8 you may need to use special converter to convert the data from windows-1251 (or any other) to UTF-8.

    3) You need to set language settings to UTF-8
    Xcgls.jpg

    4) Check if server setting is UTF-8
    rbWh4.jpg

    5) You may need to add to the .htaccess
    AddDefaultCharset utf-8

    6) You may also need to reinstall the IP.Board and all its applications using the following settings.
  10. So, then where "delete" button should be located? (logged as admin now). Also I just found now that beeing even logged in as admin I can't even edit videos added by other members :sad: Mb I've not configured app well enough?

    attachicon.gifvideos.png

    You need to manage groups permissions for this application.

    H1mv6.jpg

×
×
  • Create New...