Jump to content

Table missing after character set upgrade

Recommended Posts

So I have recently taken over a forum as webmaster as the old one has just disappeared on us, Not got a lot of experience with forum software etc so please bear with me. On the admin CP it recommends updating the character set from UTF8MB4 to a different version of UTF8. I set that upgrade going last night and after a few minutes it looked like it got stuck. I left it so I wouldn't break anything and it come up with a 500 error. Sorry I didnt save the exact error for some reason. Closed the browser and reopened the forum and all was still fine up the upgrade was still recommended so had failed.   I logged on to the back end I noticed that a lot of things were out of date too or will be very soon so I took a "backup" and started work on updating mysql the back end software and php. That all went fine with no issues. Rebooted the server, logged onto the forum and the adminCP and all was working fine. Went onto the support section and the character set was still recommended at being changed, so I gave it another go and this is where it all went wrong.

Got the same error as before. Think it was a gateway error?! Ok so I restarted the browser again and opened the control panel. looked at the support and this time it said there was an issue with one of the tables and offer to fix it. I let it fix it and it failed and gave me the following error:


SELECT *, INSTR(',1,0,', CONCAT(',',template_set_id,',') ) as theorder FROM `ibf_core_theme_templates` AS `core_theme_templates` WHERE template_set_id IN (1,0) AND template_app IN ('forums') AND template_location IN ('front') AND template_group IN ('index') ORDER BY template_location, template_group, template_name, theorder desc
IPS\Db\Exception: Table 'greg_IPB.ibf_core_theme_templates' doesn't exist (1146)
#0 /home/greg/public_html/forum/system/Db/Select.php(373): IPS\_Db->preparedQuery('/*IPS\\_Theme::g...', Array, true)
#1 /home/greg/public_html/forum/system/Db/Select.php(436): IPS\Db\_Select->runQuery()
#2 /home/greg/public_html/forum/system/Theme/Theme.php(3299): IPS\Db\_Select->rewind()
#3 /home/greg/public_html/forum/system/Theme/Theme.php(2521): IPS\_Theme->getRawTemplates(Array, Array, Array)
#4 /home/greg/public_html/forum/system/Theme/Theme.php(785): IPS\_Theme->compileTemplates('forums', 'front', 'index')
#5 /home/greg/public_html/forum/applications/forums/modules/front/forums/index.php(196): IPS\_Theme->getTemplate('index')
#6 /home/greg/public_html/forum/system/Dispatcher/Controller.php(96): IPS\forums\modules\front\forums\_index->manage()
#7 /home/greg/public_html/forum/applications/forums/modules/front/forums/index.php(52): IPS\Dispatcher\_Controller->execute()
#8 /home/greg/public_html/forum/system/Dispatcher/Dispatcher.php(152): IPS\forums\modules\front\forums\_index->execute()
#9 /home/greg/public_html/forum/index.php(13): IPS\_Dispatcher->run()
#10 {main}

Tried doing a repair of all the databases on the backend and even rebooted a couple of times but still get same error. If you click the try again button under the error you then get this error message:



We're sorry, but a temporary technical error has occurred which means we cannot display this site right now.

Table 'greg_IPB.ibf_core_theme_css' doesn't exist

You can try again by clicking the button below, or try again later.



That clearly wasn't going to work so the only thing I could think of was to restore from the backups. Turns out the backups had been failing... Another issue to look at. No wonder the last webmaster decided to bugger off. So it appears I have a couple of tables missing and no backups and a repair doesn't work either.

Oh Brother Reaction GIF by reactionseditor


So I am kinda stuck in a pickle and no idea what i can do to fix this. The forum is currently down since 2am BST last night so about 10 hrs so far. 


Anyone have any idea where I can go from here?]




Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...