Jump to content

Xcache is only caching variable(DB) not php

Recommended Posts

Problem: Xcache is not caching php, only variable DB information.


Intel® Xeon® CPU E5620 @ 2.40GHz
-Running as VPS with 1 core with 2.0Ghz allocated.
-1376MB Ram
-60GB harddisk
-Currently without Xcache fuly working using about 500mb of 1376mb Ram

Relevent Software Settings
Running under WHM /w Apache
PHP5 running mod_php (DSO) as a PHP handler

Xcache 1.3.2 is installed an enabled

Xcache snapshot from info.php http://


Global configuration file is set to using
$INFO['use_xcache'] = '1';

Xcache Admin panel evidence of not caching php from IPboard:




I'm completely stumped Could this be a permissions /directory issue?

I did attempt to create the cache directory (that according to the php.ini is set to /tmp/xcache, although i didn't see an xcache folder?)

so I attempted to create it and I got an interesting problem:

my process
mkdir /tmp/xcache
chmod 0777 /tmp/xcache

however once I do that and restart apache I received the following error by IPB.

Warning: xcache_isset() [function.xcache-isset]: xcache.var_size is either 0 or too small to enable var data caching in /home/mazda626/public_html/ips_kernel/classCacheXcache.php on line 95

I then removed that /tmp/xcache directory and restarted apache to get the site baaack live and working (as I don't want significant downtimes)

I have been going back and forth all morning with my managed host trying to resolve the issues, any ideas?

Link to comment
Share on other sites


Locate your php.ini

manfind php.ini

To me I would say your master php.ini has the value set to 0, Look for the line:


If you do not have such thing, Add the line in the xCache settings:


Then restart apache.

Hope this helps.

ps: run this:

chmod 777 /tmp/xcache/*

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...