Jump to content

Community

(e) Eric

Members
  • Posts

    949
  • Joined

  • Days Won

    1

 Content Type 

Profiles

Downloads

IPS4 Providers

Release Notes

IPS4 Guides

IPS4 Developer Documentation

Invision Community Blog

Forums

Store

Everything posted by (e) Eric

  1. The last thing would be to check permissions. Check and save and uncheck and save all the permissions in that block's permission matrix. Also there is a general On/Off config under Custom Sidebar Blocks settings. If none of that works, I would recommend uninstalling and reinstalling. Because your hook wasn't installed/enabled by default and that you had to do manual database recovery, who knows what the actual cause of the problem. So manually save any block contents you need and start over.
  2. New Version: 1.1.0 What's New in Version 1.1.0 (See full changelog) Updated to work with IPB 3.4+
  3. New Version: 1.1.0 What's New in Version 1.1.0 (See full changelog) Updated to work with IPB 3.4+
  4. I don't have much free time at the moment but it is on my list of things to tackle. Parsing posts and editor issues are my Achilles heal when it comes to IPB stuff, I wish it was a simple API call but for some reason its weird. Again, I would recommend turning off the fancy editor and just use the basic text box if you are doing lists (and just do them in HTML).
  5. Make sure the Custom Sidebar Blocks hook was also installed and enabled under Manage Hooks. Do any of your sidebar blocks show? That screenshot makes it look empty, so unless you've disabled all of the stock ones, that might be a bigger issue than just CSB.
  6. Sorry, missed this post. Is it still not working for you?
  7. hmm, I made a test block on my site and I was able to resize the width of the video. Its currently set to 150: <object type="application/x-shockwave-flash" height="151" width="150" id="live_embed_player_flash" data="http://www.twitch.tv...nnel=MyUsername" bgcolor="#000000"><br /> <br /> <br /> <br /> <br /> <br /> <param name="allowFullScreen" value="true" /><br /> <br /> <br /> <br /> <br /> <br /> <param name="allowScriptAccess" value="always" /><br /> <br /> <param name="allowNetworking" value="all" /><br /> <br /> <br /> <br /> <br /> <br /> <param name="movie" value="http://www.twitch.tv...mbed_player.swf" /><br /> <br /> <br /> <br /> <br /> <br /> <param name="flashvars" value="hostname=www.twitch.tv&channel=iflysimx&auto_play=true&start_volume=25" /><br /> <br /> <br /> <br /> <br /> <br /> </object><br /> <br /> <br /> <br /> <ahref="http://www.twitch.tv/iFlysimX" class="" style="padding:2px 0px 4px; display:block; width:250px; font-weight:normal; font-size:10px; text-decoration:underline; text-align:center;">Watch live video from iFlysimX on www.twitch.tv</a>
  8. This app simply extends the frontpage index (and the portal) and doesn't have the mechanisms to inject itself elsewhere. You would need another third-party app to show sidebars on other pages, then figure out a way to integrate CSB with it. :)
  9. The upgrade instructions should be listed in the README. But it is just like usual, download the latest, unpack, upload, and follow the upgrade instructions in ACP.
  10. I've updated the app to work with 3.4+ and uploaded it to emoneyCodes.com. After a bit if there are no issues I'll upload here. :)
  11. I've updated the app to work with 3.4+ and uploaded it to emoneyCodes.com. After a bit if there are no issues I'll upload here. :)
  12. Is this being released on IPB 3.4.X?
  13. No one has complained and its working on my site, so it should be good to go. :)
  14. That isn't possible without some sort of code moficication to the source files, plus extra settings, etc. This app only works on the default index sidebar. So it doesn't integrate with 3rd-party things like sidebars on every page or in your case sidebars for topics. You would need some custom work done for that to work probably. Here are 3 different ways to sort custom blocks, perhaps that will help: http://emoneycodes.com/forums/topic/344-ways-to-sort-custom-sidebar-blocks/?hl=sort The portal page is different from the main index, and so it is more rigid with block placement. When I say "return" I am being technical and am referring to how a function "returns" a value. I believe you are using "return" in a more colloquial way, as in, you'll send (return) html to the browser. The way it's setup, it already is in php mode so no opening and closing tags are required (and actually it errors if you do use them). The way you return the html, is by pretending the box is simply the inside of a function, and so you use the bulk of the function to build some html object and then return it at the end of the function. Echoing or printing a value doesn't return anything, and instead perform "side-effects". So imagine that my implementation of PHP is that the custom sidebar php box that you fill in is a function called "getHTML()" and Custom Sidebar Blocks calls "echo( getHTML() )". So it wouldn't make sense to echo it twice, once in the call to the function and once in the function itself. So instead of typing: echo "Hello World!"; You need to write: $someHTML = "Hello World!"; return $someHTML; Let me know if that doesn't make sense. I think I go into more detail on my site if you want to browse the FAQ/tutorials. I believe you can do that with these steps: http://community.invisionpower.com/resources/documentation/index.html/_/tutorials/content/embedding-blocks-within-other-php-blocks-r300
  15. Anything you can do in html (and perhaps PHP) this app can do. So if you have some html/javascript that can get rss and images from a site, and display it, post it in the block and enabled RAW mode and that should work. :)
  16. Looks like TB is just as swamped as I am: http://community.invisionpower.com/topic/350317-download-tb-group-format/?p=2374646
  17. Try asking the author of the Topic Hover mod.
  18. Double check that you updated to the latest version of CSB properly. It should work with 3.3.4. This is free, btw. :) The editor doesn't play nice sometimes. If you are experiencing that, you might want to disable the fancy editor in settings and just use a blank box. Not at present, but interesting idea! I've still never used an IP.Content block as a CSB block, so I dunno, but MarcherTech is my go-to guy for CSB+IPC related queries. All I know is what he tells me. Perhaps I'll have a try soon. No, this only modifies the index sidebar, it doesn't touch elsewhere. You would need to modify the html template or actually probably the css. It isn't directly related to Custom Sidebar blocks since CSB simply follows the same width that the default blocks/sidebar use. So search the forums for others who have done that. :) I'm guessing that's an issue with the default sidebar in general, not Custom Sidebar Blocks. Let me know if I'm wrong. Sorry, I've been super busy with my last semester of school. One of these days, perhaps Spring Break. For now, I would recommend using html entities directly and turning on HTML/RAW mode. It might be a bit more work at first, but you don't have to worry about the fancy editor issues.
  19. My first guess would be that it is a server issue or something other than this plug-in, as I've never seen or heard about such an issue with it. Let me know if you end up thinking it is this plug-in and I'll have a look.
  20. Glad you got it sorted! Yeah, just waiting on Terabyte to update Group Format and then I'll steal borrow the hook like I did before.
  21. Hmm, I'm not sure what you mean. Post the code you are using for that block's contents.
  22. I replied to your other post on my site already so lets continue the conversation there. :) It is your use of: <span rel='lightbox'> ... </span> So remove that and it should be fixed. :) Please elaborate. :)
  23. Yes, I just sold a Donator package on emoneyCodes.com which is running 3.4.1 just the other day. :)
  24. Thanks Demon, and glad it's all sorted now gbarto! :)
  25. Ah, those are PHP warnings and so they are't overly critical. But after doing some searches here I found the reason is because some of those template hooks are overloading functions whose parameters have changed, hence the warnings. I can't attach files here, so go here and download/import the updated hook and post if the logs stop: http://emoneycodes.com/forums/topic/279-e32-points-per-name-style/?p=3181
×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy