Jump to content

Community

Alex

+Clients
  • Content Count

    9,350
  • Joined

  • Last visited

  • Days Won

    3

 Content Type 

Profiles

Downloads

IPS4 Documentation

IPS4 Providers

Release Notes

IPS4 Guides

IPS4 Developer Documentation

Invision Community Blog

Forums

Posts posted by Alex


  1. I am of the opinion that it's up to you as a site owner to make sure you comply to local laws. If IP.Board implements this cookie law for example, what would stop some customers from another country demanding that their laws are adhered to? Things like this, and COPPA (which is another silly law) compliance are definitely up to the site owner :smile:

    Just do what the BBC and the majority of major UK sites I have seen use, put a small banner at the top that says along the lines of "By using this site you agree to us storing cookies, leave now if you do not wish to". IP.Board wouldn't have stored anything by that point.


  2. Haven't heard back from AH Modding for a while either.

    Anyone have a fix to this issue?

    For whatever reason the Wordpress password syncs up fine to the IP.Board password, but NOT the password to change your display name. Users get an error saying that their password is not correct when even when it is.

    The workaround I've found is to reset the wordpress password for the user and then let them change it. Then for some reason the "change display name" password syncs up fine.

    I'll look into that this weekend, but the passwords can only be synced if they manually log in to IP.Board or WordPress (in other words, they don't use the automatic SSO) - SSO itself won't transfer passwords due to them being unreadable as hashes.

    There's no reason to say why this won't work on 3.4.0 but I will be testing it with the new WordPress release this weekend and get back to you.



  3. Yes, I found this pretty confusing as well. First this leaves the admin puzzled about what has gone wrong.

    And when you find out you first need to go trough a mass of permission settings to make it show up. I have 400 forums, 70 gallery categories, 232 download categories, and 23 usergroups. So that is a significant amount of work for an import. Especially if you need to test imports several times. I've done my 5th test import so far.

    And if you have a large number of forums, like big boards do, it turns out to be impossible to adjust all settings. So even if you go trough all forum permission settings, only part of them are changed.

    While usergroup permissions in IPS are not as granular as in vb, I still think that they should be imported. This would make life easier.

    I am currently stuck on various bugs, and need to wait for fixes until I can continue testing the converter.

    There are technical reasons why we can't convert the permissions. What other bugs are you stuck on? I personally converted 4 forums yesterday after our most recent patch and they all went smooth (XenForo, vBulletin 4, Kunena, and a PHPBB board)


  4. Please redownload the converters - there was an issue that caused the links to not work. If you setup a conversion and make sure you don't tick 'merge' on vBulletin, it will also work. Either way download the new build.

    Also, from what you have explained you shouldn't be checking 'Merge' on the conversion setup as you are not merging two or more forums into IPB.

    Boards not showing up isn't a bug - we cannot convert permissions from any forum software, it's something that you have to do post-conversion.


  5. Hm, the package doesn't contain the right query - I'll get that updated first thing in the morning. For now you can run these two and it should get you running.

    ALTER TABLE conv_apps MODIFY app_merge TINYINT(1) NOT NULL DEFAULT 1;

    UPDATE conv_apps SET app_merge=1;


  6. Is the converter released yesterday with IPB3.4 the version which keeps ID?

    Thanks

    Yes it is, though that specific change only applies to vBulletin conversions at this stage, we can roll it out to others with ease if requested but vBulletin is where we see the bulk of the very large forums coming from.



  7. http://community.inv...p?app=languages

    I'm confused 'cause in the top contributors that states there is a different number of contributions for each member.



    It's totally impossible. Each language has the same number of strings, then why the german language pack has have than 9654 strings?


    Can you please clean this mess? There is a big mess that must be cleaned. If there are totally 7000 lang strings, recount the number of


    strings and "remove" the old-strings that are not in used anymore.



    People are looking for a clean translation , which has the same number of strings for each language pack.



    Hope this will be fixed soon..




    I think you're reading way too much into a number which just gives a bit of credit to the contributors. You make a change to a language string, you get a 'commit' added to your account. People that have more have worked on more than one language pack. As for why yours isn't showing 7000 I don't know, but I don't think its the best use of anyones time to see why you don't have 7000 showing under your account?

    The language pack is complete, and you have credit on 99.9999999% of that pack, that's all that matters surely? :)

  8. An update has been pushed out to this hook: http://community.invisionpower.com/files/file/4349-wordpress-sso-login-integration/

    New in 1.3.0: SSO and Login Authentication is now separated. What does this mean? SSO is the part of the hook which automatically logs you in to the account if you are logged into WordPress, or vice versa. If you don't want this functionality, you can now turn this part off but still allow users to login via the login forms. 1.3.0 now fully supports the IP.Board 3.3 series.

    Changelog

    • IP.Board 3.3 SQL error on installation fixed.
    • Now supports IP.Board 3.3.3.
    • SSO and Logins have been separated so you can turn one or the other off at any time, this fixes issues with sites on multiple domains.
    • Change Display Name in IP.Board now fixed.

  9. 29th May 2012
    The converters have been updated, including fixes for:

    • Redirect scripts showing an IP.Board 404 error have been fixed
    • Redirect scripts updated to support redirecting archived posts (FusionBB/vBulletin)
    • Posts showing up as soft deleted instead of unapproved (vBulletin)
    • Login fixes for Kunena, phpBB, and XenForo
    • Various other fixes




  10. A quick update to this:



    Just see this happen here again multiple times when editing strings on a page (not all strings of a page)



    This bug not always occur, but I can not see a schematic when it happens...



    I only know: I'm not changed the (translated) strings (with umlauts) and it marked as changed.




    With all due respect, I have been working on other things as well, and the bug you are reporting is hardly show stopping, it doesn't stop you being able to translate or download packs, it just marks a few strings as updated due to the symbols - on the grand scale of things I'd say that was a pretty low priority bug.

    I'll look at these, but these are all relatively minor problems.


  11. We have posted here on this topic a lot of other issues - not only IP.Board specific...



    E.g.:[list=1] [*]"Untranslated Text" does not work[/list]



    Fixed.

    "Outdated Text" does not work



    Fixed.

    Search does not work and/or we can not search for "keys" which is essential



    Search is working for me - it may have been fixed by me sorting the other things out though.

    If a member change a translated string to a new one, the number of "contributions" on the old translator of the string doesn't change (e.g. if member A translated 10 strings and member B changed all 10 strings member A have still 10 contributions)



    Not a bug, if someone comes along and updates all the translations we don't want peoples previous contributions to be forgotten about, seems wrong to remove them.

    If you save a page all strings with special umlauts/special characters (like ü ö ä) show as changed ("A minute ago"), although you have not changed anything



    Cannot reproduce.



    Fixed.

    Special characters shown not as html in the translation area



    Not too sure what you mean here, special characters seem to be displaying fine for me.


  12. Why does my language pack have 93%? everything is "100%" completed.



    System - 100% completion


    Forums - 100% completion


    Members - 100% completion


    IP.Blog - 100% completion


    Downloads - 100% completion


    Gallery - 100% completion


    Calendar - 100% completion


    Chat - 100% completion


    Content - 100% completion


    IP.Nexus - 100% completion



    08 in March since the last post was made by IPBSupport.de and we still don't see that feature work properly.




    This was fixed, the reason it happened was because the main progress bar looked at *all* language strings, and there were 800 strings that hadn't been translated into Hebrew - turns out this was due to IP.Tracker, sorted that and you now show at 100%.

  13. 18th January 2012
    The converters have received a maintenance release to rectify issues with XenForo forum passwords for customers who initially converted from vBulletin to XenForo, before converting to IP.Board.

    The update includes numerous bugfixes for the other supported products as well.



  14. 92% completion in Hebrew but it's not the correct information.


    Look at this page:


    http://community.inv...age&language=11

    System Tab notes 98% completion but doesn't have blank strings.


    Gallery 0% completion [color=orange](913 strings out of date)[/color]


    How? Gallery has some new strings that I don't even know what they are?




    92% is correct then, 92% is an average with System having the biggest effect on that percentage because it has the most strings. Seems the Gallery import went a bit iffy if it's saying they're out of date. I'll see why Gallery is playing up.

    As for the 98% completion issue - there are several untranslated strings, we'll get that area sorted ASAP though.
×
×
  • Create New...