Jump to content

Foxtrek_64

Clients
  • Posts

    14
  • Joined

  • Last visited

 Content Type 

Profiles

Downloads

IPS4 Providers

Release Notes

IPS4 Guides

IPS4 Developer Documentation

Invision Community Blog

Forums

Store

Everything posted by Foxtrek_64

  1. I'm getting this error when updating from 1.4.0 to 1.4.1 using the marketplace tab in my acp: Extraction from phar "/tmp/IPSMPWgrC4w.tar" failed: Cannot extract "Application.php" to "/var/www/html/applications/form/Application.php", setting file permissions failed I contacted Invision support and they said to contact the plugin developer. This is what permissions look like: [root@lfp-rrweb form]# ls -lah total 12K drwxrwxrwx. 11 root rrweb 160 Sep 1 2020 . drwxrwxrwx. 7 root rrweb 89 Sep 1 2020 .. -rwxrwxrwx. 1 root rrweb 4.6K May 18 08:21 Application.php drwxrwxrwx. 2 root rrweb 4.0K Sep 1 2020 data drwxrwxrwx. 4 root rrweb 49 Sep 1 2020 extensions drwxrwxrwx. 2 root rrweb 85 Sep 1 2020 hooks drwxrwxrwx. 2 root rrweb 24 Sep 1 2020 interface drwxrwxrwx. 4 root rrweb 50 Sep 1 2020 modules drwxrwxrwx. 11 root rrweb 183 Sep 1 2020 setup drwxrwxrwx. 5 root rrweb 61 Sep 1 2020 sources drwxrwxrwx. 2 root rrweb 24 Sep 1 2020 tasks drwxrwxrwx. 2 root rrweb 26 Sep 1 2020 widgets I would think I wouldn't run into any permissions issues like this, but apparently so. Any suggestions on where I should look or what I should change to fix this issue?
  2. I ran into this issue earlier today. In my case, I had logged in to the marketplace with the forum admin account, then attempted to do so with my personal account. Once I disconnected my invisioncommunity account from the forum admin account, I was able to connect it to my personal account without issue. Not sure if this case applies to you but I thought it'd be worth sharing.
  3. Good catch, @Nathan Explosion. Setting the truncate type to hide and then getting the full content resolved the issue. Thanks!
  4. I have tried using both 'hide' and 'none' as values. After saving and refreshing, I can see the new value when inspecting the html, however there does not seem to be a change in behavior.
  5. I have a custom page which displays an announcement database I have built (separate from the built-in announcements system). This database syncs with an announcements board where users may post comments. I am using the Category Articles template to display my announcements but I am not happy with how the truncation is working. By default, the template renders the data like so: <section class='ipsType_normal ipsType_richText ipsType_break ipsSpacer_bottom' data-ipsTruncate data-ipsTruncate-size='7 lines' data-ipsTruncate-type='remove'> {$record->truncated()|raw} </section> I would theorize that the data-ipsTruncate-type is what determines how the truncation is handled, though I am unsure what other values are valid here. The current truncation effect seems to be doing two things: Shorten to seven lines maximum - this I am fine with. Remove all formatting - this breaks content such as lists, and I would like to avoid this. I have looked through the database settings but I was unable to find anything that affected this by default. Did I miss something in the options that would resolve this? If not, how can I change this to behave the way I would like it to. Is there any developer documentation available for review so that I can see the what these properties control and what their values are?
  6. As an amendment to my issue, this seems to only affect the Checkbox Set type of question. Changing this to a Select Box with the Multiple Values option turned on causes the field toggle system to work as expected, however in my mind the select box is less intuitive for nontechnical users.
  7. Hoping this one can be answered by one of the devs out there who play with CSS on a regular. I have built a custom contact page that uses the forum css classes to produce sections with links. One such section, where I've been having an issue, looks like this: https://cdn.discordapp.com/attachments/468748717684686868/771564822621323306/unknown.png Specifically, I have two questions. Firstly, is there a CSS class that would solve the alignment issue with the information section at the top, and one that'll add in a dividing line between that and the first item? Secondly, when compared with the title on the actual forum, the title entry is too small. The HTML I'm using, for reference, looks like this, content omitted: <ol class="ipsList_reset cForumList"> ... <li class="cForumRow ipsBox ipsSpacer_bottom ipsResponsive_pull"> <h2 class="ipsType_sectionTitle ipsType_reset cForumTitle">Copyright Claims (DMCA)</h2> <div class="ipsDataItem_meta ipsType_richText"> <h3>What is the DMCA?</h3> <p>The Digital Millennium Copyright Act (DMCA) creates a standardized process for copyright holders to ask LuzFaltex to take down infringing content. You can find more information about the DMCA at the <a href="http://www.copyright.gov/" target="_blank">U.S. Copyright Office's official website</a>. For more information on how LuzFaltex handles DMCA request, please read our <a href="#">DMCA takedown policy.</a></p> <p>As with all legal matters, it is always best to consult with a professional about your specific questions or situation. We strongly enourage you to do so before taking any action that may impact your rights. Our guides aren't legal advice and shouldn't be taken as such.</p> </div> <ol class="ipsDatList ipsDataList_large ipsDataList_zebra ipsList_reset"> <li class="ipsDataItem ipsDataItem_responsivePhoto ipsClearFix"> <div class="ipsDataItem_icon ipsDataItem_category"> <span class="ipsItemStatus ipsItemStatus_large cForumIcon_normal"> <i class="fa fa-gavel"></i> </span> </div> <div class="ipsDataItem_main"> <h4 class="ipsDataItem_title ipsType_large ipsType_break"> <a href="...">Submit a DMCA takedown notice</a> </h4> <div class="ipsDataItem_meta ipsType_richText">If someone else is using your copyrighted content in an unauthorized manner on the RavenRock RP website or its affiliated sites, click here to submit a DMCA takedown notice and request that the infringing content be changed or removed. Before you begin, please read LuzFaltex's <a href="...">guide to submitting a takedown notice</a>.</div> </div> </li> <li class="ipsDataItem ipsDataItem_responsivePhoto ipsClearFix">...</li> </ol> </li> ... </ol> In the standard forum, the title of the forum entry is styled with cForumList ipsDataItem_title. Here the setup is identical as far as layout, but that combination doesn't seem to be detected by the CSS engine. Is this some sort of typo that I'm just not seeing or is there another issue going on here?
  8. @Michael.J Any ideas on this?
  9. I was able to get it with modifying the template. I'm not unfamiliar with template modifications, but I was trying to figure out if I could do it with the built-in copyright text system.
  10. Through the ACP. I'll do it through the templates. That seems the easiest option here.
  11. Hi Ryan, Thanks for the response. Unfortunately this also renders as raw text. Copyright line text: Copyright ©️ LuzFaltex, LLC 2014-{expression="date('Y')"}, all rights reserved Rendered text: <span id="elCopyright_userLine">Copyright ©️ LuzFaltex, LLC 2014-{expression="date('Y')"}, all rights reserved</span>
  12. Hello, I'm trying to get the copyright line to display the current year. Copyright ©️ LuzFaltex, LLC 2014-<?php echo date("Y"); ?>, all rights reserved <span id="elCopyright_userLine">Copyright ©️ LuzFaltex, LLC 2014-<!--?php echo date("Y"); ?-->, all rights reserved</span> I have also tried using template syntax, but this just gets rendered raw. <span id="elCopyright_userLine">Copyright ©️ LuzFaltex, LLC 2014-{{date("Y")}}, all rights reserved</span> I tried searching for this copyright line in the templates, but neither the global nor footer templates have any mention of this. The footer template ends with the "Contact Us" link and the global template just references the footer and then moves on to javascript. Is there a way that I can do what I'm trying to accomplish here or do I need to just opt for no copyright line and then create it myself manually by modifying the footer template?
  13. My field toggles don't seem to be working. I have a Checkbox Set field named "Contact Type" under which I have this field toggle configuration: When viewing the live form, all fields are visible even when I do not have any options selected. Did I misunderstand the purpose of form toggles or is this just not working correctly? My intent was to have these fields hidden until the user tells us what kind of contact options they want us to use, then to have those fields appear so they can supply the relevant information.
  14. I'm asking here because perhaps I'm just missing the option for this. In my community, we have a mixture of staff- and player-run events. I have an events board in my forum, segregated by whether it is a staff- or player-run event. Players use this board to post details about the event including its time, in-game location, whether it's an open or closed event, and so forth. They also add one of four tags: upcoming, postponed, completed, or canceled. I would like to tie this in to the calendar system so staff and player events appear on the calendar. I don't really care which direction this integration takes (calendar to forum or forum to calendar), just that posting in one place makes the event appear in both places. I could instruct users to create a calendar event and merely provide a link to the forum thread in the event description, however this feels like a sloppy approach and still requires managing things like RSVPs and cancelling or updating the date and time separately. What are my best options for this?
  15. Hello,

    I was looking at purchasing your Chocolate theme but it seems it is no longer available for sale.

    Do you plan to restore this theme?

    Fox

×
×
  • Create New...