Jump to content

Community

DreamOn

+Clients
  • Posts

    70
  • Joined

  • Last visited

 Content Type 

Profiles

Downloads

IPS4 Providers

Release Notes

IPS4 Guides

IPS4 Developer Documentation

Invision Community Blog

Forums

Store

Everything posted by DreamOn

  1. Yes... Looks like IPS team doesn't want us to develop plugins...
  2. Thanks for the idea, but what a disaster for a developer... We should just have to do a git clone from our IPS plugin repository and let's go, why it is so complicated with IPS... Seriously... This is not how things should be done.
  3. How do you deal IPS plugins with git? Even if I had the XML file, I should import plugin in ACP with XML file, copy/paste files from source to override files imported from XML and change all class names like this: class hook50 extends _HOOK_CLASS_ { Because when we import a plugin from XML file, hook numbers change and we need to change class name. How is it possible that it is done like this?
  4. I no longer have the XML file unfortunately but I have all folders and files in my Git repository. Is it possible? It's amazing that IPS can't read PHP files from folder. Any PHP app can do this. Developing with IPS is really a horror.
  5. Hello everybody, I have created a plugin that I sent to a Git repository. I have installed a fresh new IPS install. How can I import my plugin from source? I put the plugin folder in plugins/ directory but it's not automatically detected. Thanks!
  6. Thanks, I send you a PM.
  7. In french, we need to use two words for negative sentence: Unfortunalety, I cannot define "ne", only "pas" because of only these language strings are defined: Can you set language string for previous word for others languages?
  8. I can't translate these strings:
  9. @Makoto I just purchased your Account Deactivation application, but it doen't work as expected: The mail "Your account has been reactivated" is empty The mail "Your account deactivation request has been completed" is empty When a member click on "Deactivate my account" button in email, he is redirected to the homepage without any message like deletion, the notification disappears very quickly. Then, he receives a empty confirmation email. When a member click on "Delete my account" button in email, he is redirected to the homepage with a notification message which leaves much too quickly. The member does not have time to see it. Then, he doesn't receive an email which confirm account deletion. Can you fix it? Thanks! Invision Community v4.5.4.2 No errors in System Logs/Error lgos Use french translation
  10. Thanks, I don't see this Filter by option because we use fluid view! It's OK, but it would be great if fluid view can have this option too, I don't know if they plan it!
  11. Hello, Is it planned to filter topics by solved/unsolved in search and in forums in the near future? It's to know if I'm developing my own plugin or if I'm patiently waiting 🙂 Thanks 🙂
  12. Up... Same problem here. Weird that no member of the IPS team intervenes here.
  13. Hello, I change to change friendly urls for Download app from https://domain.com/files to https://domain.com/download. I can change https://domain.com/files to https://domain.com/download but not the others URLs. When I want to set https://domain.com/download/file/id-?? or https://domain.com/download/categories, IPS keep files in URL : Can you help? Thanks!
  14. Thanks @Morrigan but unfortunately it doesn't work: And login as a moderator, he can see this:
  15. Thanks for help but there is no option for that. Under Members > Groups > Edit : Under Members > Staff > Moderators :
  16. Hello, As administrator, I create a blog entry and save it as a draft, it is not published to public. The members cannot see this blog entry, it's OK. But the moderators can see it, why? Can I disable this? I have searched in permissions in CP Admin but I didn't find anything. Can you help? Thanks.
  17. Thanks, just removed the template row in core_theme_templates and it works!
  18. Hello, Since IPS 4.5, I can not anymore download my plugin containing a widget. When clicking on download button, this error appears: OverflowException thrown with message "" Stacktrace: #6 OverflowException in /srv/www/community.site.com/current/web/ips/system/Theme/Theme.php:5038 #5 IPS\_Theme:addTemplate in /srv/www/community.site.com/current/web/ips/applications/core/modules/admin/applications/plugins.php:1995 #4 IPS\core\modules\admin\applications\_plugins:download in /srv/www/community.site.com/current/web/ips/system/Dispatcher/Controller.php:90 #3 IPS\Dispatcher\_Controller:execute in /srv/www/community.site.com/current/web/ips/system/Node/Controller.php:62 #2 IPS\Node\_Controller:execute in /srv/www/community.site.com/current/web/ips/applications/core/modules/admin/applications/plugins.php:48 #1 IPS\core\modules\admin\applications\_plugins:execute in /srv/www/community.site.com/current/web/ips/system/Dispatcher/Dispatcher.php:152 #0 IPS\_Dispatcher:run in /srv/www/community.site.com/current/web/ips/admin/index.php:14 The problem comes from the template file: my-plugin/dev/html/widgetName.phtml. When I delete this widgetName.phtml file, download is OK. Can you help? Thanks!
  19. @AutoItScript : could you share source code of the plugin on Github? Community can maybe take over
  20. Thanks for help. I just create a new version of the plugin, upload to the site and it works now. Very strange!
  21. Hello, I install new plugins but IPS doesn't load their CSS and JS files. I try to clear cache, desinstall/resintall the plugin without success. For example a plugin has one CSS file and one JS file which are not loaded. When I check the code source of the pages, the CSS and JS files of the plugin are missing. It works on a local env with IN_DEV enabled. Can you help? Thanks! --- EDIT 1 : for information, after installing the plugins, when I entered the custom parameters for the plugin, they were not taken into account. Also, the default parameters were not written in the text fields in the form settings of the plugin. I had to uninstall and reinstall the plugin several times for the settings to be saved. Strange --- EDIT 2 : the cAcpLoginBox_logo has mysteriously disappeared for a few days, I don't know if it's related.
  22. Thanks @bfarber. So I have to define function with unique name to prevent conflict with others plugins?
×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy