Jump to content
Matt
 Share


IP.Board 3.4.4 Editor Testing

The eagle eyed among you may have spotted that we've just upgraded our company forums to IP.Board 3.4.4.

We routinely do this during a development cycle so that we can get some extended testing prior to a beta release. When we write new features and fix bugs we do test ourselves but of course we can't replicate the testing hundreds of active users with all the different browser and operating system combinations can offer.

The focus of 3.4.4 has been to further stabilise the editor. We've made great improvements since the initial release of 3.4.0 but we're aware that there are a handful of issues remaining which we want to get licked for this release.

If you have a few moments spare, we'd appreciate it if you could test out the editor, either by creating a post in the test forum or just by being more aware of any quirks or issues when making posts normally.

Anything you spot, can you please report into our bug tracker with as much detail as you can.

Thanks!

 Share

Comments

Recommended Comments



The 'My media' box can only be closed by clicking 'finished'. This is inconsistent with all the other popups that have the little cross in the upper right to close the window. For me the cross in the upper right corner is the most intuitive if I want to close a pop up, but haven't used it.

Link to comment
Share on other sites

The 'My media' box can only be closed by clicking 'finished'. This is inconsistent with all the other popups that have the little cross in the upper right to close the window. For me the cross in the upper right corner is the most intuitive if I want to close a pop up, but haven't used it.

 

Please feel free to report any issues in our tracker. :)  We want to ensure nothing gets missed.  If it's not technically a bug, we will analyze the report and make a decision on a case-by-case basis.

Link to comment
Share on other sites

Don't forget everyone, clear your browser cache and do a hard refresh! 

 

Please feel free to report any issues in our tracker. :smile:  We want to ensure nothing gets missed.  If it's not technically a bug, we will analyze the report and make a decision on a case-by-case basis.

Link to comment
Share on other sites

Matt,

Have you cleared all these changes with Marcher ... heh heh heh ....

 

One question: what is that new symbol to the right of the word paste clibpboard?  Is that new? Or is it to specifically address the concerns of the Marcherites of the world?

Link to comment
Share on other sites

New editor just made me lose 80% of my post,
http://community.invisionpower.com/topic/375468-setting-up-ipb-nginx-mariadb-and-php-fpm/#entry2386551
 
Almost made me feel like this,
http://community.invisionpower.com/topic/381987-34-editor-buggy/#entry2383555
(I kid)
 
It cut off everything after my first code box. I'd submit a bug report, but it didn't replicate the issue in the second post I made. I'll fiddle around and see if I can figure out what triggered it.

Link to comment
Share on other sites

3.4.x will be the last branch before 4.0 (at least, that is our intention right now).  We cannot say which minor point release will be the last in the 3.4.x branch, however.

 

 

One question: what is that new symbol to the right of the word paste clibpboard?  Is that new? Or is it to specifically address the concerns of the Marcherites of the world?

 

That icon has been present for several versions now... :unsure: It allows you to set some personal preferences in the editor.

 

 

New editor just made me lose 80% of my post,
http://community.invisionpower.com/topic/375468-setting-up-ipb-nginx-mariadb-and-php-fpm/#entry2386551
 
Almost made me feel like this,
http://community.invisionpower.com/topic/381987-34-editor-buggy/#entry2383555
(I kid)
 
It cut off everything after my first code box. I'd submit a bug report, but it didn't replicate the issue in the second post I made. I'll fiddle around and see if I can figure out what triggered it.

 

Be sure you cleared your browser cache completely.  As our forums are behind Cloudflare, caching can be aggressive.  If you are able to reproduce the issue at all, please be sure to post a bug report with details.

Link to comment
Share on other sites

Be sure you cleared your browser cache completely.  As our forums are behind Cloudflare, caching can be aggressive.  If you are able to reproduce the issue at all, please be sure to post a bug report with details.

Reproduced:

http://community.invisionpower.com/resources/bugs.html/_/ip-board/344-editor-drops-entire-the-post-bellow-a-specific-type-of-code-block-r41730

 

This seems to be a caching issue like bfarber said. If you experience issues, be sure to clear your cache. To prevent any possible headaches now, I'd clear your cache just to be safe.

Link to comment
Share on other sites

That icon has been present for several versions now... :unsure: It allows you to set some personal preferences in the editor.

Great, now I discovered useful feature :lol: I needed something for plain text, I'm going to inform my members :D

Link to comment
Share on other sites

Full desktop style. Fresh install with no 3rd party skins or plug-ins. Still can't view the toolbar in Chrome for Android: (User Agent: Mozilla/5.0 (Linux; Android 4.2.2; Nexus 7 Build/JDQ39) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.166 Safari/535.19) Unless the user selects "Request Desktop Site" in the browsers menu pull-down. (User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.45 Safari/535.19 Stock Android Browser: same as above I happened to test with a Nexus 7, but it's not device specific. Opera: Works. Dolphin: Works. Firefox: Works. vBulletin 3.x/4.x/5 (also uses ckeditor) works. I take it this issue is not within the scope of this release? Also, why is the editor hidden on page display and then toggled by the user clicking in the square area? In other words why is it collapse by default?

Link to comment
Share on other sites

Full desktop style. Fresh install with no 3rd party skins or plug-ins. Still can't view the toolbar in Chrome for Android: (User Agent: Mozilla/5.0 (Linux; Android 4.2.2; Nexus 7 Build/JDQ39) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.166 Safari/535.19) Unless the user selects "Request Desktop Site" in the browsers menu pull-down. (User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.45 Safari/535.19 Stock Android Browser: same as above I happened to test with a Nexus 7, but it's not device specific. Opera: Works. Dolphin: Works. Firefox: Works. vBulletin 3.x/4.x/5 (also uses ckeditor) works. I take it this issue is not within the scope of this release? Also, why is the editor hidden on page display and then toggled by the user clicking in the square area? In other words why is it collapse by default?

 

We block the editor on mobile devices right now.  That's not a bug.

 

The editor is collapsed on display to reduce visual "noise" for the average user who is simply reading the page.

Link to comment
Share on other sites




Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...