Jump to content

tenaki

Members
  • Posts

    1,912
  • Joined

  • Last visited

 Content Type 

Profiles

Downloads

IPS4 Providers

Release Notes

IPS4 Guides

IPS4 Developer Documentation

Invision Community Blog

Forums

Store

Everything posted by tenaki

  1. Parse error: syntax error, unexpected '&' in /var/www/vhosts/httpdocs/forums/system/Theme/Theme.php(3904) : eval()'d code on line 17 Fatal error: Class '\IPS\Theme\class_content_template_for_block_' not found in /var/www/httpdocs/forums/applications/cms/sources/Blocks/Block.php on line 283 Got this error creating a new block, preview template The code below {{if !empty( $records ) }} <h3 class='ipsWidget_title ipsType_reset'>{lang="block_latest_records" sprintf="$database->recordWord( 2, TRUE )"}</h3> {{if $orientation == 'vertical'}} <div class='ipsPad_half ipsWidget_inner'> <ul class='ipsDataList ipsDataList_reducedSpacing'> {{foreach $records as $record}} <li class='ipsDataItem'> <div class='ipsDataItem_icon ipsPos_top'> {template="userPhoto" group="global" app="core" params="$record->author(), 'tiny'"} </div> <div class='ipsDataItem_main'> <div class="ipsCommentCount ipsPos_right {{if ( $record->record_comments ) === 0}}ipsFaded{{endif}}" data-ipsTooltip title='{lang="replies_number" pluralize="$record->record_comments"}'>{expression="$record->record_comments"}</div> <a href="{$record->url()->setQueryString( 'do', 'getLastComment' )}" title='{lang="view_this_cmsrecord" sprintf="\IPS\Member::loggedIn()->language()->addToStack( 'content_db_lang_sl_' . $record::$customDatabaseId, FALSE ), $record->_title"}' class='ipsDataItem_title ipsType_break'>{wordbreak="$record->_title"}</a><br> <span class='ipsType_light ipsType_small'>{lang="byline_nodate" htmlsprintf="$record->author()->link()"} · {datetime="$record->mapped('date')"}</span> </div> </li> {{endforeach}} </ul> </div> {{else}} <div class='ipsWidget_inner'> <ul class='ipsDataList'> {template="recordRow" group="listing" location="database" app="cms" themeClass="IPS\cms\Theme" params="null, null, $records"} </ul> </div> {{endif}} {{endif}} I want to add record image to the above but can't seem to manage it {{if $record->record_image}} < class="cCmsRecord_image"> <img class="ipsImage" src="{file="$record->record_image" extension="cms_Records"}"> </div> {{endif}}
  2. I use twitter cards on another site, I will have a look at how it is set up
  3. Would also like show in listing and show in display on main fields page rather than opening each one and editing it
  4. With display options it would be really good if you could save and reload rather than save and close, cos you have to edit, check how it looks etc and it is a pain have to keep opening a field,especially when you have a few.
  5. How do you delete a whole database display template? There is a delete button which can delete individual files within a template but I cannot see how to delete the whole template
  6. Sorry another one. I am using <if> to hide custom fields in my template if the fields are left empty which works fine {{if count( $record->customFieldDisplayByKey('county','display') )}} {$record->customFieldDisplayByKey('county', 'display')|raw} {{endif}} But if I add list items <li> or breaks <br />they are visible {{if count( $record->customFieldDisplayByKey('county','display') )}} <li> {$record->customFieldDisplayByKey('county', 'display')|raw} </li> {{endif}} Is there away to hide not just the content of the field but formatting as well?
  7. Excellent thank you I had to just alter your code a bit to make it work in display templates {{if count( $record->customFieldDisplayByKey('field_additional-image_136_137_138','display') )}} {$record->customFieldDisplayByKey('field_additional-image_136_137_138', 'display')|raw} {{endif}}
  8. Where is Marcher when you need him Can't make it work Tried {{ if $record->customFieldDisplayByKey('additional-image_136_137_138') }} {$record->customFieldDisplayByKey('additional-image_136_137_138', 'display')|raw} {{ endif }} And get an config error Just trying to hide empty fields
  9. Are you creating a new block. I had to scrap all my old 3.x blocks as most didn't work
  10. Trying to use custom fields in a record template {$record->customFieldDisplayByKey('fuel', 'listing')|raw} How would I use the above with the {{if}} statement So that when the field is empty it is not displayed in template
  11. How would I go about creating a contact form in an IPC database, I currently use contact seller which is a member field but obviously guests can use that I thought of using an email field but then you are into spam and all that. Any ideas
  12. As a number field you cannot use non numeric characters such as , or . How do I format the number field so I can enter 2.50 or 25.00 or 25,000.00 etc not worried about the £sign as I have put that in the display option Or am I better using text box and let members sort it out
  13. This doesn't work in the my set up I have home page mysite.com forums in mysite.com/forums If I use /calendar for example it works on forums but get a 404 from the home page So I guess I will have to use the full URLs eg mysite.com/forums/calendar etc etc
  14. Would be nice if you don't have the chat showing as a main menu item but use the block to have it invisible if nobody is in there
  15. I know I had a moan about a few of the filters being missing but loving the blocks now. You can stick em on the forums, slot them in a page, whack a video link in and stick that on your forums and have a vid showing in your side bar. Lots of options Great, thanks
  16. Has anything been sorted with this as I can't find how to do it either
  17. Thats what I thought but doesn't seem to work you can select multiple items but it doesn't drop down
  18. Simples in the end, it took a lot of finding though for some reason. But you need to give reviews permissions. Go to the database you want and click the drop down and click permissions
  19. Database option allow comments or allow reviews Allow reviews doesn't seem to do anything?
  20. Got it sorted should be {$formValue} and I just added it to the URL field of the database so I could use {$formValue} rather than make a second field just for thumbshots So in URL field display it is <img src="http://images.thumbshots.com/image.aspx?cid=0o9U8fC5h2s%32d&v=1&w=[Width]&url={$formValue}" border="1" alt="Preview by Thumbshots.com" />
  21. I have a database with a URL field with a field key of linkswebsite In another field I have text field where I have the display option of <img src="http://images.thumbshots.com/image.aspx?cid=0o9U8fC5h2s%3d&v=1&w=[Width]&url=[linkswebsite]" border="1" alt="Preview by Thumbshots.com" /> which doesn't work I have also tried <img src="http://images.thumbshots.com/image.aspx?cid=0o9U8fC5h2s%3d&v=1&w=[Width]&url=[{linkswebsite}]" border="1" alt="Preview by Thumbshots.com" /> Any ideas?
×
×
  • Create New...