Jump to content
Alex
 Share


Introducing IP.Converge Modules

IP.Converge is designed to be an open platform allowing any application to share a common authentication method. This allows sites on different servers, and using different products, to let users access it with a 'global' login.

Unfortunately due to limitations within IP.Converge, only a handful of IPS applications utilised it. However, with the recent introduction of IP.Converge 1.1, functionality has been added to allow 3rd-party applications which use a different password hashing system, to integrate with Converge itself.

Being able to integrate popular products seamlessly was an opportunity we simply could not miss! We have noticed that modifications integrating products such as Joomla and Wordpress with IP.Board were so commonly requested, that we had to do something about it.

Introducing IP.Converge Modules
As many of you will be aware of, we have a team of Community Developers who actively develop and maintain our community-projects; IP.Tracker and IP.Shoutbox. We now have a new project that has been in development for some time, IP.Converge Modules. We are starting off with modules for integrating Joomla, WordPress and WordPress MU with IP.Converge and further modules will follow in the near future. You may have read our community developers talking about the development of these on the forums already.

This new range of community projects should prove a popular addition. Available for beta testing, we currently have IPC.Joomla and IPC.WordPress, a separate module is available for WordPress MU users (IPC.WordPress MU). These Converge-ready applications will integrate your existing Converge applications with these popular products. If you wanted to, you could link up multiple Joomla/WordPress installations with your IP.Board, as Converge supports this very well.

For the first release, the modules will offer simple integration compatible with IP.Converge, however in the near future more extension sets will be available for download. These extension sets will each offer a different level of integration for the products, but for now we are simply focusing on integrating these popular products.

To avoid confusion surrounding the products named 'JIB' and 'WIB' developed by Brandon D, IPC.Joomla, IPC.WordPress and IPC.WordPress MU are in fact the new 'JIB' and 'WIB'. Brandon D has been leading this new community project, and therefore work on his two old projects has been carried over to this community project.

You can download the beta releases of these Converge modules here, and the new forums have now been revealed, please feel free to ask any questions there! The Resource site's community project page has also been updated to reflect this new addition! Finally, a new bug tracker project has been set up to allow you to report bugs in these modules.

These converge modules require the PHP version that the product requires, for example to install IPC.Joomla, you will need a PHP version which is compatible with Joomla itself.

IP.Converge 1.1.0 RC 2
To go alongside this release, the second release-candidate of IP.Converge is now available for download for those with an active IP.Board license. Please continue to report any bugs you find in the IP.Converge bug tracker.

In order to install the Converge modules, you must be using at least IP.Converge 1.1 RC 2.

We hope that these new two projects will go a long way and prove to be a very popular addition.

 Share

Comments

Recommended Comments



Hello

I am trying to install the IPV.Joomla module locally, however I am stuck at the 'Paths & Accounts' screenshot , where I keep getting the following
An unkonwn error has occurred while trying to perform the handshake process with IP.Converge. Double check your IP.Converge URL and try again.

ALso the screen above is showing:
Notice: Constant _JEXEC already defined in C:\wamp\www\Joomla\module_installer\module\appFramework.php on line 19

Notice: Constant JPATH_BASE already defined in C:\wamp\www\Joomla\module_installer\module\appFramework.php on line 20

Notice: Constant DS already defined in C:\wamp\www\Joomla\module_installer\module\appFramework.php on line 21

Notice: Use of undefined constant CVG_MODULE_DEBUG_ON - assumed 'CVG_MODULE_DEBUG_ON' in C:\wamp\www\Joomla\converge_local\apis\global\classXmlRpc.php on line 888

Notice: Undefined index: user in C:\wamp\www\Joomla\converge_local\apis\global\classXmlRpc.php on line 673

Notice: Use of undefined constant CVG_MODULE_DEBUG_ON - assumed 'CVG_MODULE_DEBUG_ON' in C:\wamp\www\Joomla\converge_local\apis\global\classXmlRpc.php on line 888

Notice: Use of undefined constant CVG_MODULE_DEBUG_ON - assumed 'CVG_MODULE_DEBUG_ON' in C:\wamp\www\Joomla\converge_local\apis\global\classXmlRpc.php on line 888

Notice: Use of undefined constant CVG_MODULE_DEBUG_ON - assumed 'CVG_MODULE_DEBUG_ON' in C:\wamp\www\Joomla\converge_local\apis\global\classXmlRpc.php on line 888

Notice: Use of undefined constant CVG_MODULE_DEBUG_ON - assumed 'CVG_MODULE_DEBUG_ON' in C:\wamp\www\Joomla\converge_local\apis\global\classXmlRpc.php on line 888

Notice: Use of undefined constant CVG_MODULE_DEBUG_ON - assumed 'CVG_MODULE_DEBUG_ON' in C:\wamp\www\Joomla\converge_local\apis\global\classXmlRpc.php on line 888

I did neter the correc path to the converge folder I tried pointing directly to the index.php file, to one folder above, all without result...

Any help would be greatly apprecaited

Marco

Link to comment
Share on other sites

[quote name='celina' date='01 July 2009 - 06:05 PM']
dying to get access to this module but cannot access it without a current support contract from IPS, which I don't need...help!


The Converge modules are only available to those with an active license ;)

[quote name='celina' date='01 July 2009 - 06:09 PM']
also, what version of IPB do i need for this?


You'll need Converge 1.1. - IPB 2.3 or 3.0 will be fine, but only 3.0 supports the new features like username log in.

Link to comment
Share on other sites

I did try to instal with joomla it says

Local Converge Folder Exists: FAILED
Configuration File Writable: FAILED


I have joomla on the root directory public_html/joomla_site
ipb is on the public_html/forum
IPS Converge is on the public_html/converge (and i renamed the folder)
IPC.Joomla is on IPC.Joomla/module_installer

I asked this to about 5 Invision related forums and all are ignoring... does it really work ?

Link to comment
Share on other sites

[quote name='Mark' date='05 July 2009 - 11:28 AM']

The Converge modules are only available to those with an active license ;)



You'll need Converge 1.1. - IPB 2.3 or 3.0 will be fine, but only 3.0 supports the new features like username log in.

Converge 1.1 not working with 2.3 and you dont get any help also. converge is dead project, there is no support. im waiting answers already 2months
* http://community.invisionpower.com/topic/297275-test-unsuccessful/
* http://community.invisionpower.com/topic/297524-test-unsuccessful/

Link to comment
Share on other sites

[quote name='Brandon D' date='05 April 2009 - 08:52 PM']
Yes, Drupal is up high on the list of apps to cover. We're working on an additional extension set for the current three modules before making any new ones, though.


Brandon D,

Any news about the Drupal module?

Thanks!

Rodrigo

Link to comment
Share on other sites

I am trying to install the ipc.joomla module. After I put in email addresses, passwords etc, it comes up with this:

Double check your IP.Converge URL and try again.

I've tried quite a few different options, including copying the one in the support manual. What is the IP.Converge URL supposed to be, or where can I find it?

Link to comment
Share on other sites




Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...