Jump to content
You're invited! Join our 4.6 Live Event on ZOOM 6/24 ×

Community

Apfelstrudel

+Clients
  • Posts

    634
  • Joined

  • Last visited

 Content Type 

Profiles

Downloads

IPS4 Providers

Release Notes

IPS4 Guides

IPS4 Developer Documentation

Invision Community Blog

Forums

Store

Posts posted by Apfelstrudel

  1. Hello,

    I'd like to highlight search results in feeds if a club is pinned.

    Formatting works fine and I already have it working using club_id in a template condition.

    But to make it more comfortable I'd like to highlight a feed line automatically if a club is pinned.

    The only problem I have is that the pinned setting is not part of $indexData in template system->searchResult.

    Is there an easy way to get it into this template?

    I would really appreciate any help.

  2. But don't forget all those mail bounces the robots produce. Although they won't be active the system sends an activation mail which bounces in most of the cases. This is negative for our spam score.

    So often I suggested some kind of stats to get an overview of those robot registration tries. It would also be interesting to see how many people write a good first post but don't get through the last activation step. With that information I can optimzie my customer journey and provide additional information for the user.

    IPS, please make the post before register posts visible to admins in the acp!

  3. Thanks Daniel for the support but adding ...

    Quote

    define( 'DEV_USE_FURL_CACHE', TRUE );

    ... to constants.php didn't make it. FURLs are still not available.

    Obviously all my template changes are not being used because also this won't work in dev mode.

    I guess I don't understand the idea behind dev mode in the way it was made for but I just want to create plugins and test them immediately afterwards in my xampp version. But I can't do this because my xampp version doesn't run regarding look and feel as it does live right now.

    Sorry devs, don't hit me. I have to learn how to think like a pro. 😄

  4. By adding this constant the site works now BUT ...

    • the entire site is in english now although the english language pack is disabled. I can't switch it to my local language although it is being showed as active.
    • All custom SEO urls don't work although they are all listed and activated.
    • All databases don't work anymore. Error code: 256
      ErrorException: You have used a function (count) that should be called from the root namespace for performance reasons (/forum/system/Theme/Theme.php(4465) : eval()'d code::65). (256)

    My technical specs of the local XAMPP system:

    • php: 7.4.14
    • mysql: v5.5.5-10.4.17-MariaDB
    • no plugins or add-ons installed

    Any tips?

  5. Hi,

    I am also having an issue with enabling dev mode (on local XAMPP). I copied all necessary dev folders (except for apps I don't have).

    I set all file permissions correctly.

    The software still works BUT as soon as I add the IN_DEV setting to constants I get an error for every page:

    Whoops \ Exception \ ErrorException (E_WARNING)
    session_name(): Cannot change session name when headers already sent

    Any ideas?

  6. I agree that the "mark as solved" link should not be part of post 1. So I got a solution to hide it.

    Go to following template:

    Forums -> front -> topics -> post

    ... and add the green code.

    Quote

                            {{if !($item->topic_firstpost == $comment->pid) AND ( $comment->item()->isSolved() and $comment->item()->mapped('solved_comment_id') == $comment->pid ) AND $comment->item()->canSolve()}}
                                <li><a href='{$item->url()->csrf()->setQueryString( array( 'do' => 'unsolve', 'answer' => $comment->pid ) )}' data-action="unsolveComment">{lang="unsolve_content"}</a></li>
                            {{endif}}
                            {{if !($item->topic_firstpost == $comment->pid) AND $comment->item()->canSolve() AND ! $comment->item()->isSolved()}}
                                <li><a href='{$item->url()->csrf()->setQueryString( array( 'do' => 'solve', 'answer' => $comment->pid ) )}' data-action="solveComment">{lang="solve_content"}</a></li>
                            {{endif}}

     

     

  7. Hello,

    because newsletters are a sensitive topic here in Europe (GDPR) I'd like to hide the entire newsletter block from the notification center.

    Yes I've already set the manual opt-in method for bulk mails but I also want to remove this block from this center.

    The main reason is that the checkbox for email notification is enabled by default.

    How can I hide this box? We do not send any newsletter because we have no additional opt-in process.

    Thanks in advance for any help.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy