Jump to content

GFLRoy

Clients
  • Posts

    24
  • Joined

  • Last visited

 Content Type 

Profiles

Downloads

IPS4 Providers

Release Notes

IPS4 Guides

IPS4 Developer Documentation

Invision Community Blog

Forums

Store

Posts posted by GFLRoy

  1. Hello there,

    We've purchased this plugin and have been using it heavily (we have, potentially, a 100 or so forms) for a while. We've encountered a bit of an issue where, periodically, a form will lose all of its fields and those fields will somehow end up on another form or disappear completely. Such forms look like this:XnIEXN3.png

    Our site manager says that there are no logs regarding the issue in ACP. Is there any known solution to this issue?

  2. Hello, I've made an IPS 4 database using IPS 4 Pages. In this database, I have a "Member" field with the "Multiple Selection" option checked. When making a record, I can add more than one member. However, it only saves the first member after I create the record or edit it.

     

    I am running IPS 4.1.19.1. Has anybody else had this issue? If so, this may be a bug with IPS 4.

     

    Any help would be highly appreciated!

     

    Thanks.

  3. 25 minutes ago, Nathan Explosion said:

    If reproducible - log it as a bug in the tracker.

    Tested and works fine for me - what image url is it that you have used?

    Hello, I have edited the original post. This isn't an issue and I apologize for making it seem that way before editing the post.

     

    Anyway, I want to know if it is possible to directly use the image source in forum descriptions instead of the IPS 4 filter link.

     

    Thanks.

  4. Hello, I have a question regarding images in the forum description. Currently, it uses an IPS 4 filter link to display images. For example, if you edit your forum description and go to "Source", you will see the "src" isn't set to the image directly. I would like to display the image directly from the source.

     

    Here is an example of my forum's description source that shows there is an IPS 4 filter link:

    <p>
    	Testing images on subforums.
    </p>
    
    <p>
    	<img class="ipsImage" data-munge-src="<myimage>" src="https://gflclan.com/?app=core&amp;module=system&amp;controller=redirect&amp;url=<myimage>&amp;key=<secure>&amp;resource=1">
    </p>

     

    Quote

     

    Is there any way to make it so forum descriptions always rely on the direct image source instead of the IPS 4 image filter? I can set the "src" to the image directly, but every time I edit the forum description, it resets back to the IPS 4 filter link.

     

    I hope to receive a reply and any help is highly appreciated!

     

    Thanks.

  5. 2 hours ago, CalvinK said:

    I've never worked with MariaDB (although moving my community onto it is on my todo list), but there's a number of people who have some experience with it. Might be worthwhile just putting "(MariaDB)" in your title so it's clearer ^_^

    Sadly, I don't see an edit button for the original post.

     

    Also, after trying different things to see if IPS 4 would install correctly, I am still stuck. I finally decided to see if IPB 3.4.9 installed, and yes, it did install correctly. It installed all the tables, etc fine using the same database details as the IPS 4 installation.

     

    I'm not sure what else the IPS 4 installer requires. I'm running MariaDB 5.5.47 and I hope the IPS 4 installer supports that.

     

    Thanks.

  6. 2 hours ago, CalvinK said:

    I wasn't expecting it to exist, don't worry!

    It's just so we can clarify that the core sessions table hasn't been created yet the install obviously thinks it has been created as it's trying to write a session to it.

    You are correct about it thinking there are tables in the database already. I found another log file (uploads/logs) and it seems to think all of the tables exist. Here is one entry (out of many others):

    Sat, 28 May 2016 15:12:22 +0000
    Table '********.ips4_core_sys_conf_settings' doesn't exist
    SELECT conf_key, conf_default, conf_value FROM `ips4_core_sys_conf_settings` AS `core_sys_conf_settings`
     | File                                                                       | Function                                                                      | Line No.          |
     |----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------|
     | /system/Db/Db.php                                                          | [IPS\Db\_Exception].__construct                                               | 388               |
     '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
     | /system/Db/Select.php                                                      | [IPS\_Db].preparedQuery                                                       | 346               |
     '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
     | /system/Db/Select.php                                                      | [IPS\Db\_Select].runQuery                                                     | 244               |
     '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
     | /system/Settings/Settings.php                                              | [IPS\Db\_Select].setKeyField                                                  | 139               |
     '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
     | /system/Settings/Settings.php                                              | [IPS\_Settings].loadFromDb                                                    | 119               |
     '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
     | /system/Dispatcher/Front.php                                               | [IPS\_Settings].__isset                                                       | 39                |
     '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
     | /system/Dispatcher/Dispatcher.php                                          | [IPS\Dispatcher\_Front].init                                                  | 86                |
     '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
     | /index.php                                                                 | [IPS\_Dispatcher].i                                                           | 13                |
     '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
    #0 /home/**********/public_html/system/Db/Exception.php(109): IPS\_Log::log('Table '********...', 'sql')
    #1 /home/**********/public_html/system/Db/Db.php(388): IPS\Db\_Exception->__construct('Table '********...', 1146, NULL, 'SELECT conf_key...', Array)
    #2 /home/**********/public_html/system/Db/Select.php(346): IPS\_Db->preparedQuery('SELECT conf_key...', Array)
    #3 /home/**********/public_html/system/Db/Select.php(244): IPS\Db\_Select->runQuery()
    #4 /home/**********/public_html/system/Settings/Settings.php(139): IPS\Db\_Select->setKeyField('conf_key')
    #5 /home/**********/public_html/system/Settings/Settings.php(119): IPS\_Settings->loadFromDb()
    #6 /home/**********/public_html/system/Dispatcher/Front.php(39): IPS\_Settings->__isset('setup_in_progre...')
    #7 /home/**********/public_html/system/Dispatcher/Dispatcher.php(86): IPS\Dispatcher\_Front->init()
    #8 /home/**********/public_html/index.php(13): IPS\_Dispatcher::i()
    #9 {main

     

    I also forgot to mention, I am using MariaDB. As far as I am aware, IPS doesn't have any problems with MariaDB since it is very similar to MySQL. 

     

    I've also tried doing this through the root user (obviously as a test to see if it works at all), but no luck. I have enabled the general MySQL (MariaDB) log file and it appears to be at least executing some queries during the installation:

    
    160528 11:07:16   906 Connect   *****************@***** as anonymous on *********
                      906 Query     SET NAMES utf8mb4
                      906 Quit
                      907 Connect   *****************@***** as anonymous on *********
                      907 Query     SET NAMES utf8mb4
                      907 Quit
                      908 Connect   *****************@***** as anonymous on *********
                      908 Query     SET NAMES utf8mb4
                      908 Quit
                      909 Connect   *****************@***** as anonymous on *********
                      909 Query     SET NAMES utf8mb4
                      909 Quit
                      910 Connect   *****************@***** as anonymous on *********
                      910 Query     SET NAMES utf8mb4
                      910 Quit
                      911 Connect   *****************@***** as anonymous on *********
                      911 Query     SET NAMES utf8mb4
                      911 Quit
                      912 Connect   *****************@***** as anonymous on *********
                      912 Query     SET NAMES utf8mb4
                      912 Quit
                      913 Connect   *****************@***** as anonymous on *********
                      913 Query     SET NAMES utf8mb4
                      913 Quit
    160528 11:07:17   914 Connect   *****************@***** as anonymous on *********
                      914 Query     SET NAMES utf8mb4
                      914 Quit
                      915 Connect   *****************@***** as anonymous on *********
                      915 Query     SET NAMES utf8mb4
                      915 Quit
                      916 Connect   *****************@***** as anonymous on *********
                      916 Query     SET NAMES utf8mb4
                      916 Quit
                      917 Connect   *****************@***** as anonymous on *********
                      917 Query     SET NAMES utf8mb4
                      917 Quit
                      918 Connect   *****************@***** as anonymous on *********
                      918 Query     SET NAMES utf8mb4
                      918 Quit
                      919 Connect   *****************@***** as anonymous on *********

     

    As I said before, making a separate test script to insert into the database works fine. This is only an issue with the IPS 4 installer.

     

    I will continue to look for solutions. If anybody could give any suggestions, it would be greatly appreciated!

     

    Thanks.

  7. 17 minutes ago, CalvinK said:

    Does the core_sessions table exist in your database?

    No. Although, why should it? It should be creating the tables (since this is a new IPS 4 installation), not executing queries on tables. Please correct me if I am wrong though (I may be). 

     

    Thanks.

  8. Hello everybody, I am trying to install a fresh IPS 4 (4.1.12.1) on one of my new machines. However, I am running into an issue every time I start the installation.

    It first says "Setting Up Databases" and then goes straight to a "<hostname> has redirected too many times" page error (on Google Chrome). After investigating, I found that this error has been spammed in the error_log:

    [28-May-2016 02:38:52 UTC] PHP Fatal error:  Uncaught exception 'IPS\Db\Exception' with message 'Table '******.core_sessions' doesn't exist' in /home/******/public_html/system/Db/Db.php:388
    Stack trace:
    #0 /home/******/public_html/system/Db/Db.php(688): IPS\_Db->preparedQuery('REPLACE INTO `c...', Array)
    #1 /home/******/public_html/system/Session/Front.php(300): IPS\_Db->replace('core_sessions', Array, true)
    #2 [internal function]: IPS\Session\_Front->write('20b87717065f066...', '')
    #3 {main}
      thrown in /home/******/public_html/system/Db/Db.php on line 388

     

    I've tried different versions of IPS 4 and I am still getting the same error (4.1.11.1, 4.1.12, and 4.1.12.1). With that said, I've tried writing another PHP script to see if it's an issue with the MySQL server, however, the script ran queries on the MySQL server fine. Therefore, the connection between IPS 4 and the database should be okay.

     

    Does anybody have any idea what could cause this? I have opened a ticket with the Invision Power staff, but I do not know how long it will take them to reply (I am trying to get this fixed ASAP).

     

    Thanks.

  9. Hello everybody, I have a suggestion for IPB. Is there a way to add another permission option (for forums), to make it so whatever group is checked can only see their topics and reply to their topics only?

    I have a form manager and when you submit the form, a topic is created in a forum, which is where everybody looks at the submitted form. It would be nice to make it so the person that submitted the forum in a specific group can only look at their topic and only reply to their topic (this user would be in a default group such as Registered Users), then admins can look at all topics and reply to all of them. Basically just another option in forum permissions. I don't think this should be a feature of the addon I have, I think this should be a default option in IPB. Since it isn't added already, I would imagine this getting denied but it's worth bringing up because I couldn't find this on Google anywhere.

    Thanks,

    GFL (Games for Life)

  10. Great addon :)

    Can you make a store item that is user-customizable that can run SQL queries on remote databases?

    For example I have something in my shop that users can purchase, and it writes to a database my game servers can read, so they have donator/VIP perks.

    Thanks :)

×
×
  • Create New...