Jump to content

misfit76

Clients
  • Posts

    198
  • Joined

  • Last visited

 Content Type 

Profiles

Downloads

IPS4 Providers

Release Notes

IPS4 Guides

IPS4 Developer Documentation

Invision Community Blog

Forums

Store

Posts posted by misfit76

  1. I am getting the following error when trying to create a Block. This is happening when all detailes are entered and i hit "Save".  I was trying to create "Main Block ( Multiple Image Backgrounds )"

    TypeError: Argument 2 passed to IPS\_Db::preparedQuery() must be of the type array, null given, called in /home/skupper/www.bmw2002faq.com/system/Db/Db.php on line 936 (0)
    #0 /home/skupper/www.bmw2002faq.com/system/Db/Db.php(936): IPS\_Db->preparedQuery('INSERT INTO `la...', NULL)
    #1 /home/skupper/www.bmw2002faq.com/system/Patterns/ActiveRecord.php(487): IPS\_Db->insert('landingpage_ima...', Array)
    #2 /home/skupper/www.bmw2002faq.com/applications/landingpage/modules/admin/main/blocks.php(631): IPS\Patterns\_ActiveRecord->save()
    #3 /home/skupper/www.bmw2002faq.com/system/Dispatcher/Controller.php(90): IPS\landingpage\modules\admin\main\_blocks->contentBlockMultiple()
    #4 /home/skupper/www.bmw2002faq.com/system/Node/Controller.php(69): IPS\Dispatcher\_Controller->execute()
    #5 /home/skupper/www.bmw2002faq.com/system/Dispatcher/Dispatcher.php(153): IPS\Node\_Controller->execute()
    #6 /home/skupper/www.bmw2002faq.com/admin/index.php(13): IPS\_Dispatcher->run()
    #7 {main}

    Thank you!

  2. 5 hours ago, CodeBite said:

    @misfit76 In the slider settings, you can choose the pages on which to display the slider.

    At the moment i can chose the application on which the Slider can appear. I am looking to be able to specify exact pages.  I woudl like for it to be on the home page, but not the rest of content in the "Pages" application.

     

    thank you,

    Steve K

  3. 17 hours ago, CodeBite said:

    @misfit76

    Everything is possible, please review the template settings.

    You change the colors in the file codebite__nexxe_var.css

     

     

    There are no problems on the demo, there is the latest version. It is possible that the installed plug / application causes the errors to disable and check everything, the same on another template, check for these errors.

    It is very possible that the menus and notifications are not working due to JS errors.

     

     

    Thank you for pointing me in the right direction!  I was be to figure out that if the Javascript include location is set to "Inside the <head>" i get the error as listed above with the menu, slider, and notifications.  When the Javascript include location is set to "Just before </body> tag" things are functioning properly.

     

    Thank you,

    Steve 

     

  4. Is it possible to change the primary color of the theme?  I thought i changed all of the "orange" colors to my primary color, but a lot of things atill in the same color.  Also, is it possible to change the color of the back ground?  

     

    Also, i might have a js error.

    the console is showing:

    root_library.js.gz?v=105a0f30411631741813:2 Uncaught TypeError: Cannot read properties of undefined (reading 'disableRightClick')
        at baseController.setup (front_front_htmlplayer.js.gz?v=105a0f30411631741813:1)
        at baseController.initialize (front_front_htmlplayer.js.gz?v=105a0f30411631741813:1)
        at initControllerOnElem (root_framework.js.gz?v=105a0f30411631741813:24)
        at initializeControllers (root_framework.js.gz?v=105a0f30411631741813:6)
        at Object.init (root_framework.js.gz?v=105a0f30411631741813:4)
        at HTMLDocument.<anonymous> (root_library.js.gz?v=105a0f30411631741813:86)
        at e (root_library.js.gz?v=105a0f30411631741813:2)
        at t (root_library.js.gz?v=105a0f30411631741813:2)

     

    I see that my "notifications" do not show up

     

    1910701459_ScreenShot2021-09-15at2_46_01PM.png.9be6db3e9fc129c7e032ca61de0c4b66.png

    and the Menu is broken (does not get "More" Button.

    934911130_ScreenShot2021-09-15at2_51_55PM.thumb.png.c41474de0bc8a034b1f6d24d354fcd71.png

    Any help is appreciated

     

    Thank you,

    Steve 

  5. 10 hours ago, Adriano Faria said:

    Not sure how you're getting this error:

    	public function execute()
    	{
    		$this->runUntilTimeout( function()
    		{
    			$sql = \IPS\Db::i()->select( '*', 'paytopintopics_topics', array( "pinned=1 AND ptpt_status=? AND ptpt_limit<?", 'pinned', time() ), 'tid DESC', 25 )->join( 'forums_topics', 'paytopintopics_topics.ptpt_topic_id=forums_topics.tid' );
    			if ( !$sql->count() )
    			{
    				return FALSE;
    			}

    There's only one ptpt_status column in the app and it's not duplicated in the query, etc.

    You probably still have these columns in your topics table from the old plugin; it should have been dropped. Make sure you don't have them in forums_topics table. If you have, drop them. Let me know if you need help to check and drop the columns.

     

    Help finding if they exist and dropping them is appreciated

    steve

  6. I am getting an error in the cron and it is in the logs. Is there something that i am missing int he DB?

    SELECT * FROM `paytopintopics_topics`  LEFT JOIN `forums_topics` ON paytopintopics_topics.ptpt_topic_id=forums_topics.tid WHERE pinned=1 AND ptpt_status='pinned' AND ptpt_limit<1630680301 ORDER BY tid DESC LIMIT 25
    Column 'ptpt_status' in where clause is ambiguous

     

     

    #0 /home/skupper/www.bmw2002faq.com/system/Db/Select.php(383): IPS\_Db->preparedQuery('/*ipb_prd::ipdb...', Array, true)
    #1 /home/skupper/www.bmw2002faq.com/system/Db/Select.php(577): IPS\Db\_Select->runQuery()
    #2 /home/skupper/www.bmw2002faq.com/applications/paytopintopics/tasks/pinRequest.php(42): IPS\Db\_Select->count()
    #3 /home/skupper/www.bmw2002faq.com/system/Task/Task.php(367): IPS\paytopintopics\tasks\_pinRequest->IPS\paytopintopics\tasks\{closure}()
    #4 /home/skupper/www.bmw2002faq.com/applications/paytopintopics/tasks/pinRequest.php(66): IPS\_Task->runUntilTimeout(Object(Closure))
    #5 /home/skupper/www.bmw2002faq.com/system/Task/Task.php(266): IPS\paytopintopics\tasks\_pinRequest->execute()
    #6 /home/skupper/www.bmw2002faq.com/system/Task/Task.php(229): IPS\_Task->run()
    #7 /home/skupper/www.bmw2002faq.com/applications/core/interface/task/task.php(58): IPS\_Task->runAndLog()
    #8 {main}

     

    Thanks for the help!

    Steve K.

  7. Thanks for looking. 

    Here is what i found on my Mac:

    Chrome: Just a link

    Firefox: Player with Sound

    Safari: Work as expected.

    And yes, it is the same with the app disabled. I'll contact IPB Support to see if they can sort this.

    Thank you,

    Steve 

  8. I am trying to add the social media icons to the records in the directory by fomratting the fields like this

    <span><a href="https://www.facebook.com/{$value}"><i class="fab fa-facebook" aria-hidden="true"></i></a></span>

    Would you know how i can format them so they a show up on the same line in the record view?

    https://www.bmw2002faq.com/vendors/parts-vendors-and-manufacturers/ireland-engineering-r1/

     

    Also, with the gallery, is it possible to include the name of the gallery like you have in another template?

    Thank you!

×
×
  • Create New...