Jump to content

Nathan Explosion

Clients
  • Posts

    7,013
  • Joined

  • Days Won

    128

 Content Type 

Downloads

Release Notes

IPS4 Guides

IPS4 Developer Documentation

Invision Community Blog

Development Blog

Deprecation Tracker

Providers Directory

Projects

Release Notes v5

Forums

Events

Store

Gallery

Posts posted by Nathan Explosion

  1. 4 hours ago, liquidfractal said:

    ANy ETA on 1.1, which can play videos in blogs?

    *fingers crossed* a couple of weeks.

    Got v1.0.7 coming in next few days to fix a couple of small issues, then going back to v1.1 to get Announcements, Calendar and Pages added in to the supported sections/applications, where I've got a little idea on how to overcome the problem you had with the beta of v1.1 which will then expand it on out to Blogs too.

  2. 9 hours ago, thetrials said:

    Hey @Nathan Explosion just bought your plugin, which is awesome.

    Thanks!

    9 hours ago, thetrials said:

    From what I can put together the video is dependent on browser support, but it seems Chrome and Safari don't support all encoding codecs of MP4.

    Correct - it's all down to whether the browser can play the codec. If it can't, then there is nothing that my plugin can do about that - the plugin is intended to display the ability to play the audio/video items, from there it is up to the browser, and its user(s), as to whether it can play (as indicated in the plugin description, there is a link there that can help people determine if their browser can play a certain format/codec combination)

    image.thumb.png.db4fb6a06b2aafc582e63f5f9d5646d3.png

    Sorry, but there is nothing (to my knowledge) that I can do that will force a browser to play a video in the native HTML5 player if it can't support the codec that is used.

    What I can do is try to check the codec that the video is using and then not display the player if the browser doesn't support it, with a clear indication of why the player isn't displayed to that user. I've still got a little work to do on a planned update for a previous issue, and will start looking into adding that functionality (if that is achievable then I might be able to incorporate a fallback to a player such as videojs....no promises though. Maybe even provide an option for the admin to determine whether to use the native player or to use the videojs player.....hmmmmm)

  3. 11 hours ago, TheSkyLounge.tv said:

    Holy moly!

    :D

    The most recent release of the plugin has that manipulation all built in, so users won't have to perform it each time - they just drop (excuse the pun) in the Dropbox link and the plugin will take care of it all, with a nice BIG warning about usage....basically, if in doubt then reach out for support.

    image.thumb.png.2c0dcc72219ef1b8867bb16334caee7f.png

     

     

  4. 16 hours ago, Nathan Explosion said:

    No need - once I've taken a closer look then I can fix it. Totally forgot about the 'Download attachments' permission that was available, so I'll just refine things to adhere to that instead of the simple guests check that is being done in this case. Busy all day tomorrow (normal work) so afternoon is the earliest I can take a look.

    OK, having taken a look I'll get an update out over the weekend to sort this element out.

  5. Just now, Monstris said:

    Thanks I appreciate it. yeah so only the webm links show when you enable it in settings but the video player code is not showing. If I knew how plugins work in this script I would fix it myself but would take ages lol.

    No need - once I've taken a closer look then I can fix it. Totally forgot about the 'Download attachments' permission that was available, so I'll just refine things to adhere to that instead of the simple guests check that is being done in this case. Busy all day tomorrow (normal work) so afternoon is the earliest I can take a look.

  6. Provide a link to your post then, which makes it easier to see the 'issue'....

    Reason I put 'issue' like that is simple: if the video is an attachment then there is no point showing the player. Why? Click the link to find out...Guests cannot view attachments in 4.2.x:

    image.thumb.png.feddd16e2beb8e24e272aa5b209ff107.png

    If it's a remote link then that is different.

    Hence - provide a link to the post so I can see the 'issue'

  7. On 10/12/2017 at 7:56 PM, ProSkill said:

    What does pre-load videos mean? I'd like to make it so that embedded videos from third-party sites show up and play, however, I don't want upload video attachments to auto-play because where there are 10 to 15 videos per page it slows the page and server down as it tries to play all of the the videos at once.

    Edit: I figured it out. Once again thank you, this plugin is great! 

     

    For others reading this: preload ≠ autoplay.

    Preload functionality for the html5 video and audio tag basically tells the browser whether to automatically load the content ready for viewing/listening. There are three possible settings, and they are documented in the plugin settings.

    Autoplay will automatically begin playing the content after the page loads, and I will not be adding this functionality to the plugin purely for the reason stated above by ProSkill :D

  8. 10 hours ago, TheSkyLounge.tv said:

    @Nathan Explosion So you're telling me that I could upload my .mp4 to Dropbox...link it in our forum, and this will provide our visitor with a playable video!?

    In theory, yes. But I've just tested it out and it appears that dropbox don't allow remote embedding....I'll test again later, but it looks like a 'no' right now.

    Update: I've determined how a dropbox url can be modified to allow hotlinking. There's no change needed to plugin to actually support this but below is what you would need to do now to have it work.

    Further update: I've just spent a couple of minutes putting in a little function to do the manipulation needed, so that will be in the next update I release (v1.0.6)

    Example url provided by Dropbox when creating a share link is: https://www.dropbox.com/s/aewhi52igjvxp18/video1.mp4?dl=0

    1. Remove ?dl=0 from the url
    2. Change www to dl
    3. Submit post

    Without the url manipulation:

    image.thumb.png.596888dfeccdc1a9f0e09547004542b5.png

    With the url manipulation:

    image.thumb.png.d3fb4060cfd4ea42cd1cba8b8bfeb9be.png

     

    8 hours ago, superj707 said:

    would be super cool if this worked with downloads app. Heres what I am thinking. Someone uploads a video to downloads app and user who downloads video can just watch it right on the site without having to save to their computer. would be hand especially for people with apple phones who can never see the videos

    At some point in the future, maybe. I don't own, or plan to own, a license for Downloads so for the moment it's a 'no'

  9. 2 hours ago, Donald Meek said:

    ooking up i got a dice

    well i got ONE die going cant get more than one yet not sure the syntax perhaps for the dice

    1-12,1-12,1-12

    seems i only get one die

    but ok

    As already noted....that is a bug that will be fixed in the next version, which is now my next target for release.

     

     

     

     

  10. I was planning on releasing v1.1 next (which would allow the functionality of the plugin to extend to Pages/Calendar/Announcements/Blogs) but there are a number of issues that I need to overcome before I can release it (namely, not having access to the likes of Blogs & Gallery to ensure that the functionality works/doesn't impact those applications) I still plan to get that one out there, but it's going to take a little longer than originally planned. I now plan to release a new version which will expand the functionality to Pages/Calendar/Announcements, with a follow-up version expanding the functionality to Blogs.

    In the meantime, I've backported other items that I planned to include in v 1.1 and am releasing v1.0.5 to get those new features out. So.......

    What's new in version 1.0.5

    • added ability to control the preloading of video/audio files
    • added ability to control which forums in which the video/audio players are displayed
    • added ability to allow the video player to be resized within the browser window (up to the size of the maximum width defined in settings)
    • removed the maximum height video setting, as it is not used any more (video maintains aspect ratio on display/resize)

    Important: There have been some reports recently of other apps/plugins seeing settings disappear/resetting after some time or on app/plugin updates, so please review your plugin settings after updating.

  11. 2 minutes ago, liquidfractal said:

    HI Nathan,

    I've been getting some entries in my error logs that seem to have something to do with the HTML5 player.  For example, trying to view a JPG image in my gallery posted a long time ago didn't work and threw this error, which IPS say is "probably caused by" the HTML5 player plugin:

    
    TypeError: Argument 1 passed to DOMNode::removeChild() must be an instance of DOMNode, null given (0)
    #0 /home/XXX/public_html/init.php(448) : eval()'d code(39): DOMNode->removeChild(NULL)
    #1 /home/XXX/public_html/init.php(448) : eval()'d code(13): IPS\hook955->neavplayerparseDOM('')
    #2 /home/XXX/public_html/system/Content/Content.php(291): IPS\Content\hook956->content()
    #3 /home/XXX/public_html/applications/gallery/modules/front/gallery/view.php(240): IPS\_Content->truncated()
    #4 /home/XXX/public_html/system/Dispatcher/Controller.php(96): IPS\gallery\modules\front\gallery\_view->manage()
    #5 /home/XXX/public_html/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
    #6 /home/XXX/public_html/applications/gallery/modules/front/gallery/view.php(61): IPS\Content\_Controller->execute()
    #7 /home/XXX/public_html/system/Dispatcher/Dispatcher.php(146): IPS\gallery\modules\front\gallery\_view->execute()
    #8 /home/XXX/public_html/index.php(12): IPS\_Dispatcher->run()
    #9 {main}

     

    You're running the beta of v1.1 of the plugin, so thanks for posting this. For the sake of avoiding confusion, please report issues with the beta to me via PM.

    All others - this issue won't come up with the current released version.

  12. 4 minutes ago, pequeno said:

    Thank you for your support.

    One questión. In vídeos that works fine, is it posible to put a image from the video? Because vídeo apppears with white screen.

    That is all down to the file itself, and the browser - the default behaviour of the html5 video tag (the plugin simply does that....adds the video tag around the file's link) is to perform a preload of the content it is to play...if the file contains the information, then an image (ie the very first frame of the video) will be displayed. If it doesn't, then white screen. Again, not an issue with the plugin itself.

×
×
  • Create New...