Jump to content

tekguru

Members
  • Posts

    1,354
  • Joined

  • Last visited

 Content Type 

Profiles

Downloads

IPS4 Providers

Release Notes

IPS4 Guides

IPS4 Developer Documentation

Invision Community Blog

Forums

Store

Everything posted by tekguru

  1. Is there any way to turn it off completely or to turn it off for guests only?
  2. Right, but if a Mod does not look at the ModCP (and why should they), and they don't look at the forums (most of us go straight to New Content) then none of those indicators are visible at all. What is needed is either a Notification to be popped up, or that the posts be shown to Moderators as part of New Content. They have the permissions to see such posts so it should be in New Content as it is new content visible to them.
  3. That is likely the fault of the community as we asked the developer to make the Mod available. He should make it available to you IMHO.
  4. Today we had a guest posting on site and I received an email advising me of such. However when logging on and visiting the site there was nothing showing under New Content and nothing indicating a post required approval. The only way of finding the post to approve it was to use the link in the email. If there any way to give greater visibility to posts which require moderation? The other question is who are such emails sent to? Is it only myself as site Administrator or does it include the other staff members?
  5. So to close this out, can you guys confirm that this looks okay (seems to be running fine):
  6. Okay, do we remove and reinstall, or overwrite the old version? (Sorry to ask but my first plugin update on 4.x.x)
  7. If that could be done it would be a great feature as it would look much more cohesive when viewed.
  8. Seconded, and information as to get things like thumbnails (from articles & posts) into a block are 'must haves'. I raised a ticket concerning such and was advised that bascally non standard customisation wsas not supported. The inbuilt blocks are so basic is it ridiculous. A mini tutorial advising what variables are available would be awesome and save people a heck of a lot of work!
  9. And that has us fully operational, thanks for the assistance guys!
  10. Yeah but I want my config file where I can get at it without needing root access.
  11. Okay will force them to rename and try it. That is: /usr/bin/indexer --config /home/guru/public_html/sphinx_conf/sphinx.conf and /usr/bin/searchd --config /home/guru/public_html/sphinx_conf/sphinx.conf
  12. On the first I've told them not to use the original file and to delete it and replace it with 'sphinx.conf.use', however they seem to want to leave it in place and use the 'sphinx.conf.use' file. The gods only know why. Should the '--all' not be used at all then either for the config setting or the running on the daemon??
  13. Okay latest feedback from my host: The sphinx.conf.use file is: searchd { listen = 127.0.0.1:3312:mysql41 max_children = 30 pid_file = /var/sphinx/buildsearchd.pid preopen_indexes = 0 collation_server = utf8_general_ci workers = threads log = /var/log/sphinx/searchd.log } index ips { type = rt path = /var/sphinx/index rt_field = index_title rt_field = index_content rt_field = index_tags rt_attr_bigint = index_object_id rt_attr_bigint = index_item_id rt_attr_bigint = index_container_id rt_attr_bigint = index_author rt_attr_bigint = index_views rt_attr_bigint = index_num_comments rt_attr_bigint = index_num_reviews rt_attr_json = index_permissions rt_attr_timestamp = index_date_created rt_attr_timestamp = index_date_updated rt_attr_string = index_class rt_attr_uint = index_class_id rt_attr_uint = index_hidden }Any ideas why we are getting "FATAL: no indexes found in config file '/home/xxx/public_html/sphinx_conf/sphinx.conf.use'" as the index settings seem to be there? I assume the second error is due to the --all parameter being added for running?
  14. Okay, can you advise in which location your searchd.log is saved as we're getting 'FATAL: failed to open log file 'searchd.log': Permission denied' error message? We've deleted all old incarnations of that file from when we used sphinx year ago and it still can't write the file so we're trying to work out where it wants to write to.
  15. Right! My host has given up as permissions are good as far as they are concerned. We'll see if Invision manage to come up with anything.
  16. PD? This is sphinx that wont start on the server itself with the config file generated, or are you saying there is an issue with the config file itself that IPS4 is generating??
  17. My host has switched the configuration file to /home/guru/public_html/sphinx_conf/sphinx.conf.use (correct file) and is getting this error: FATAL: failed to open log file 'searchd.log': Permission denied They have changed the ownership of both /var/log/sphinx/searchd.log and /var/lib/sphinx/searchd.log, but the error persists So approaching giving up on ever getting Sphinx working now....... Did you have any of these issues?
  18. Only just saw this reply, now changed the updated file, and asking the host to try again. Fingers crossed! This is very much appreciated.
  19. My hosts have just confirmed hey are using the wrong conf file. More to follow.
  20. Right, thanks. Makes sense. Same version I have. My config is as: searchd { listen = vps2.description.com:3312:mysql41 max_children = 30 pid_file = /var/sphinx/buildsearchd.pid preopen_indexes = 0 collation_server = utf8_general_ci workers = threads } index ips { type = rt path = /var/sphinx/index rt_field = index_title rt_field = index_content rt_field = index_tags rt_attr_bigint = index_object_id rt_attr_bigint = index_item_id rt_attr_bigint = index_container_id rt_attr_bigint = index_author rt_attr_bigint = index_views rt_attr_bigint = index_num_comments rt_attr_bigint = index_num_reviews rt_attr_json = index_permissions rt_attr_timestamp = index_date_created rt_attr_timestamp = index_date_updated rt_attr_string = index_class rt_attr_uint = index_class_id rt_attr_uint = index_hidden } Does that look okay to you, as ISP407 will still not accept it as working. In /var/lib/sphinx I have: In /var/sphinx: In /var/run/sphinx My host also advised: Yet every time I try to activate sphinx in ACP I get: I think my host is getting tired of me asking them for details of what is where Any further ideas as this is driving me insane!
×
×
  • Create New...