Jump to content

Community

HeadStand

+Clients
  • Content Count

    3,264
  • Joined

  • Last visited

  • Days Won

    14

 Content Type 

Profiles

Downloads

IPS4 Documentation

IPS4 Providers

Release Notes

IPS4 Guides

IPS4 Developer Documentation

Invision Community Blog

Forums

Posts posted by HeadStand


  1. 4 hours ago, Vegan Gaymer said:

    There are no errors logged. How do I manually publish? 

    From the newsletters screen, click the "Manage Content" button from the menu on the right. There should be an option at the top to Publish. Keep in mind that this will distribute the newsletter to all subscribers.


  2. On 2/17/2020 at 5:59 AM, sound said:

    There seems to be an issue with the forum topic posts in the latest release

    In the topic post all the links now go through the newsletter app rather than directly to the topic url, as in  the url in the topic now contains the below

    
    /?do=click&key=*|unsubscribe_key|*&issue=*|issue_id|*&src=

    causing a fail with the below reported...


    Error code: EX1366

    This error was probably caused by application Newsletters.
    If the issue persists, disable it and contact the author for further assistance.

     

    the email newsletter appears to be working ok

     

     

    A new version has been pushed to the Marketplace. It contains a fix for this issue.

    On 2/21/2020 at 1:12 PM, Vegan Gaymer said:

    It's been confirmed that it is not an invision issue. Is there any way we can troubleshoot this? Thanks!

    Is there anything in your system logs? Have you tried manually publishing the newsletter to see if any errors come up?


  3. New version uploaded to the marketplace. Changes include:

    • Multiple issues with unsubscribe links. Fixed.
    • Post before register was not working correctly. Fixed.
    • Clicks are now tracked as unique vs total clicks.
    • Multiple issues with tracking stats. Fixed.
    • Disabled advertisements were included in the newsletter. Fixed.
    On 2/15/2020 at 1:07 PM, Vegan Gaymer said:

    DAILY DIGESTS NOT SENT FOR MONTHS

    I had not taken seriously a few reports in my community about not receiving a daily digest and advised them on how to ensure their settings were correct, but now it is months later and I have a huge stack of support tickets reporting that daily digests are not being received. It has been going on for months, apparently. 

    I don't know if this is an issue with this application or something wrong with Invision platform, but I thought I would ask here, first.

    What can I do to help troubleshoot this? Thanks!

    (note: application is up to date)

    troy

    Are you sure this is with regard to this application? Daily digests are part of IPS and the notification settings are related to that. If you have a newsletter configured to send out daily, that would be this application. Please confirm.


  4. 13 hours ago, Joel R said:
    
    SELECT * FROM `newsletters_pending_issues` WHERE newsletter_id=4 AND issue_date <= IS NULL ORDER BY issue_date desc
    IPS\Db\Exception: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'IS NULL ORDER BY issue_date desc' at line 1 (1064)
    #0 /home/nginx/domains/mywebsite.com/public/system/Db/Select.php(373): IPS\_Db->preparedQuery('/*IPS\\newslette...', Array, true)
    #1 /home/nginx/domains/mywebsite.com/public/system/Db/Select.php(436): IPS\Db\_Select->runQuery()
    #2 /home/nginx/domains/mywebsite.com/public/system/Db/Select.php(355): IPS\Db\_Select->rewind()
    #3 /home/nginx/domains/mywebsite.com/public/applications/newsletters/sources/Issue/Pending.php(168): IPS\Db\_Select->first()
    #4 /home/nginx/domains/mywebsite.com/public/applications/newsletters/sources/Newsletter/Newsletter.php(991): IPS\newsletters\Issue\_Pending::getPendingIssue(Object(IPS\newsletters\Newsletter))
    #5 /home/nginx/domains/mywebsite.com/public/applications/newsletters/tasks/PublishNewsletters.php(65): IPS\newsletters\_Newsletter->publish()
    #6 /home/nginx/domains/mywebsite.com/public/system/Task/Task.php(255): IPS\newsletters\tasks\_PublishNewsletters->execute()
    #7 /home/nginx/domains/mywebsite.com/public/applications/core/modules/admin/settings/advanced.php(709): IPS\_Task->run()
    #8 /home/nginx/domains/mywebsite.com/public/system/Dispatcher/Controller.php(85): IPS\core\modules\admin\settings\_advanced->runTask()
    #9 /home/nginx/domains/mywebsite.com/public/applications/core/modules/admin/settings/advanced.php(34): IPS\Dispatcher\_Controller->execute()
    #10 /home/nginx/domains/mywebsite.com/public/system/Dispatcher/Dispatcher.php(152): IPS\core\modules\admin\settings\_advanced->execute()
    #11 /home/nginx/domains/mywebsite.com/public/a2nimda/index.php(14): IPS\_Dispatcher->run()
    #12 {main}

    Error in Newsletter @HeadStand

    This was fixed in the patch I just pushed the other day....


  5. 9 hours ago, AlexWebsites said:

    @HeadStand, My unsubscribe links do not work as well for some reason. I'm using *|unsubscribe|* but the link it generates goes to page not found. Any ideas what could cause this? The link that it generates is like

    
    https://www.mysite.com/index.php?app=core&module=system&controller=redirect&url=https://www.mysite.com/index.php?app=core%26module=system%26controller=redirect%26url=https://www.mysite.com/newsletters/unsubscribe/%2526key=*%25257Cunsubscribe_key%######*%26key=ee##############################################################resource=%26email=1%26type=&key=ecdfd###########################################################resource=&email=1&type=

    Any ideas?

    Looks like it's picking up the redirector from inside the ACP. How are your tasks being triggered - by user activity or by cron job?

    Edit: one more thing - is your newsletter scheduled (daily/weekly/etc) or manual?


  6. A new version has been uploaded to the marketplace. This version includes tracking opens and clicks for each issue.

    At the moment, it only displays the total opens and clicks on the "Back Issues" screen. I do intend to add full charts so that you can see when things were opened, which newsletters have the best rate, etc.


  7. 3 hours ago, Janyour said:

    Please include at least the number of emails sent and recipients, its more then essentiel i think,

     

    That should be in the "Back Issues" screen of the newsletter. It would tell you how many were sent, and you can view the subscribers.


  8. On 10/22/2019 at 5:48 AM, Janyour said:

    Hello, any feature to see newsletters stats pelase ?

    Our weekly newsletter is sent every week but we dont know how many people receive it, who click, who open, .. !!

    Not at this time. It's something I have wanted to add for a while, but haven't had time to do it properly yet. 


  9. On 10/15/2019 at 7:54 AM, Janyour said:

    Hello, how to use specific smtp server for this app only ? we dont want to use the main smtp server.

    i tried to see for spark but its no more available on IPS

    I'm afraid a custom SMTP server is not currently supported.


  10. On 9/28/2019 at 8:36 AM, fix3r said:

    Does this support new videos from 

     ?

    Have you resolved this? If not, I"ll take a look.

    I've been offline for the last few days; it's Jewish holiday season, so my schedule is completely out of whack this entire month. Haven't been neglecting things, just haven't been working. 🙂

     

    3 hours ago, fix3r said:

    one file names from the gallery break out..

     

    508655696_ScreenShot2019-10-05at8_40_32PM.thumb.png.7a23660f35cfbf7da0cd869d3254a84a.pngl

    I'll fix this. Let me know about the previous issue so that I can do both in one shot (if necessary).


  11. A new version has been uploaded to the Marketplace. Changes include:

    • Optimizations for sites with a lot of hidden content
    • Topics did not have reactions displayed. Fixed.
    • When installed with other 3rd party apps, a template error was thrown (in some cases). Fixed.

  12. On 7/24/2019 at 5:54 PM, fix3r said:

    so the chatbox+ message don't show

    I'm not sure what you're referring to. What chatbox?

     

    On 7/24/2019 at 6:52 PM, fix3r said:

    Users can react to status updates but not to threads or posts, for $45 i really expected this to work

    Feed is not showing embedded videos

    Reactions should be working everywhere. Are there any messages or errors in your system logs when you try to react? Is the reaction button not showing at all, or is it not working? Please confirm.

    Re embedded videos: I originally included that and was specifically asked to strip them out. Can't make everyone happy. 😞 

     

    On 7/24/2019 at 8:13 PM, fix3r said:

    i have left a subpar review for this item, do not recommend 

    Your first post requesting support was at 1:25 PM EDT on Wednesday, and this post was at 8:13 PM on Wednesday. That's less than 7 hours after your first request. So I get a subpar review because I didn't DROP EVERYTHING IMMEDIATELY AND RESPOND the minute you posted? Nice! Thanks! 👏

     

    On 7/24/2019 at 8:21 PM, fix3r said:

    2063652012_ScreenShot2019-07-24at8_21_03PM.thumb.png.322a46fae1024eaa66a01bc8b63cbae0.png

    I have a fix for this issue locally and an update will be posted to the Marketplace today.

     

    On 7/24/2019 at 8:39 PM, fix3r said:

    app quit working , disabled awaiting support 

    Patience is a virtue.


  13. On 7/9/2019 at 5:44 AM, sound said:

     

    updated 3 weeks ago and just found out a weekly newletter hasn't been published since the update

    when try to manually publish via the acp get the following error message

    1ANNC/4 This newsletter has a distribution in progress and cannot be published at this time.

     

     

     

    this means that your newsletter has some old issue that was never completed properly. Check the "Back Issues" for your newsletter and see if there is anything that is still open; if so, you can just close it from that screen.

    I will have an update released soon with a few fixes, I'm just not ready yet. One of those fixes will be to kill distribution automatically after X days, so that this issue can be avoided.

    7 hours ago, AlexWebsites said:

    Further testing it seems to not happen when I disable Babble Chat by @CodingJungle. Oddly enough if both newsletters and babble chat are enabled, my /register/ link does not work. disable one or the other and it works fine.

    Thanks for finding this. CodingJungle and I are looking into it together.


  14. On 7/4/2019 at 4:42 PM, Christforums said:

    Also unsubscribe link doesn't work for my site. Takes people to page doesn't exists......

    I am unable to reproduce this issue. It would be helpful if you would post the link that you are being taken to. I fixed this problem a few months ago and haven't had any complaints since. Are you sure you're running the latest version? What version of IPS do you have? 

     


  15. On 6/28/2019 at 5:36 AM, Sonya* said:

    Additionally, I can configure what nodes I would like to show on the feed stream but I cannot configure what items (nodes) should be included in the block widget. Would it not be better to consider settings for the page in the widget as well?

    Node filtering should be the same in both places. What exactly is the issue? What are you not able to configure?

    On 6/28/2019 at 5:27 AM, Sonya* said:

    Suggestion: can we show only items that the user has a permission to write on in the widget? The reason is - we have over 200 clubs on the site. And all of them are shown in the social stream. This does not make sense for the most users as they are not members of clubs and will never be. Imagine, we have a pet site. There are cats, dogs, birds, spiders, rabbits and so on. Over 200 kinds of pets. And there are clubs for every kind of pet there. If I have rabbits and only rabbits, I am not interested in content of all other clubs. But my social stream is full of the content of other clubs.

    If only content where I am allowed to create a record or a comment is shown then I automatically see only global areas like AND my clubs where I am member of. This is what makes sense for the most users.

    Thank you!

     

    I'm not sure I agree with this. Most people want to see content they can view, not necessarily content they can reply to. That being said, I may be able to add some options specific to clubs, where the admin can decide if all visible club content should be shown, or if users should only see clubs to which they already belong. Will that work?


  16. On 6/5/2019 at 5:42 PM, Giray said:

    I reread the entire section and indeed, I think I'm not the only one that would like to have some more control over style. I guess we have to dig down into the templates and css, but I think there are basic changes you could implement in the supplied CSS, down the road?

    1. If I select two items in a multiple item field, the output is a comma with no space separating the two items. There shoulda at least be a space. Thoughts?
    2. If an editor field comes after any other field, the title of the field is single spaced (stuck to the previous field) but then the first line that was typed in the editor is double spaced (that's using plain text). Thoughts?

    Thanks!

    I will fix #1.

    #2 is not a styling issue. #2 is the actual editor content - it always inserts paragraph breaks around the text. If you don't want paragraph breaks, you'd need to use a TextArea instead of an editor (but of course then you wouldn't get any other formatting options).


  17. On 6/2/2019 at 9:56 AM, Giray said:

    Hi there.

    Couple of pre-purchase questions (not deal breakers).

    1. We agree that we can assign different field sets 'per' calendar?
    2. By any chance... I bought Club Categories (TheJackal) to have different 'types' of clubs. I need to have different fields for different club categories. Do you think it'll work?
    3. Same question with Collections (DevFuse)? I need to have different fields for different categories.

    Thanks!!

     

    PS. long time... 7 years.

    I remember you! 🙂

    1. Yes
    2. I don't integrate with 3rd party modifications out of the box unless they're using the Container/Item/Comment structure. Categories wouldn't use such a thing. That being said... I think Clubs itself supports custom fields. Does it not? Is it not enough for what you're trying to do? If not, we can talk privately about building a custom integration piece.
    3. I haven't ever seen the Collections modifications so I can't answer this question. If it uses the standard structure it should support it.
×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy