Jump to content
Invision Community

Jyosua

+Clients
  • Content count

    74
  • Joined

  • Last visited

About Jyosua

  • Rank
    Member
  • Birthday 04/17/1989
  1. Discord Integration

    Hey, what about that exception I posted when creating a new subforum? It's preventing my other admins from creating new subforums.
  2. Discord Integration

    I recently updated, which may or may not be related, but when I try to create a new subforum, I receive this error:
  3. Discord Integration

    I've noticed more instances of the old IPS4 Double-Post bug since I installed this plugin. Not entirely sure why, though.
  4. This still happens to me on 4.1.19.1.
  5. Discord Integration

    No problem and thanks for the integration module! It saved me a lot of work.
  6. Discord Integration

    Every time I tried to install this application, github or paid tar, I get this error. I tried looking through the install files for a possible conflict, but I don't see anything in the install queries that should cause this. I've never installed anything Discord-related in my IPS4 setup, either. I found this in my system logs: INSERT INTO `ibf_core_login_handlers` ( `login_settings`, `login_key`, `login_enabled`, `login_order`, `login_acp` ) VALUES ( '', 'Discord', 1, 14, 0 ) Duplicate entry 'Discord' for key 'PRIMARY' Was able to get past those issues by manually deleting the entry in the database, completely deleting the application folder files, and then reinstalling, but now I'm getting an error when trying to sign into discord on the Account Settings page: IPS\discord\Api\Exception\ForbiddenException: (0) #0 FORUMPATH/applications/discord/sources/Api/AbstractResponse.php(64): IPS\discord\Api\_AbstractResponse->throwException('403') #1 FORUMPATH/applications/discord/sources/Api/GuildMember.php(57): IPS\discord\Api\_AbstractResponse->handleApi() #2 FORUMPATH/system/Login/Discord.php(108): IPS\discord\Api\_GuildMember->update(Object(IPS\Member)) #3 FORUMPATH/applications/core/modules/front/system/settings.php(996): IPS\Login\_Discord->authenticate(Object(IPS\Http\Url\Friendly), Object(IPS\Member)) #4 [internal function]: IPS\core\modules\front\system\_settings->_profilesync() #5 FORUMPATH/applications/core/modules/front/system/settings.php(55): call_user_func(Array) #6 FORUMPATH/system/Dispatcher/Controller.php(97): IPS\core\modules\front\system\_settings->manage() #7 FORUMPATH/applications/core/modules/front/system/settings.php(35): IPS\Dispatcher\_Controller->execute() #8 FORUMPATH/system/Dispatcher/Dispatcher.php(129): IPS\core\modules\front\system\_settings->execute() #9 FORUMPATH/index.php(13): IPS\_Dispatcher->run() #10 {main} So this appears to be happening only to my account because of this response: array ( 'code' => 0, 'message' => 'Privilege is too low...', ) I'm guessing that because my account is the primary administrator, the integration does not have permission to modify my user on Discord at all. You might want to disable login on the Account Settings page for this case, or just handle this a bit better? It seems to work fine for other users.
  7. Wishlist for v3.2

    I would love a feature that would go through and tell you about unused folders and SQL tables, and offer to prune them for you.
  8. Download: (T30) Tickets System 1.0.0

    [quote name='tera
  9. Skin Generator for Mobile Skin

    Someone should certainly direct a staff member to this thread. :P
  10. Download: (T30) Tickets System 1.0.0

    FYI: THis no longer works on 3.1.0
  11. There should be an option in the skin generator to generate a mobile skin using the same colors. Just sayin'.
  12. I noticed when I upgraded to IPB 2.3.6, extra linebreaks were left behind when quotes were stripped, after you quote a post containing quotes. I opened a ticket about this, and they pointed me to the sources/classes/post/class_post.php file, which had the linebreak stripping line commented out. I uncommented it, however, that removed ALL linebreaks, which wasn't desired either. Instead, I resolved my issue by leaving that line commented out, and instead inserting the following before the quotestripping line: $tmp_post = preg_replace( "#(?:\n|\r|\r\n)(\ It effectively removed any extra linebreaks left behind from the quotestripping. You could integrate this into the quotestripping function, but I decided not to because I may want to change the way this is handled on my forum later. Anyways, I just wanted to let you guys be aware of this issue. :) I didn't post this in the bug section because it's not a bug per se, but I'm suggesting it be added.
×