Jump to content
Rikki
 Share


Support for PHP 5.4 ending soon

For our self-hosted customers, we wanted to give you advanced notice that support for PHP 5.4 in the IPS Community Suite will be ending soon. IPS Community Suite 4.1.11 will be the last release to support this version of PHP.

PHP 5.4 was released in 2012 and reached 'end of life' in September 2015, and so we will be requiring at least PHP 5.5 from IPS Community Suite 4.1.12 onwards. We do recommend PHP 5.6 or greater as 5.5 is approaching end of life as well.

If you currently use PHP 5.4, please contact your host and ask them to upgrade to a supported version as soon as possible.

If you would rather not have to worry about server-level issues like this, consider switching to one of our Community in the Cloud plans. They include all of our suite apps and we take care of all of the server management for you, leaving you to focus on running your community. If you are currently self-hosting, we can transfer your community to a cloud plan for free, in most cases. Contact our sales team for more information.

 Share

Comments

Recommended Comments



My 2 cents.

PHP 5.4.x is still the mainstream version in CentOS / EL 7.x. Removing support for PHP 5.4 will require an OS upgrade from service providers that are unwilling to install non-stock RPMs / Source files. Most providers wont do that, just look how many years it took them to switch Apache 1.3 to 2.0.

IPS should wait till EL8 is out before they remove support for PHP 5.4.

Link to comment
Share on other sites

23 hours ago, Jesper said:

My 2 cents.

PHP 5.4.x is still the mainstream version in CentOS / EL 7.x. Removing support for PHP 5.4 will require an OS upgrade from service providers that are unwilling to install non-stock RPMs / Source files. Most providers wont do that, just look how many years it took them to switch Apache 1.3 to 2.0.

IPS should wait till EL8 is out before they remove support for PHP 5.4.

CentOS 6.7 / EL6 latest official RPM's only have PHP 5.3.  So far I've not seen a true 6.7 to 7.x upgrade for CentOS, so anyone that needs to upgrade PHP either needs to use a 3rd party repo, or re-image their server with 7.x and re-install everything.  Even then, as you say, the official RPM's only have PHP 5.4.  So you're still stuck needing a 3rd party repo for anything higher.  

I understand the internet needs to advance, operating systems and hosting companies aren't keeping up.  Making 3rd party repositories mandatory and a proverbial mine-field when they just stop releasing updates.  

At least with MySQL, they have their own repository... You just have to add it and configure it.

Link to comment
Share on other sites

I agree with Charles etc on this. Invision must not be held back by old and insecure software.

I however am with a host (Servage - I am happy to name and shame) who do not offer a PHP version higher than 5.4 at the moment, so I will also be affected by the decision of Invision to remove support for PHP 5.4.

However I do not blame Invision for ending support. I blame Servage for not keeping up to date with technology. The decision of Invision has led me to contact Servage who state they are moving to a new control panel that will support greater versions of PHP than 5.5. However there is no ETA at this moment in time.

YOU are the customer. YOU have the power. I have made it clear in no uncertain terms that I will consider moving hosts if they do not pull their finger out, and I intend to move hosts if I do not receive a satisfactory answer.

TELL your hosts the truth. The fact that PHP 5.5, 5.6 and 7 are all stable versions of PHP. Most hosts will state PHP 7 is unstable and that is a blatant lie. What is usually the case is that they have a custom control panel which doesn't support PHP 7. They should be aware of PHP 7 and updating to add support as soon as possible.

TELL your hosts that by not updating their versions of PHP they are not taking seriously the security updates that have come with PHP 5.5, 5.6 and 7 and that by hosting with them they are leaving your websites open to attack.

Don't blame Invision for discontinuing support for a version of PHP that has been EOL for a while now... blame your hosts and tell them you are unhappy that they will not take the concerns seriously. Only with pressure will they perhaps decide to act more responsibly as hosts.

Link to comment
Share on other sites

On 21 April 2016 at 5:36 PM, Jesper said:

My 2 cents.

PHP 5.4.x is still the mainstream version in CentOS / EL 7.x. Removing support for PHP 5.4 will require an OS upgrade from service providers that are unwilling to install non-stock RPMs / Source files. Most providers wont do that, just look how many years it took them to switch Apache 1.3 to 2.0.

IPS should wait till EL8 is out before they remove support for PHP 5.4.

It's pretty easy to upgrade I believe even cPanel support 5.5+

Link to comment
Share on other sites




Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...