Jump to content
Mark
 Share


Get Ready For IPS 4.0!

IPS Community Suite 4.0, the most significant update to IP.Board and the rest of our apps we've ever made, is fast approaching a state where we'll be ready for a public preview and, soon after that, public beta testing!

We know most of you are just as excited as we are about this and can't wait to try it out.

With 4.0, we've made some significant leaps in terms of modernization, and it's possible that you might need to do some preparation before you're ready to install it. Notably, our minimum PHP and MySQL versions have gone up. It's the first time we've needed you to do this in 6 years, and the versions we need you to have have been around for a long time, we're not requiring the latest versions.

In addition, 4.0 is UTF-8 only (if you don't know what that is, it's a way text can be stored in your database which you may or may not be using at the moment) and while the 4.0 upgrade process will ask you to convert your database if you're not already using it, this is a moderately time-consuming process, so if you convert your database now, it's one less thing to worry about on upgrade day.


To make this process as easy as possible, we have created a little script which you can upload to your server to test if you're ready.

Download Now

 Share

Comments

Recommended Comments



 

1. It should be very quick, as your data is already UTF8, it's just changing the collation.

2. It will modify the existing tables.

 

Mark please consider the suggestion of separate database tables before gold release.

Link to comment
Share on other sites

 

Mark please consider the suggestion of separate database tables before gold release.

 

I had the same problem. i backuped my database before i run it to change the collation (only) via CLI. It was a flawless and fast process.

Link to comment
Share on other sites

Just had to convert the collations. Done, no problems. I also had to upgrade MYSQL. Couple of hiccups but my host came to the rescue. What's interesting is my forums are now quicker following the MYSQL upgrade. I'm now good to go for version 4 :smile:

Link to comment
Share on other sites

Warning to some. If using the option just to convert some columns etc in the utf8 converter it seems to remove some of the indexes. Should imagine large forums as mine would notice straight away (rendered my site useless), but smaller sites may not notice to begin with. Make sure you check the indexes within ACP after running.

Link to comment
Share on other sites

The converter is going unbelievably slow on my CentOS box.

 

IP.Board 3.4.6

MySQL 5.5

PHP 5.4.29

 

It's been running for 6 hours. For a forum with only 150,676 and 8,000 members, I'm positive this is a problem.

 

 

Wow, my stats are a little more than yours and it took no more than 30 minutes.   The tool worked great.

Link to comment
Share on other sites

I have! 

Convert your databse they said, it will be fun they said)

Web-interface does not work at all, via shell I converted database but got both orig_ and x_utf_ tables. I tried v.1.1.8 and now I got just orig_ tables and deleted x_utf_. I don`t beleive this thing really works)

Link to comment
Share on other sites

I have! 

Convert your databse they said, it will be fun they said)

Web-interface does not work at all, via shell I converted database but got both orig_ and x_utf_ tables. I tried v.1.1.8 and now I got just orig_ tables and deleted x_utf_. I don`t beleive this thing really works)

 

Hey man, start reading instead of saying its BS just cause you don't understand things.

 

It is supposed to get both orig_ and x_utf_ tables. Its a safe measure, so you can go back to the original tables if something got messed up.

 

PS: I converted to UTF8 just fine. So this thing, really works.

Link to comment
Share on other sites

 

Hey man, start reading instead of saying its BS just cause you don't understand things.

 

It is supposed to get both orig_ and x_utf_ tables. Its a safe measure, so you can go back to the original tables if something got messed up.

 

PS: I converted to UTF8 just fine. So this thing, really works.

 

I`m happy for you!

Everything works fine while orig_ and x_utf_ tables are both exist. But when I finish conversion, some of my tables prefixed orig_, some none prefixed and forum crashes or does not work correct. Is that clear? 

Link to comment
Share on other sites




Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...