Jump to content

Terms text and Footer links


Go to solution Solved by Marc Stridgen,

Recommended Posts

How to change the title "Registration Terms" on Terms of Use page to "Terms of Use"? Is there a language/strings Settings page to change this?

The terms should "always" apply even to view the site as a guest rather than apply only for registration.

2) How to add links in the Footer for Terms, etc?

Edited by WebCMS
Link to comment
Share on other sites

You would need to use the language system to modify the name of the Registration Terms if you wish to do that. Please see this guide: 

 

 

Adding anything to the footer which is not there would require a theme modification or plugin to do so.

Link to comment
Share on other sites

@Jim M Changing the language string for Terms of Use worked.

Why not render the Terms of Use and Guidelines links in the footer if they are not empty under System > Terms & Privacy Policy? Not sure why these links are not included in the footer but it is only logical to render them conditionally.

Thanks!

Edited by WebCMS
Link to comment
Share on other sites

I modified the footer template to add links and saved the template.

But when I re-open the footer template, it doesn't load the HTML in the editor (which loaded fine when I modified it). It shows the globalTemplate's html in the editor in the 1st tab but the footer tab's editor is empty. The footer template list item on the left has a "M" icon to its right. I have multiple themes.

What am I doing wrong?

Could contain: Page, Text, File, Computer Hardware, Electronics, Hardware, Monitor, Screen

Link to comment
Share on other sites

7 hours ago, Marc Stridgen said:

Is there perhaps anything showin up within console on your browser?

 

7 hours ago, Randy Calvert said:

And are you using a WAF like cloudflare?  If so try disabling it temporarily. 

 

My app is on invisionservice.com cloud service. Nothing related to its hosting is in my control.

Here is the console output - a JS glitch:

admin_admin_templates.js.gz?v=d815db93211697539050:34 Uncaught TypeError: Right-hand side of 'instanceof' is not an object
    at baseController._updateToolbar (admin_admin_templates.js.gz?v=d815db93211697539050:34:26)
    at baseController.changedTab (admin_admin_templates.js.gz?v=d815db93211697539050:31:6)
    at nr (root_library.js.gz?v=d815db93211697539050:1:7597)
    at HTMLDivElement.<anonymous> (root_library.js.gz?v=d815db93211697539050:1:8025)
    at HTMLDivElement.<anonymous> (root_library.js.gz?v=d815db93211697539050:1:1076)
    at HTMLDivElement.dispatch (root_library.js.gz?v=d815db93211697539050:2:39997)
    at v.handle (root_library.js.gz?v=d815db93211697539050:2:37968)
    at Object.trigger (root_library.js.gz?v=d815db93211697539050:2:70063)
    at HTMLUListElement.<anonymous> (root_library.js.gz?v=d815db93211697539050:2:70665)
    at Function.each (root_library.js.gz?v=d815db93211697539050:2:3129)

Edited by WebCMS
Link to comment
Share on other sites

On 10/18/2023 at 2:16 AM, Marc Stridgen said:

If you revert that template, do things show up properly? It looks like there is an issue with your code there thats actually breaking the page 

I tried after a couple of days and I'm able to edit the footer template without having to Revert the prior changes.

I don't see any errors in the browser's console.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...