Jump to content

Get error "Template core/admin/global/globalTemplate is throwing an error" when accessing AdminCP

Recommended Posts

I moved my self-hosted IPS to a newly installed server. Now I wanted to upgrade to the latest 4.7.x version, bus wheen trying to access the AdminCP, I get this error:

[[Template core/admin/global/globalTemplate is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

I tried adding the following line to constants.php:

\define('RECOVERY_MODE', true);

This lets me log into the AdminCP, and the recovery mode runs. It claims to have reset the default theme, but as soon as I remove the RECOVERY_MODE line again, I geet the same error as mentioned above again. It seems as if the themee revert did not do anything. Maybe I don't havbe write permissions on a folder - but which?

I also looked into the database table "core_log" and found this:

Error: Call to undefined method IPS\Dispatcher\Admin::showSwitchLink() in /var/customers/webs/(CENSORED)/htdocs/system/Theme/Theme.php(860) : eval()'d code:1594
Stack trace:
#0 /var/customers/webs/(CENSORED)/htdocs/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_core_admin_global->globalTemplate()
#1 /var/customers/webs/(CENSORED)/htdocs/system/Dispatcher/Dispatcher.php(173): IPS\Theme\_SandboxedTemplate->__call()
#2 /var/customers/webs/(CENSORED)/htdocs/system/Dispatcher/Standard.php(113): IPS\_Dispatcher->finish()
#3 /var/customers/webs/(CENSORED)/htdocs/system/Dispatcher/Dispatcher.php(155): IPS\Dispatcher\_Standard->finish()
#4 /var/customers/webs/(CENSORED)/htdocs/warehouse/index.php(13): IPS\_Dispatcher->run()
#5 {main}

So, somewhere the method IPS\Dispatcher\Admin::showSwitchLink() gets called, but I don't know where...

Any suggestions?


Link to comment
Share on other sites

Well, the call to the method is in the globalTemplate template.

The error message indicates that either:

the file /system/dispatcher/admin.php no longer exists (you'd have loads of other errors too if that was the case)


the function showSwitchLink doesn't exist in the mentioned file.


Edited by Nathan Explosion
Link to comment
Share on other sites

As you are  not on the latest release, and that's what you are attempting to do anyway, upload a fresh set of files from your client area, and upgrade at /admin/upgrade instead. This should resolve what you are seeing there as it does eem to indicate you are missing things.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...