Jump to content

bug - approving scheduled articles flawed


Recommended Posts

 

Our current articles setup - all articles submitted by members need to be approved

 

a member submits an article

the admin edits the article and schedules it to be published 24 hours later

the admin then approves the article (this can only be done via the front end)

though the article is still awaiting publishing and so should be still hidden after approval - it now shows to all but still has the 'clock' icon showing awaiting publication

 

therefore it appears that when the admin 'approves' the article the system is setting the wrong permissions on the article causing it to show to all

Link to comment
Share on other sites

What you are seeing is correct in terms of a clock icon showing, but it would only show to people who have access to view hidden items, and the author. If you believe this not to be the case, we would need an example item, user who can see it, and where they can see it. 

Link to comment
Share on other sites

On 4/20/2023 at 11:07 AM, Marc Stridgen said:

What you are seeing is correct in terms of a clock icon showing, but it would only show to people who have access to view hidden items, and the author. If you believe this not to be the case, we would need an example item, user who can see it, and where they can see it. 

 

On 4/19/2023 at 11:54 AM, sound said:

 

Our current articles setup - all articles submitted by members need to be approved

 

a member submits an article

the admin edits the article and schedules it to be published 24 hours later

the admin then approves the article (this can only be done via the front end)

though the article is still awaiting publishing and so should be still hidden after approval - it now shows to all but still has the 'clock' icon showing awaiting publication

 

therefore it appears that when the admin 'approves' the article the system is setting the wrong permissions on the article causing it to show to all

 

ok set up a test article 

 

here's the flow

articles are setup so members can post articles but the article needs 'approval'

1 . member posted an article - as above it now needs approval

2. article scheduled to publish in two months by admin

3. article then 'approved' by admin on the front end

 

resulting in the article now showing in full public view - when it should not show - plus the 'clock' showing

 

have pm'd you a link so you can see this in the real world

 

as said it seems the 'approval' process is flawed , possibly skipping the 'published' aspect  completely

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...