Jump to content

[Bug] INT-> BIGINT on gallery_images.image_file_size


H5K

Recommended Posts

Hi,

Our community allows users to upload very large videos to the gallery. We recently had to change the image_file_size column datatype in the gallery_images table from INT to BIGINT to support this.

Reporting this because now we're getting a warning in the AdminCP because we changed the table. Tagging @Olivia Clark and @Andy Millne since you two seem to be very familiar with the recent gallery changes and probably can confirm if this is a bug or intended.

Thanks

Edited by H5K
Link to comment
Share on other sites

19 hours ago, Marc Stridgen said:

That would be intended. If you change a field type, the system will notice that field type as being outside what the default is, and try to correct it

Thank you for the response and apologies for the confusion. I was not questioning whether the table modification message was intended or not.

I am questioning whether it is intended for gallery_images.image_file_size to be an int and not a bigint. The gallery has recently improved support for videos which can be considerably large. The reason we had to change the column datatype is because our users got an error when they tried to upload videos that were too large.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...