Jump to content

Invision Community upgrade from 4.4.7 to 4.7.7 [FILES PROBLEM]

Recommended Posts


I'm having some problems upgrading my forum to the newest version (4.7.7). I've done everything under "Manual upgrade" part in the Guide.

After updating PHP 7.4.x -> 8.1.8, copying all files successfully from the package downloaded in the "Client Area" and then proceeding on the "/admin/upgrade", I'm having this communicate for files under "/applications/blog/*" and "/applications/gallery/*" -> "If you are sure the files have been uploaded correctly, make sure the permissions are set correctly on them." (other requirements are green), but I only have subscription for the "Forums" package, however I've seen that in my older installation there were folders "/applications/blog/" and "/applications/gallery/", but I've never subscribed to them.

I've tried adding bellow to the "constants.php" and also deleting the "blog/" and "gallery/", but the "/admin/upgrade" page is still listing them as incorrect.

\define( 'IPS_FOLDER_PERMISSION', 0777 );
\define( 'IPS_FILE_PERMISSION' , 0777 );


Could contain: Page, Text, File

Link to comment
Share on other sites

4 hours ago, Pawel Czechowski said:

@Marc StridgenHow to properly uninstall them from the root folder (I can't do the rollback to get my AdminCP back)? I don't see any uninstall script or anything, also I've tried simply removing them from "/applications/" catalog, but it seems to not be the case.

These are in your database so you would need to restore a backup of files and database to get back to where you were before the upgrade attempt or if you want to move forward using those applications, you would need to purchase those applications for your license.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...