Jump to content

HTMLPurifier - UnitConverter.php error


Recommended Posts

This is happening often on the website by some members... wonder what it could be.

TypeError: abs(): Argument #1 ($num) must be of type int|float, string given in /var/www/html/107602/system/3rd_party/HTMLPurifier/HTMLPurifier/UnitConverter.php:264
Stack trace:
#0 /var/www/html/107602/system/3rd_party/HTMLPurifier/HTMLPurifier/UnitConverter.php(264): abs('0,0000000000')
#1 /var/www/html/107602/system/3rd_party/HTMLPurifier/HTMLPurifier/UnitConverter.php(178): HTMLPurifier_UnitConverter->round('0,0000000000', 4)
#2 /var/www/html/107602/system/3rd_party/HTMLPurifier/HTMLPurifier/Length.php(153): HTMLPurifier_UnitConverter->convert(Object(HTMLPurifier_Length), 'pt')
#3 /var/www/html/107602/system/3rd_party/HTMLPurifier/HTMLPurifier/AttrDef/CSS/Length.php(65): HTMLPurifier_Length->compareTo(Object(HTMLPurifier_Length))
#4 /var/www/html/107602/system/3rd_party/HTMLPurifier/HTMLPurifier/AttrDef/CSS/Composite.php(39): HTMLPurifier_AttrDef_CSS_Length->validate('0pt', Object(HTMLPurifier_Config), Object(HTMLPurifier_Context))
#5 /var/www/html/107602/system/3rd_party/HTMLPurifier/HTMLPurifier/AttrDef/CSS/Multiple.php(58): HTMLPurifier_AttrDef_CSS_Composite->validate('0pt', Object(HTMLPurifier_Config), Object(HTMLPurifier_Context))
#6 /var/www/html/107602/system/3rd_party/HTMLPurifier/HTMLPurifier/AttrDef/CSS/Border.php(44): HTMLPurifier_AttrDef_CSS_Multiple->validate('0pt', Object(HTMLPurifier_Config), Object(HTMLPurifier_Context))
#7 /var/www/html/107602/system/3rd_party/HTMLPurifier/HTMLPurifier/AttrDef/CSS.php(103): HTMLPurifier_AttrDef_CSS_Border->validate('0pt none', Object(HTMLPurifier_Config), Object(HTMLPurifier_Context))
#8 /var/www/html/107602/system/3rd_party/HTMLPurifier/HTMLPurifier/AttrValidator.php(96): HTMLPurifier_AttrDef_CSS->validate('border: 0pt non...', Object(HTMLPurifier_Config), Object(HTMLPurifier_Context))
#9 /var/www/html/107602/system/3rd_party/HTMLPurifier/HTMLPurifier/Strategy/ValidateAttributes.php(38): HTMLPurifier_AttrValidator->validateToken(Object(HTMLPurifier_Token_Start), Object(HTMLPurifier_Config), Object(HTMLPurifier_Context))
#10 /var/www/html/107602/system/3rd_party/HTMLPurifier/HTMLPurifier/Strategy/Composite.php(24): HTMLPurifier_Strategy_ValidateAttributes->execute(Array, Object(HTMLPurifier_Config), Object(HTMLPurifier_Context))
#11 /var/www/html/107602/system/3rd_party/HTMLPurifier/HTMLPurifier.php(211): HTMLPurifier_Strategy_Composite->execute(Array, Object(HTMLPurifier_Config), Object(HTMLPurifier_Context))
#12 /var/www/html/107602/system/Text/Parser.php(265): HTMLPurifier->purify('<header class="...')
#13 /var/www/html/107602/system/Text/Parser.php(233): IPS\Text\_Parser->purify('<header class="...')
#14 /var/www/html/107602/system/Helpers/Form/Editor.php(424): IPS\Text\_Parser->parse('<header class="...')
#15 /var/www/html/107602/system/Helpers/Form/FormAbstract.php(167): IPS\Helpers\Form\_Editor->getValue()
#16 /var/www/html/107602/system/Helpers/Form/Editor.php(569): IPS\Helpers\Form\_FormAbstract->setValue(true, false)
#17 /var/www/html/107602/system/Helpers/Form/FormAbstract.php(147): IPS\Helpers\Form\_Editor->setValue(true)
#18 /var/www/html/107602/system/Helpers/Form/Editor.php(212): IPS\Helpers\Form\_FormAbstract->__construct('topic_comment_7...', NULL, true, Array, Object(Closure), NULL, NULL, NULL)
#19 /var/www/html/107602/system/Content/Item.php(4977): IPS\Helpers\Form\_Editor->__construct('topic_comment_7...', NULL, true, Array, Object(Closure))
#20 /var/www/html/107602/system/Content/Item.php(4654): IPS\Content\_Item->commentFormElements()
#21 /var/www/html/107602/system/Theme/Theme.php(885) : eval()'d code(5327): IPS\Content\_Item->commentForm()
#22 /var/www/html/107602/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_forums_front_topics->topic(Object(IPS\forums\Topic), Array, NULL, Array, true, '\n\n\n\t\n\t<ul class...', Array)
#23 /var/www/html/107602/applications/forums/modules/front/forums/topic.php(576): IPS\Theme\_SandboxedTemplate->__call('topic', Array)
#24 /var/www/html/107602/system/Dispatcher/Controller.php(118): IPS\forums\modules\front\forums\_topic->manage()
#25 /var/www/html/107602/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#26 /var/www/html/107602/applications/forums/modules/front/forums/topic.php(39): IPS\Content\_Controller->execute()
#27 /var/www/html/107602/init.php(932) : eval()'d code(21): IPS\forums\modules\front\forums\_topic->execute()
#28 /var/www/html/107602/system/Dispatcher/Dispatcher.php(153): IPS\forums\modules\front\forums\tthumb_hook_forums_module_topic->execute()
#29 /var/www/html/107602/index.php(13): IPS\_Dispatcher->run()
#30 {main}

#0 /var/www/html/107602/system/Theme/SandboxedTemplate.php(71): IPS\_Log::log(Object(TypeError), 'template_error')
#1 /var/www/html/107602/applications/forums/modules/front/forums/topic.php(576): IPS\Theme\_SandboxedTemplate->__call('topic', Array)
#2 /var/www/html/107602/system/Dispatcher/Controller.php(118): IPS\forums\modules\front\forums\_topic->manage()
#3 /var/www/html/107602/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#4 /var/www/html/107602/applications/forums/modules/front/forums/topic.php(39): IPS\Content\_Controller->execute()
#5 /var/www/html/107602/init.php(932) : eval()'d code(21): IPS\forums\modules\front\forums\_topic->execute()
#6 /var/www/html/107602/system/Dispatcher/Dispatcher.php(153): IPS\forums\modules\front\forums\tthumb_hook_forums_module_topic->execute()
#7 /var/www/html/107602/index.php(13): IPS\_Dispatcher->run()
#8 {main}

Link to comment
Share on other sites

Looking in your community's system log errors, I do see these occurring. However, grabbing the content from the post that an admin account and another user's posted (which was nearly identical), I am unable to reproduce this. 

Are you seeing this with certain content you or your members are posting?

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...