Jump to content

Error during upgrade

Recommended Posts

15 hours ago, Jamie_Beatson said:

Hi there - I've done that but I'm not seeing any issues in Admin CP/Support. The only thing showing is "Enable utf8mb4" - though the system won't let me convert the database.

Is that likely to be the root issue?

It is indeed likely related. Also compact row format if that is showing. You mention you the system wont let you convert it. What is actually happening when you try?

Link to comment
Share on other sites

It's a bit weird - yesterday it simply wouldn't let me convert the database - it just failed. I didn't save a copy of what came up because I ran out of time and was coming back to work on it today.

Today I've got further with it - it appears to have gone through the conversion process and I then get to this message:

In order to finish the conversion:

  1. Open the /home/weareper/public_html/wapforum/conf_global.php on your server.
  2. Locate the sql_utf8mb4 declaration, which may look like this:
    'sql_utf8mb4' => false,
    Or like this:
    $INFO['sql_utf8mb4'] = false;
  3. Change the false to true. If neither line exists, add the second version to the end of the file and change the false to true. Do not change any other aspect, including any comma or semi-colon after the false

I've gone into the relevant file and the second line already exists in the conf_global.php file. It was already flagged as true. I then click the finish button and it just goes back to the same page - nothing changes and it doesn't appear to complete the process.

Link to comment
Share on other sites

We would need to look further into this for you, however the access details on file appear to be incorrect or missing. Could you please update these details by visiting your client area, selecting the relevant purchase, then clicking "Review/Update Access Information" under the "Stored Access Information" section. 

We look forward to further assisting you. 


Link to comment
Share on other sites

  • 1 month later...

Hi there- bringing this back up as I'm only now getting time after the holidays to revisit this issue.

I've converted my tables to dynamic row format - I've checked the information_schema on my database and they are all showing as dynamic. I've had to alter them all manually as I don't appear to have permissions via my hosting provider to set dynamic as the default row format.

I'm now back with the same issue I was having in my December 1 post - I can't complete the Enable utf8mb4 process. I'm still getting the same issue where it goes through the conversion process then asks me to change the variable in conf_global.php to true (it is already set to true) - but when I press "Finish" nothing happens and it just refreshes the same page.

Any further suggestions?

Link to comment
Share on other sites

Running the upgrade again and getting the same error as the first time round:


Specified key was too long; max key length is 1000 bytes


Have confirmed that the row in the table is set to Dynamic and I can't see a reason why I can't go any further. Any ideas?

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...