Jump to content

missing hovercard in the "Who's online" widget


ossipetz
 Share

Go to solution Solved by Daniel F,

Recommended Posts

Hello

we encounter a rather strange behavior with the "Who's online" widget. It usually shows a hovercard for the online members.

this seems to always work when using the english translation.

when switching to the german language pack (from invisionfocus, from the marketplace), the usernames sometimes are not rendered as links and don't show that hovercard:

English as expected:

Could contain: Page, Text

German as expected:

Could contain: Page, Text

Germ, rendered without the links / hovercard:

Could contain: Page, Text

 

Also the html does not contain any links. But weirdly the current user ("wm") is not even in the html list.

Good variant:

Could contain: Page, Text, File, Bird, Animal

 

Weird variant (no hovercard link, current user not in the list but shown in the browser):

Could contain: Page, Text, File, White Board

 

What we tried:

  • deleted the language pack, reinstalled from marketplace. issues shows up again.
  • clearing the system cache usually resolves this issue for some time.
  • we compared all the templates if there are any changes we missed during the upgrades. But we have no changes in the templates that points at this weirdness.
  • disabled the redis cache. issue still shows up.
  • logs contain no errors or indicators whats going on.

 

The template userLinkFromData is unchanged:

Could contain: Page, Text, File

But it's hard to read.

 

It's very strange this only happens in the german language pack. If there is a missing translation that causes this we cannot find it. And sometimes it just works normally.

Has anyone else noticed this? (Invision Community v4.7.4 - but we think this existed before this version too)

Link to comment
Share on other sites

1 hour ago, ossipetz said:

It's very strange this only happens in the german language pack. If there is a missing translation that causes this we cannot find it. And sometimes it just works normally.

Has anyone else noticed this? (Invision Community v4.7.4 - but we think this existed before this version too)

Confirm this, but it makes no difference what language, and I guess we are using the same german language pack.

Link to comment
Share on other sites

9 hours ago, Marc Stridgen said:

Could you please confirm you are seeing it on a default unaltered language, and also logged in

Hi Marc, I couldn't reproduce this issue. But I am sure (to 90%) it was on the original language and logged in. But I guess it had something to do with caching.

Link to comment
Share on other sites

On 11/28/2022 at 7:46 PM, Jim M said:

Please contact the author of the language pack as there is likely something incorrect causing an issue.

well I can do that, but I would not know what to ask them. They are probably "translation" people. Not debug-random-things-people. I would send myself back to here. If the language file can be imported, nothing can be wrong with it. I try to find a better clue or better question.

It is most probably a cache issue. If I clear all caches the widget is correct. Only after a while it renders that logged out variant - but I'm still logged in (I can see an admin-only forum for example).

Not sure how that can be caused by a language pack - as it works with an empty cache. Maybe the cache mechanism includes some language aspect somehow and doesn't work for non-english? It's just weird. None of the translation keys in that widget seem to be untranslated. But I might have missed one 🤔

Link to comment
Share on other sites

2 minutes ago, ossipetz said:

well I can do that, but I would not know what to ask them. They are probably "translation" people. Not debug-random-things-people. I would send myself back to here. If the language file can be imported, nothing can be wrong with it. I try to find a better clue or better question.

It is most probably a cache issue. If I clear all caches the widget is correct. Only after a while it renders that logged out variant - but I'm still logged in (I can see an admin-only forum for example).

Not sure how that can be caused by a language pack - as it works with an empty cache. Maybe the cache mechanism includes some language aspect somehow and doesn't work for non-english? It's just weird. None of the translation keys in that widget seem to be untranslated. But I might have missed one 🤔

Confirming the language pack is compatible with the release you're on is the first step. However, I would say this sounds like a caching issue.

Are you able to reproduce this on an unmodified language pack if you stay on it for long?

 

Link to comment
Share on other sites

I’ve seen this problem with several blocks (e.g. recent achievements) and remember forum discussion about this. 

Usually, it doesn’t appear because blocks like those don’t need to differentiate between guests and members. But since privacy is a bigger concern in Germany, German websites will often hide the member profiles from guests. And then there would need to be a difference between the cached guest block and the cached member block. Apparently there is none. So whenever the block caching time is over, the status of the first visitor of the page will decide whether everyone sees the guest version or the member version for the next 5 minutes or so. 

Link to comment
Share on other sites

  • Solution
6 minutes ago, opentype said:

I’ve seen this problem with several blocks (e.g. recent achievements) and remember forum discussion about this. 

Usually, it doesn’t appear because blocks like those don’t need to differentiate between guests and members. But since privacy is a bigger concern in Germany, German websites will often hide the member profiles from guests. And then there would need to be a difference between the cached guest block and the cached member block. Apparently there is none. So whenever the block caching time is over, the status of the first visitor of the page will decide whether everyone sees the guest version or the member version for the next 5 minutes or so. 

Love the finding! And I can confirm that @ossipetz has them disabled for guests.
We have a bug report for this

Link to comment
Share on other sites

  • 1 month later...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...