Jump to content

Background processing after conversion horrible, horrible slow


Ramsesx
 Share

Go to solution Solved by opentype,

Recommended Posts

Using webservice easy cron since 35 hrs. now but the pace of the tasks are absolutely horrible slow. At this rate, it will probably take several weeks to finish. Rebuilding posts is now at

 
Rebuilding posts 32,55%
 
Two days ago it was at 24%. There must be something wrong.
 
Edited by Ramsesx
Link to comment
Share on other sites

Depending on your server it’s also worth to try to increase following constant values

 

                // Maximum number of things to rebuild per cycle for background tasks
                'REBUILD_INTENSE' => 1, // For extremely intensive routines, such as rebuilding images
                'REBUILD_SLOW'    => 50,    // For routines that take a while
                'REBUILD_NORMAL'    => 250,    // For most routines
                'REBUILD_QUICK'    => 500,    // For routines that are fast
                
    

Link to comment
Share on other sites

Ok, this looks way better. So one question, if I run this at manual mode, it processes some stuff and after gets to a white page and I have it to start again. Is this the normal behavior?

 

21 minutes ago, Daniel F said:

 // Maximum number of things to rebuild per cycle for background tasks
                'REBUILD_INTENSE' => 1, // For extremely intensive routines, such as rebuilding images
                'REBUILD_SLOW'    => 50,    // For routines that take a while
                'REBUILD_NORMAL'    => 250,    // For most routines
                'REBUILD_QUICK'    => 500,    // For routines that are fast

I don't have access to my server.

Will continue on evening, have to go for now. Thanks for helping.

Link to comment
Share on other sites

My final solution now, I run it on browser, but it's always timing out. So I installed a plugin for firefox where the page autoloads after a given time (2 minutes). The dry and dirty way how to do the job. Looks way better now and tomorror it should be completed. Thank y'all for helping.

Link to comment
Share on other sites

So, after the most time consuming tasks have ran through, it stops now on the task: Rebuilding Gallery Images at 23,58 %

I have added the value into the conf_global.php (?) like suggested by @Daniel F

 'REBUILD_INTENSE' => 1, // For extremely intensive routines, such as rebuilding images

There are only 14 images in the gallery...

 

Link to comment
Share on other sites

1 hour ago, Ramsesx said:

So, after the most time consuming tasks have ran through, it stops now on the task: Rebuilding Gallery Images at 23,58 %

I have added the value into the conf_global.php (?) like suggested by @Daniel F

 'REBUILD_INTENSE' => 1, // For extremely intensive routines, such as rebuilding images

There are only 14 images in the gallery...

 

You would want to up the number there as 1 is default settings.

Additionally, it’s worth mentioning if you’re still hitting a white screen, this could be a server error you’re hitting and simply ignoring this and reloading the page will not allow this to progress. You will need to engage your hosting provider to figure out the error and if it is a software error, please pass it to us here. 

Link to comment
Share on other sites

1 hour ago, Jim M said:

Additionally, it’s worth mentioning if you’re still hitting a white screen, this could be a server error you’re hitting and simply ignoring this and reloading the page will not allow this to progress.

Thanks, after some researching I found out that I have to add

php_value max_execution_time 300 into my .htaccess

Now the background process runs smoothly without timing out.

Edited by Ramsesx
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...