Jump to content

Moving Server Issue

Recommended Posts

Hi all,

I have a small self-hosted community, and am trying to move from one hosting platform to another.

I have followed the Moving to Another Server guide but I have encountered a problem I'm unsure how to get around.

Everything is moved over and I can access the front page of my community, but when I try to login to the ACP, I get this error:

[[Template core/admin/global/globalTemplate is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

No matter what I try, I cannot get into the ACP to run the support tool.

Additionally to the above, navigating away from the homepage generates a 404 error. I suspect this might be to to do with Friendly URLS which was enabled on the old server, but because my community now operated on a new URL, I need to update something in the ACP? Config_Globals is updated with the new URL. 

I'm sure there's something simple I've missed.

IPB 4.6.9

Let me know if you need any info.

Any help greatly appreciated.


 (.htaccess file in case it helps in relation to the friendly URLs problem)

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(js|css|jpeg|jpg|gif|png|ico|map)(\?|$) /404error.php [L,NC]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]


Link to comment
Share on other sites

Hi Mark,

Thanks for quick reply.

PHP Version is 7.4 and this was the same on the old server, but admittedly I don't know if it's the exact same version. (7.4.xx)

I ran the recovery mode, whcih did revert my forum to the default theme, but I still get the same error when trying to login to the ACP. Also still getting the 404 errors when navigating outside the front page.

Don't suppose you have any other suggestions?


EDIT: Sorry forgot to add, logs file is empty (I did double check permissions of the folder to make sure it's writable)




Edited by Jonathan G
Link to comment
Share on other sites

Thank you both for your suggestions.

The error log didn't show anything related to the issue,

However I added the ISP4.PHP file and it highlighted an issue with the PHP version. It seems my new host is using PHP 7.3 and not 7.4. Not quite sure how I missed that. My new host advised me they were using 7.4, but it looks like they have a different server for PHPMyAdmin which is on 7.4 which is where they took the information from.

I assume the only way to fix is to get my server host to change to 7.4?

Link to comment
Share on other sites

Yes, your host needs to make that change to PHP 7.4.

Once they do you should be able to get up and running again, or at least to the point that recovery mode will work.

(Also please remember that the current version of IPS Community, v4.7.4, requires PHP 8.x so you should also ask your host if that can be made the default, when you upgrade from 4.6.9 to 4.7.4)

Link to comment
Share on other sites

Sorry for the late reply.

Host updated to PHP 7.4, which didn't resolve the issue with the ACP, but did fix navigating to other pages on the site other than the front page. 

When I looked at the ACP error message again, it made me think when moving to the new server, one of the files hadn't transferred properly/corrupted somehow. I re-uploaded a fresh copy of the files and this resolved the issue with the ACP.

Thanks for all the suggestions guys. Bit of an odd one but all down to my lack of knowledge/common sense. 🙂


Edited by Jonathan G
Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...