Jump to content

Docker stack (NGINX / PHP-FPM / MARIA) and upgrading


Go to solution Solved by Randy Calvert,

Recommended Posts

Hey guys,

 

For our community we run a docker stack on an azure machine.

 

It's comprised of:

 

- Nginx

- PHP-FPM (7.3)

- Mariadb (10.2)

- Certbot for https certs

- Some helper containers

Currently we run IPS 4.5.2.

As PHP 8.0 will be recommended for new version I wanted to test if the upgrade procedure was working correctly.
Therefore I took a backup of the database, spun up a new stack with the same settings and tried upgrading the php-fpm container to 8.0.

Before the new container, I can access the staging environment just fine.
After the new php-fpm container I notice that it just keeps loading until the max_execution_time is hit, and then it proceeds to dump some code in the browser, without any error messages.

Any ideas? Should I try a more "baby steps" approach using a 7.4 container?

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...