Jump to content

PHP8 error


Michael R
 Share

Go to solution Solved by Michael R,

Recommended Posts

After switching to back to PHP 7.4 from PHP 8.1, I can no longer access the AdminCP. I am getting the error below. How can I access AdminCP to restore?

 

[[Template core/admin/global/globalTemplate is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

Link to comment
Share on other sites

4 minutes ago, Michael R said:

After switching to back to PHP 7.4 from PHP 8.1, I can no longer access the AdminCP. I am getting the error below. How can I access AdminCP to restore?

 

[[Template core/admin/global/globalTemplate is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

Can you temporarily switch back to 8.1 to look at the global template for customizations?

Link to comment
Share on other sites

13 minutes ago, Chris027 said:

Can you temporarily switch back to 8.1 to look at the global template for customizations?

Catch 22. No error. Just a blank screen now. This is getting really frustrating.And I still can't access admin.

3 minutes ago, Michael R said:

Catch 22. No error. Just a blank screen now. This is getting really frustrating.And I still can't access admin.

I have all the incompatible 3rd party apps turned off too.

Edited by Michael R
Link to comment
Share on other sites

I was able to switch back to 7.4 but I cannot get into admin. Gives me the same error. I miss the days when I had technical support...

At this rate, if I cannot fix it I may have to close the site all together. It should not be this hard.. I've been a customer 17 years and it all has to stop because I can't do a simple move to PHP 8.

Edited by Michael R
Link to comment
Share on other sites

Just now, Michael R said:

I was able to switch back to 7.4 but I cannot get into admin. Give me the error. I miss the days when I we had technical support...

At this rate, if I cannot fix it I may have to close the site all together. It should not be this hard.. I've been a customer 17 years and it all has to stop because I can't do a simple move to PHP 8.

What error are you getting when trying to access the ACP?  

Have you tried using Recovery Mode?  

Once you set your constants file, clear your browser cache (to make sure you don't have an active ACP session) or just use a different browser.  Login to ACP.  It will run through a process to disable anything in the ACP that might be messing things up.  Once done, it will tell you to remove the constants.php variable.  You should have access to ACP again and can re-enable plugins, themes, etc one at a time.  

Link to comment
Share on other sites

I split this into your own support topic so we can assist you. Let’s please not do anything further while I take a look at this for you. I will comment back here soon with what I find. 

@Michael R, could you please ensure that the FTP access details on file are correct? Seems I am getting timeout issues.

Link to comment
Share on other sites

Thanks, so I am back to where I started.

I want to upgrade to move to 8 before November.

I have disabled all the incompatible third party applications.

I switch to PHP 8, but can no longer access site - using default theme.

Do I need to remove all  incompatible customization to move to PHP 8?

Edited by Michael R
Link to comment
Share on other sites

5 minutes ago, Michael R said:

Thanks, so I am back to where I started.

I want to upgrade to move to 8 before November.

I have disabled all the incompatible third party applications.

I switch to PHP 8, but can no longer access site - using default theme.

Do I need to remove all  incompatible customization to move to PHP 8?

What is the error you receive on PHP 8? That needs to be provided here and we can provide further direction.

Link to comment
Share on other sites

Just now, Michael R said:

There is no error. Only a blank screen.

That would be a suppressed server error. You would need to gather the error from your Server Error log. If you do not have access to this or unsure how to gather it, please contact your hosting provider. 

Link to comment
Share on other sites

Not sure if this helps.

 

Quote

We have checked the logs and found the following errors

============

[Sat Oct 15 18:57:24.481927 2022] [proxy_fcgi:error] [pid 7981:tid 48007828895488] [client 70.188.137.225:59165] AH01079: failed to make connection to backend: httpd-UDS, referer: https://clausnet.com/discover/unread/
[Sat Oct 15 18:57:24.516949 2022] [mpm_worker:notice] [pid 19580:tid 48007540429888] AH00297: SIGUSR1 received. Doing graceful restart
[Sat Oct 15 18:57:25.565027 2022] [:notice] [pid 7978:tid 48007540429888] [host server.clausnet.com] mod_lsapi: Selfstarter 7978 stopped
[Sat Oct 15 18:57:25.610146 2022] [lsapi:notice] [pid 19580:tid 48007540429888] mod_lsapi: version 1.1-34
[Sat Oct 15 18:57:25.610888 2022] [:notice] [pid 9711:tid 48007540429888] [host server.clausnet.com] mod_lsapi: Selfstarter 9711 started
[Sat Oct 15 18:57:25.618887 2022] [http2:info] [pid 19580:tid 48007540429888] AH03090: mod_http2 (v1.15.28, feats=CHPRIO+SHA256+INVHD+DWINS, nghttp2 1.49.0), initializing...
[Sat Oct 15 18:57:25.619098 2022] [mpm_worker:notice] [pid 19580:tid 48007540429888] AH00292: Apache/2.4.54 (cPanel) OpenSSL/1.1.1q mod_bwlimited/1.4 configured -- resuming normal operations
[Sat Oct 15 18:57:25.619107 2022] [core:notice] [pid 19580:tid 48007540429888] AH00094: Command line: '/usr/sbin/httpd'
[Sat Oct 15 19:03:53.368298 2022] [proxy:error] [pid 9714:tid 48007944877824] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /opt/cpanel/ea-php80/root/usr/var/run/php-fpm/d0759de0d20fd1f81dac7051724ec58bd2e192df.sock (:80) failed
[Sat Oct 15 19:03:53.368413 2022] [proxy_fcgi:error] [pid 9714:tid 48007944877824] [client 185.191.171.41:8326] AH01079: failed to make connection to backend: httpd-UDS
[Sat Oct 15 19:03:53.368903 2022] [proxy:error] [pid 9714:tid 48007944877824] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /opt/cpanel/ea-php80/root/usr/var/run/php-fpm/d0759de0d20fd1f81dac7051724ec58bd2e192df.sock (
:80) failed

[Sat Oct 15 19:03:53.368929 2022] [proxy_fcgi:error] [pid 9714:tid 48007944877824] [client 185.191.171.41:8326] AH01079: failed to make connection to backend: httpd-UDS

 

Link to comment
Share on other sites

I'm having pretty much this same issue. My site works fine when the PHP version is set to 7.4 but as soon as I switch to 8 the site stops working. If I switch back to 7.4 everything works fine.

My server allows uploading PHP PEAR packages. Is there a specific PEAR package, or a set of multiple packages possibly that I / we could upload to solve this?

Edited by Aramaech
Link to comment
Share on other sites

9 hours ago, Aramaech said:

Ok, now I only seem to be locked out of the admin cp when using php 8.0 but the site itself seems to be working ok with it. Same server error when trying to load the admin cp tho.

 

2 things I recommend trying:

  1. Running the requirements checker that Randy mentioned above (https://invisioncommunity.com/files/file/7046-invision-community-requirements-checker/)
  2. Disabling all third-party applications and plugins.

If you're still having issues, there should be an error message presented from our software when attempting to access the ACP. If you're receiving just a blank page, you would need to consult your server error log.

Link to comment
Share on other sites

2 hours ago, Jim M said:

2 things I recommend trying:

  1. Running the requirements checker that Randy mentioned above (https://invisioncommunity.com/files/file/7046-invision-community-requirements-checker/)
  2. Disabling all third-party applications and plugins.

If you're still having issues, there should be an error message presented from our software when attempting to access the ACP. If you're receiving just a blank page, you would need to consult your server error log.

Did both.

Still getting blank screen using the default theme. No error message in ACP.

Do I need to remove all third-party applications and plugins or just disable them?

I also notice that the back end is really slow now after moving to PHP8. Should I change it to 8.1?

Edited by Michael R
Link to comment
Share on other sites

4 minutes ago, Michael R said:

Did both.

Still getting blank screen using the default theme. No error message in ACP.

Do I need to remove all third-party applications and plugins or just disable them?

Could you please update the ACP credentials on file? I would like to try recovery mode but cannot login to the ACP once I set it with the invalid credentials on file. Please ensure you update the display name with an email address

Link to comment
Share on other sites

3 minutes ago, Jim M said:

Could you please update the ACP credentials on file? I would like to try recovery mode but cannot login to the ACP once I set it with the invalid credentials on file. Please ensure you update the display name with an email address

Hmm. I did already. I will PM you

Link to comment
Share on other sites

Unfortunately, there is still an underlying issue stopping the execution of the software. Even in recovery mode, I am getting a 500 Internal Server Error presented. This is a lot like your check engine light on your car, it says there is an issue but not what or where. Again, we would need the Server Error log entry to see what is happening here. Please reach out to your hosting provider if you are unsure how to gather this information.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...