Jump to content

October update broke my forum!


RocketFoot
 Share

Go to solution Solved by Jim M,

Recommended Posts

2 minutes ago, RocketFoot said:

Sure!  It still isn't working...when I click on a topic view, I get this error:

[[Template forums/front/topics/post is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

I'm afraid that the front-end developer who designed that specific template, also modified some files in ../../topics/post. Since the new update you cannot anymore modify the CORE Files (which I agree with). Before you could edit the files and even revert to default files if you ever had a problem with an outdated template.

But I can still help you, if you want. Since this topic is useless because of the template beeing out of date, I will continue to speak with you on private.

@Jim M You're always right 😄

Link to comment
Share on other sites

@Jim M sorry for x2 mention for today.

The problem wasn't from the template actually. It was from Third Party Application "Community Map".
I disabled it and now It's working.

! Attention for all clients.
When you update your IPS Version to IPS v4.7+ and you get template errors first of all try disabling one by one the plugins & applications to make sure that one of the plugin / application isn't the culprit.

  

27 minutes ago, Jim M said:

That would indicate that the template there is not compatible with the latest release and you'll need to work with the author to ensure it is compatible.

And this is the second this you should do if still doesn't work . !!

Edited by drawncodes
Link to comment
Share on other sites

1 hour ago, drawncodes said:

Since the new update you cannot anymore modify the CORE Files

Can someone direct me to the specifics of this? I searched the release notes and can't find anything that describes what's no longer modifiable and starting with which version. 

Link to comment
Share on other sites

same here, my entire forum has gone replaced with this message. It happened when I did a forum software update today. I'm pretty sure this happened before and I was able to get rid of it by disabling classifieds, but now the forum has gone I can't get into the admin control to disable it again. Anyone know how I can access my admin control panel with the forum gone to switch classified off?  Is there a url that will take me directly to my admin control panel?      

Fatal error: Declaration of IPS\classifieds\_Advert::getItemsWithPermission($where = [], $order = null, $limit = 10, $permissionKey = 'read', $includeHiddenItems = IPS\Content\Hideable::FILTER_AUTOMATIC, $queryFlags = 0, ?IPS\Member $member = null, $joinContainer = false, $joinComments = false, $joinReviews = false, $countOnly = false, $joins = null, $skipPermission = false, $joinTags = true, $joinAuthor = true, $joinLastCommenter = true, $showMovedLinks = false) must be compatible with IPS\Content\_Item::getItemsWithPermission($where = [], $order = null, $limit = 10, $permissionKey = 'read', $includeHiddenItems = IPS\Content\Hideable::FILTER_AUTOMATIC, $queryFlags = 0, ?IPS\Member $member = null, $joinContainer = false, $joinComments = false, $joinReviews = false, $countOnly = false, $joins = null, $skipPermission = false, $joinTags = true, $joinAuthor = true, $joinLastCommenter = true, $showMovedLinks = false, $location = null) in /home/treasure/public_html/forums/applications/classifieds/sources/Advert/Advert.php on line 605

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...