Jump to content

Upgraded to new version - updating app has locked me out - Any ideas?


Go to solution Solved by Jim M,

Recommended Posts

Hey Everyone,

I just updated to the newest version.  The system told me my theme was not compatible and Im going to update that -- stupid me updated an outdated app first and now I get this:

Fatal error: Cannot use "parent" when current class scope has no parent in /home/customer/www/taxidermy-talk.com/public_html/system/Theme/Theme.php(2703) : eval()'d code on line 41

I can not seem to get back into my AdminCP to fix the issue.  Is there a work around to get into the control panel with this error?  Can not seem to find the solution in the forums.

 

Thank you,

Robert

Link to comment
Share on other sites

Posted (edited)

Hey Jim,

Thank you for the quick reply.  So I created that constants.php file and added the recovery line -- that gets me back into the AdminCP sortof -- I get this:

"Before you are able to use the Admin Control Panel, you must edit 'constants.php' and remove the following line:  define( 'RECOVERY_MODE', TRUE );

 

Clicking get support then returns to this same error.  

 

Robert

Edited by Lego Me Eggo
Link to comment
Share on other sites

3 minutes ago, Lego Me Eggo said:

Hey Jim,

Thank you for the quick reply.  So I created that constants.php file and added the recovery line -- that gets me back into the AdminCP sortof -- I get this:

"Before you are able to use the Admin Control Panel, you must edit 'constants.php' and remove the following line:  define( 'RECOVERY_MODE', TRUE );

 

Clicking get support then returns to this same error.  

 

Robert

You will need to remove that line as the system performed the recovery and disabled your third party add-ons.

Link to comment
Share on other sites

Hmm..  Thats just the thing -- after creating that file and refreshing the AdminCP it took me the error above.  Removing the line and refreshing returns me to:

Fatal error: Cannot use "parent" when current class scope has no parent in /home/customer/www/taxidermy-talk.com/public_html/system/Theme/Theme.php(2703) : eval()'d code on line 41

Weird.

Robert

Link to comment
Share on other sites

  • Solution

Could I confirm that you were logged out of the ACP before applying the constant and then logged in afterwards?

If so, please provide us access:

We would need to look further into this for you, however the access details on file appear to be incorrect or missing. Could you please update these details by visiting your client area, selecting the relevant purchase, then clicking "Review/Update Access Information" under the "Stored Access Information" section. 

We look forward to further assisting you. 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...