Jump to content

Locked Task: queue - and background processes backing up like crazy


Emediate
 Share

Go to solution Solved by Emediate,

Recommended Posts

v4.7.1 - have not upgraded as yet due to so many reports of apps and plugins not yet compatible and getting locked.

But for 24 hours, my queue task has been locked and background processes are all queuing up. 

Could contain: Text, Number, Symbol

When I click Run Now, I get "The task is already running and cannot be ran until it has finished or the lock is removed." If I remove the lock, on its next scheduled run, it just locks again.

The only thing I can think of that triggered this was I attempted to move around 20,000 members from one usergroup to another, and in the task list that is currently sitting at 1.6% (after 24 hours), but surely other background processes can run simultaneously? 

Link to comment
Share on other sites

The background queue is resulting in a 500 Internal Server Error. This is the same as the check engine light on your car. It says something is wrong but not exactly what or where. You would need to work with your hosting provider to look at your server's error log entries to find the appropriate error and if a server error, resolve it with them. If it is a software error, please pass it here.

Link to comment
Share on other sites

There's several tasks causing the 500 Server Error which is stopping the tasks from running.

Hosts have been monitoring it all day.

Quote
[18-Sep-2022 05:25:26 UTC] PHP Fatal error:  Maximum execution time of 300 seconds exceeded in /home/stereoglobal/public_html/forums/system/Patterns/Singleton.php on line 38
Quote
[18-Sep-2022 05:31:13 UTC] PHP Fatal error:  Maximum execution time of 300 seconds exceeded in /home/stereoglobal/public_html/forums/system/Db/Db.php on line 607

We've raised the timeout and thrown more resources at the server (128Mb RAM) and it's working hard, but not sure its every going to complete them.

This seems to have predominantly started when we initiated the move of 34,000 members from one group into another. Ever since then all these other tasks have started backing up and just won't run.

Link to comment
Share on other sites

  • Solution

We have resolved this. It was the application Drip Campaigns - we had a drip setup so that if a member moves into the Member Group (say, when they are promoted from New Member group or similar) - it would send them an email.  Drip Campaigns works flawlessly for us with managing new member registrations - however it seems to have come unstuck with a mass member group move. Lesson learned.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...