Jump to content

"Too many redirects"


Jon Hole
 Share

Go to solution Solved by Jon Hole,

Recommended Posts

Sometime between 9am and 10am (UK time) today, our self-hosted forum stopped working - https://www.zero88.com/forum/

I’ve checked with multiple people and it’s down for all of them.

We get a "too many redirects" error.

The rest of the website (non-Invision forum) is working fine.

There have been no changes to our server settings or forum settings today (or for quite a while previously)

The SSL certificates are in date.

When my IP address tries to access the forum, the server logs show 10x “301 GET /forum/ HTTP/1.0”

However, from the server logs, it appears that other IP addresses are successfully accessing the forum (logs show specific pages with code “200”) – I just don’t know how or who.

I'm a little lost as to where to start diagnosing this

Link to comment
Share on other sites

First of all I would think to yourself, regardless of whether you believe something to have changed, something must have indeed changed. So it's a case of tracking down what that change is. The first thing I would do in order to check this would be to rename any htaccess files outside of your community directory, just temporarily to see if your site loads. This would be the most common cause of issues like these

Link to comment
Share on other sites

Thanks Marc,

I've previously attempted removing .htaccess from the /forum directory, and the parent / directory, with no sucsess. I've just doubled checked by renaming, and still not fixed.

One thought of something that has changed... today all our social channels were shutdown (part of a transition to our "parents" social channel). I don't remember any tie-in more than a simple URL link.

Link to comment
Share on other sites

$INFO['board_url']			=	'https://zero88.com/forum';

This is already set within conf_global.php

I noticed in the client area that our licence was only http, but didn't want to change it just to "test" as I wouldn't be able to change it back... and I'm guessing the licence within the clientarea wouldn't in itself cause this issue.

Link to comment
Share on other sites

  • Solution

Hi Marc,

I just tried changing:

https://zero88.com/forum

to

 

https://www.zero88.com/forum

and that appears to have fixed the issue.

That file hasn't been changed, and the forum software hasn't been updated (it's on the to-do list!). What would have caused that setting to to create a problem like this?

 

Link to comment
Share on other sites

5 minutes ago, Marc Stridgen said:

Please update your access details on file to correct the sftp location for your files.

Done

 

Just now, Marc Stridgen said:

So something on the server has changed there.

Very strange... I know none of our team have made that change within the past month... maybe a default change by our hosting?

Anyway, thank you very much for your very quick help and guidance Marc, appreciate it.

Link to comment
Share on other sites

Sorry @Marc Stridgen, one thing I've just noticed - font icons aren't working:

Could contain: Logo, Trademark, Symbol

Could contain: Text

 

Presumably this is related, due to the missing "www" in the URL of the font (typing the below into my browser downloads the font, but presumably the URL forwarding is kicking in).

https://zero88.com/forum/applications/core/interface/font/fontawesome-webfont.ttf?v=4.7.0

In the template, this is just listed as:

href="{url="applications/core/interface/font/fontawesome-webfont.woff2?v=4.7.0"

How do I change where this is pointing? The only place I can find the URL within the AdminCP is within the licence. In the client area, I can't change the URL to include "www", as it says "There seems to still be an installation of Invision Community at the URL on file. Before you can change the URL, you must first remove the existing installation."

Edited by Jon Hole
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...