Jump to content

Subscriptions expired after 4.7.0 upgrade even with valid expiry date


Recommended Posts

Additionally subscriptions not showing under expired or active that are in the database still. 

Affects subscriptions with an active paypal billing agreement, even with changing flags in db to active there is still nothing changing in the software to reflect accurate subscription and renewal benefits. 

Was fine before the upgrade.

Link to comment
Share on other sites

The problem is much more widespread than I thought. There are hundreds of bogus invoices were generated and set to pending and expired the primary subscription for the entire site. @MarkThis is a very big 5 figure issue for me. 

Could contain: Menu, Text, Number, Symbol, Word, Plot

Each user with this bogus invoice has a similar pattern in their profile of this:

Could contain: Text, Menu

Meanwhile in their customer profile their subscription remains active and shows a bogus renewal pending:

Could contain: Text

It seems like the OP was an isolated case that was weird, the rest of these all follow the same pattern but have active subscriptions with bogus expiry and pending invoices. Is there a way to re-run the subscription expiry automation from the admin dashboard or with a CLI command?

Link to comment
Share on other sites

Not at all. The issue here is you posted in community support, rather than the one in the official support forum which is monitored by members of staff. I have moved the topic for you now

Please provide me with the member ID of the example in your first post, and we can then take a look for you.

Link to comment
Share on other sites

  • 1 month later...

We would need to look further into this for you, however the access details on file appear to be incorrect or missing. Could you please update these details by visiting your client area, selecting the relevant purchase, then clicking "Review/Update Access Information" under the "Stored Access Information" section. 

We look forward to further assisting you. 

 

Link to comment
Share on other sites

  • 3 weeks later...
On 9/19/2022 at 2:36 AM, Marc Stridgen said:

We would need to look further into this for you, however the access details on file appear to be incorrect or missing. Could you please update these details by visiting your client area, selecting the relevant purchase, then clicking "Review/Update Access Information" under the "Stored Access Information" section. 

We look forward to further assisting you. 

 

This is fixed - I wonder why I'm not getting emails when you reply here. 

Link to comment
Share on other sites

17 minutes ago, Rick Vasquez said:

This is fixed - I wonder why I'm not getting emails when you reply here. 

The default settings on this site do not have email notifications for replies when you follow a topic.  You can change your preferences in the notification settings...

https://invisioncommunity.com/notifications/options/

Choose Followed Content and make sure you add email as a notification type.  

The IPS staff will have to help with the original issue however.  🙂 

Edited by Randy Calvert
Link to comment
Share on other sites

On 9/18/2022 at 4:55 PM, Rick Vasquez said:

Member ID 24 - I am just now seeing this sorry. 

I am seeing subscriptions showing under active and expired for this user. They have 2 active and 6 expired. 

Did you remove data from this user's history here? Unfortunately, I am not seeing the invalid invoice for this user. I do see the weird expiration on August 3rd which I'd like to investigate further. Do you have another user with this intact? 

Link to comment
Share on other sites

I mean any user that has the product treefiddy monthly renewal had this issue. It was everyone with this subscription tier. 

I had to do a lot of fixes to get them back in the right groups and on current invoices - I just need to know it isn't going to happen again on the next update. 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...