Jump to content

Cannot Access ACP After Upgrade to 4.7

Go to solution Solved by Marc Stridgen,

Recommended Posts

I went through the upgrade process to 4.7 today and received no errors. After the process completed, I went back to my Admin Control Panel but now all I see is:

[[Template core/admin/global/globalTemplate is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

Of course I can't run the support tool since I can't get to the ACP. In the past I experienced a similar issue that was caused by missing tables, but I can't imagine how that happened today since I only ran the 4.7 upgrade process and didn't touch our database at all.

Link to comment
Share on other sites

1 hour ago, Mark H said:

Please try using Recovery Mode:

Scroll to the bottom of the page, the section titled "Recovery Mode (Self hosted only)", and please make certain to follow all instructions in order.

I added the line to my constants.php file, but nothing changed on the ACP. I still see the same error.

Link to comment
Share on other sites

I'm seeing that issue, yes. (I've also removed the recovery line from your constants.php file.)

As the next step, please download a fresh copy of the software from the Client Area and extract it to your desktop.

It will create a folder named ips_xxxxx (xxxxx is random string)

Then use an FTP client and upload the contents of that ips_xxxxx folder to your forum main folder, overwriting when prompted and making sure all files transfer without error.

Once done, first visit the upgrade URL directly at ./admin/upgrade/ to see if there is a minor upgrade that needs to be applied. (Perform that upgrade if one shows.)

Then visit the Admin panel URL and see if you can now login. If you can't, please reply here.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...