Jump to content

Incorrect session data path in 4.7 upgrade

Go to solution Solved by Jan Krohn,

Recommended Posts

I'm getting error 4S109/5 during upgrade:

We were unable to start a PHP session. You will need to contact your host to adjust your PHP configuration before you can continue. The error reported was: session_start(): Failed to read session data: files (path: /var/cpanel/php/sessions/ea-php72)

I noticed that the path is incorrect though. It should be ea-php74, since PHP 7.4 is installed. I did check in php.ini, and directly on the server, and can confirm that ea-php74 is correct. It looks to me that the upgrade routine fetches the path from somewhere else, and not from php.ini.

I already tried re-installing PHP 7.2 with the same config as I now have on PHP 7.4, but it still doesn't work (server error 500, likely due to depracated PHP functions).

My next idea was to find the location where this path is configured, and overwrite it manually to ea-php74, but couldn't find it. So unless there's some other idea how to fix this, I could need some help finding the place where to overwrite the path.

(It would still be a workaround though. To fix properly, the upgrade routine needs to fetch the session data path from PHP configuration.)

Could contain: File, Text, Word, Webpage

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...