Jump to content

Upload error

Go to solution Solved by Marc Stridgen,

Recommended Posts

Good evening Invision,


I have a small error on my website. I’ve tried to upload a picture onto my website and it came up with the error „6”, and it says to contact the support team. I logged into the admin panel and I have noticed, that there was critical error. I have opened it and it said that I have to paste this „define( 'TEMP_DIRECTORY', dirname( __FILE__ ) . '/uploads' );  „ into the constants.php file to resolve the error. After I’ve done this, the error is still showing on my website. None of the users cannot upload their avatars or post any pictures on the website. Please, get back to ma as soon as possible. Any help will be much appreciated.




Link to comment
Share on other sites

Do you have any further information on the error? What type of file was this that you're uploading? Are you able to provide the file? Please also update access to your community as outlined below:

We would need to look further into this for you, however the access details on file appear to be incorrect or missing. Could you please update these details by visiting your client area, selecting the relevant purchase, then clicking "Review/Update Access Information" under the "Stored Access Information" section. 

We look forward to further assisting you. 


Link to comment
Share on other sites

Thank you for a quick reply.

This is the error that I'm getting when I try to upload my any picture anywhere on the forum.

Could contain: Number, Text, Symbol

The error says to contact the technical support.


These are the logs that I'm getting after trying to upload a .png file.


#0 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/system/File/File.php(398): IPS\_File::validateUpload(Array, NULL, NULL)
#1 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/system/Helpers/Form/Upload.php(748): IPS\_File::createFromUploads('core_Attachment', NULL, NULL, NULL, NULL, 0, Object(Closure), NULL, true)
#2 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/system/Helpers/Form/Upload.php(305): IPS\Helpers\Form\_Upload->processUploads()
#3 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/system/Helpers/Form/Editor.php(725): IPS\Helpers\Form\_Upload->__construct('topic_comment_4...', Array, false, Array)
#4 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/system/Helpers/Form/Editor.php(176): IPS\Helpers\Form\_Editor->getUploader('topic_comment_4...')
#5 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/system/Content/Item.php(4749): IPS\Helpers\Form\_Editor->__construct('topic_comment_4...', NULL, true, Array, Object(Closure))
#6 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/system/Content/Item.php(4539): IPS\Content\_Item->commentFormElements()
#7 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/system/Theme/Theme.php(880) : eval()'d code(6452): IPS\Content\_Item->commentForm()
#8 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_forums_front_topics->topic(Object(IPS\forums\Topic), Array, NULL, Array, NULL, NULL, Array)
#9 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/applications/forums/modules/front/forums/topic.php(562): IPS\Theme\_SandboxedTemplate->__call('topic', Array)
#10 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/init.php(913) : eval()'d code(66): IPS\forums\modules\front\forums\_topic->manage()
#11 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/system/Dispatcher/Controller.php(101): IPS\forums\modules\front\forums\viewers_hook_codeForumsModFrontForumsTopics->manage()
#12 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#13 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/applications/forums/modules/front/forums/topic.php(39): IPS\Content\_Controller->execute()
#14 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/system/Dispatcher/Dispatcher.php(153): IPS\forums\modules\front\forums\_topic->execute()
#15 /usr/home/Flaw123less619/domains/gramy-4fun.pl/public_html/index.php(13): IPS\_Dispatcher->run()
#16 {main}

The details are updated.


Edited by KsiążeHappy
Link to comment
Share on other sites

Please switch to an unmodified language pack and theme then please disable any third party applications/plugins. Then test again.

Please also see the IP address that I put in the "notes" section of the Client Area for you and ensure you add that so our technicians can access your community's ACP.

Link to comment
Share on other sites

26 minutes ago, KsiążeHappy said:

Theme is set back to default. Applications and plugins have been disabled and same errors comes up.

Please ensure that you've done the language pack as well. Please use the default, un-modified English one.

26 minutes ago, KsiążeHappy said:

I cannot see any IP in the client area. Could you please guide me, where exactly it is?

This would be in your notes area but I have messaged it to you as well.

Link to comment
Share on other sites

I do not think it is a cloudflare fault. I was using cloudflare since I started my website. I have friends online who are also  using cloudflare and everything works fine for them. This error just pop up suddenly in the middle of yesterdays night. 

If I disable cloudflare I will have to change DNS settings which might even take up to 48h to change. If this is the only option then I will do it, but I highly doubt it's Cloudflare fault. 

Once yet, I have deleted the line from constants.php. This critical information popped up, when the error started to show up on the forum.


Could contain: Text, Page, Word, White Board, Plot


I have followed the instructions once I click "Fix This", but the result was the same as now. 

Edited by KsiążeHappy
Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...