Jump to content

Almost there! Ported over my database but the upgrade from 4.6.11 to doesn't work

Recommended Posts

Hello All,

Thanks for your help especially to Miss_B! Here's what I did:

1) I copied the database from my old web server to the new one. Old database has table prefixes "ibf_"

2) I did a fresh installation of and didn't specify any table prefixes

3) Then I changed this line of code in config_global.php file
    'sql_tbl_prefix' => '',
To the following code:
    'sql_tbl_prefix' => 'ibf_',


So far so good...everything on the forum including the adminCP works beautifully. But then I got notification I needed to upgrade from 4.16.11 to I tried this and here's where everything falls apart:

Somehow the forum made use of this hidden directory from my old web host.
During the upgrade process, it says that this directory doesn't exist so the whole upgrade gets stuck.

My form exists globally at www.audioinnovate.com/forums. So when I go to my server, the forum files exist at home/audioinnovate/public_html/forums. When I use FTP, home/audioinnovate is the root directory. I have no way of creating or accessing any files at a lower directory level. For all practical purposes, this weird /home/users/web/b1038/sl.audioinn/ directory doesn't exist anymore because I moved files off of another server. I have no way of either creating or accessing this weird directory.

I searched all of my database files and fixed the string /home/users/web/b1038/sl.audioinn/public_html/forums/uploads to /home/audioinnovate/public_html/forums/uploads but that did NOT fix the problem.

So my question is:

How do I fix the upgrade process so it's no longer searching for this hidden directory /home/users/web/b1038/sl.audioinn/public_html/forums/uploads and instead searches for the existing directory /home/audioinnovate/public_html/forums/uploads?



Link to comment
Share on other sites

Hello Nathan, Mark,

Yes thank you for your help. This did work but not without a bit of grief. The first time I tried the adding the directory /home/audioinnovate/public_html/forums/uploads which is the valid one on the new server and deleting /home/users/web/b1038/sl.audioinn/public_html/forums/uploads which is the invalid directory from the old server. The storage settings all updated to the new directory but then suddenly I was stuck with "forum upgrade in process" messages and the forum stopped working. I think this may have something to do with the fact that the "move files automatically" setting was checked.

So the way I had to fix this was to delete my entire forum and then restore the entire forum. Fortunately this process only takes a few seconds with all of the backup files on the web server. Interestingly the admin control panel then said I was up-to-date with version, and when I went back to the storage settings, they were blank. So I deselected the "move files automatically", restored the  /home/audioinnovate/public_html/forums/uploads directory under storage settings -> configurations, and all started working.

I think it would be advisable for anyone dealing with broken file systems - especially moving from one server to another where this is clearly possible - the "move files automatically" box should NOT be checked or the whole process will crash as the forum searches for a non-existent directory.

Anyways, thank you so much for pointing me in the right direction. All resolved now!


Edited by Elliot Marx
Link to comment
Share on other sites

Very glad to hear that 🙂 Of course the software isnt really built to be used in the manner you were trying to use it there, so there will always be some abnormalities, as you saw there. You should be all good now you got it upgraded though

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...