Jump to content

Can't see ikey due to template issue.

Recommended Posts


 Jumped on the back end of my website recently to check a key that someone has purchased and in place of where the key should be, I'm getting the message:
     [[Template nexus/admin/purchases/lkey is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

 Now I feel like if I simply "Run the support tool in the AdminCP to restore the default theme" that should fix the issue. The problem is, I don't see any way to "restore the default theme."

 If anyone is aware of how I would go about doing that, it would be amazing as I have a number of customers now who aren't sure if they have used a code, and I can't easily find out as it isn't displaying it on their account.

BlueBirdRP - David Scaroni

Edited by David Scaroni
Changed tag
Link to comment
Share on other sites

  • 2 months later...
4 minutes ago, Narvuk said:

@Jim M I get this too, tried disabling all and still same error, it happens when using the API for me once activated the admin show this error

We would need to look further into this for you, however the access details on file appear to be incorrect or missing. Could you please update these details by visiting your client area, selecting the relevant purchase, then clicking "Review/Update Access Information" under the "Stored Access Information" section. 

We look forward to further assisting you. 


Link to comment
Share on other sites

@Jim M I have loaded a dev enviroment and the issues comes after api activation

to resolve the issue in my dev enviroment

as you notice the extra contains null, IPS doesnt like the null value where it is in the database


if extra is blank or has no results it need to be set to nothing for example



this resolved the error on my dev but was unsure where in the php the value null gets set when either using the api to activate the usage of the license



You can pass [] in extra when activate via api to save it going null, but if left blank when sending it causes extra: to become null which throws the error in ACP view license key view. of product

Edited by Narvuk
Update to fix solution
Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...