Jump to content

Registration Error - EX0


mulphy
 Share

Recommended Posts

Hi guys, we can't get any new members and I keep getting ex0 when I run tests. I tried to disable captcha and spam as I thought it might be related but still no joy. Please find the system error below:

 

ArgumentCountError: Too few arguments to function IPS\core\modules\front\system\_register::_createMember(), 2 passed in /home/ytekn890zxdc/public_html/init.php(893) : eval()'d code on line 9 and exactly 4 expected (0)
#0 /home/ytekn890zxdc/public_html/init.php(893) : eval()'d code(9): IPS\core\modules\front\system\_register::_createMember(Array, Array)
#1 /home/ytekn890zxdc/public_html/applications/core/modules/front/system/register.php(240): IPS\core\modules\front\system\hook318::_createMember(Array, Array, NULL, Object(IPS\Helpers\Form))
#2 /home/ytekn890zxdc/public_html/applications/core/modules/front/system/register.php(103): IPS\core\modules\front\system\_register->_registrationForm(NULL)
#3 /home/ytekn890zxdc/public_html/system/Dispatcher/Controller.php(101): IPS\core\modules\front\system\_register->manage()
#4 /home/ytekn890zxdc/public_html/system/Dispatcher/Dispatcher.php(152): IPS\Dispatcher\_Controller->execute()
#5 /home/ytekn890zxdc/public_html/index.php(13): IPS\_Dispatcher->run()
#6 {main}

 

#0 /home/ytekn890zxdc/public_html/init.php(995): IPS\_Log::log('ArgumentCountEr...', 'uncaught_except...')
#1 [internal function]: IPS\IPS::exceptionHandler(Object(ArgumentCountError))
#2 {main}

Link to comment
Share on other sites

1 hour ago, teraßyte said:

The error log only mentions hook318 which doesn't help unfortunately. Do you have any applications or plugins related to the registration process? Like a plugin adding a field for new registrations or something.

That was my original thought - captcha or security questions. I removed them both to test and still nothing.

Could someone take a look for me please? 

Link to comment
Share on other sites

10 hours ago, mulphy said:

Anyone available please?

It's Sunday today so I guess not. Someone from IPS will have a look tomorrow most likely.

 

P.S.: Captcha and Q&A are not plugins so disabling those wouldn't have any effect on the error. You need to check either in Applications or Plugins for modifications causing the issue.

Edited by teraßyte
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...