Jump to content

Installing update 4.6.11 fails

Recommended Posts

Hello. I've tried twice now to install the latest update. I cleared the cache in between. I get the following error -

Error: Class 'IPS' not found (0)
#0 /home/customer/www/mysite.co.uk/public_html/forums/applications/core/modules/admin/system/upgrade.php(569): IPS\_Log::log(Object(LogicException), 'auto_upgrade')
#1 /home/customer/www/mysite.co.uk/public_html/forums/system/Helpers/Wizard/Wizard.php(181): IPS\core\modules\admin\system\_upgrade->_login(Array)
#2 /home/customer/www/mysite.co.uk/public_html/forums/applications/core/modules/admin/system/upgrade.php(109): IPS\Helpers\_Wizard->__toString()
#3 /home/customer/www/mysite.co.uk/public_html/forums/system/Dispatcher/Controller.php(101): IPS\core\modules\admin\system\_upgrade->manage()
#4 /home/customer/www/mysite.co.uk/public_html/forums/applications/core/modules/admin/system/upgrade.php(54): IPS\Dispatcher\_Controller->execute()
#5 /home/customer/www/mysite.co.uk/public_html/forums/system/Dispatcher/Dispatcher.php(153): IPS\core\modules\admin\system\_upgrade->execute()
#6 /home/customer/www/mysite.co.uk/public_html/forums/admin/index.php(13): IPS\_Dispatcher->run()
#7 {main}


(I changed my urls to mysite.co.uk). I've checked and all of the URLs listed exist in the exact place that is shown. However, I don't know what the folder IPS is supposed to be?

Link to comment
Share on other sites

Thanks marc, which files are missing please?  I've just downloaded fresh files from client area and there are no folders in there I don't have. All the files "not found" in the error are fully present, apart from ones at the end of lines mentioning a folder called IPS, but there's no IPS folder in the core files either so I'm confused.

Link to comment
Share on other sites

Thanks again Mark. I've been running IPS forums for well over 10 years, I've never had files go missing before. How is that even possible? The forums have been and were working perfectly okay.

I uploaded all of the files and the upgrade appeared to work okay. But now whenever I log into my control panel I get the following message -

Your site is ready to upgrade
A new version is available to install and it is strongly recommended that you complete the upgrade process for this new version before continuing to the AdminCP. Sometimes changes in new versions will result in errors until the upgrade process has been completed.

Needless to say whenever I select complete upgrade it takes me to a page that tells me there's nothing to upgrade. I've tried clearing the cash in my browser, and on my dashboard. Is this something to do with a leftover file that can be deleted?


Link to comment
Share on other sites

7 minutes ago, Randy Calvert said:

Once you uploaded the new files did you run yourdomain.com/admin/upgrade.  It will walk you through the upgrade process. 

Yes, thanks, the update completed successfully and everything works ok. The issue was that each time I logged into my dashboard, it said there was an incomplete update and gave the option to complete it. Whenever I clicked to complete the update it reported that there was no update to complete. After this I was taken to my dashboard where everything looked okay.

As it happens, I just logged in for the fifth time and this time the messages disappeared. Another puzzle.


Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...