Jump to content

File download sometimes downloads "descarga" file name


Ibai
 Share

Recommended Posts

Hi there,

From several version until now, sometimes (I don't know when neither why) when clicking in "download file" button, it downloads a file with "descarga" name.

I really don't know how to explain. Best option is to see with your eyes:

https://www.fmsite.net/files/file/1165-actualización-fm-2022-temporada-21-22

As you can see in the following image, the file name is "Actualización juan_clarinet 21-22.fmf". However, when you download the file, you will download a file with "descarga" filename such as the last image attached.

image.png.994f91cdf03fe210cb802a58977efb53.png

image.png.6de6630c74c84f6c8ba1b40c368fadde.png

I think that it has sth to be with the filename. Maybe there's issues with files names with "accent mark" or special characters as the "ñ"?

 

 

Link to comment
Share on other sites

11 hours ago, Marc Stridgen said:

Please could you check mod_security on your server (or securi if you have that running) and check their logs at the time this happens?

Hey Marc, 

Thanks for your reply. I checked mod_sec logs and there's nothing I can relate to this issue, neither in error_log.

Link to comment
Share on other sites

44 minutes ago, Jim M said:

Have you tested this on the default language pack? Wondering if perhaps something changed in the language string and is causing an issue now with your custom language pack.

Good point. Just checked and not seems to be related. I changed to English and also downloads a "descarga" named file.

When you click there, you also get a "descarga" named file?

Link to comment
Share on other sites

Yes, it was from Chrome... Still with this issue. 

You gave me an idea and tried from Firefox. De file name that is downloaded is: Dgupb3qc

Also tried from Internet Explorer. The name seemed better, though it didn't have file extension.

I don't know, could this be a bug? This is not happening in all files but this happens now and them in some of them.

Link to comment
Share on other sites

On 2/25/2022 at 9:53 AM, Marc Stridgen said:

Do you have any plugins running on your browser which may be renaming this? If we cannot reproduce on your site and you can, the issue really must be on your end rather than that of the site

The point is that it's not only happening to me, but to a great number of users...

I don't even have any uBlock plugin enabled in Chrome.

This does not happen with every file, just some of them. For instance, this user has already re-uploaded the file and the issue still happens.

In this example, it's working fine: https://www.fmsite.net/files/file/1205-fm22-estructura-paraguay-2022-ap-y-cl-4-niveles-promedios

What browser are you using? This is very weird, I tried from my laptop, my computer and also from work's PC. Tried MacOS in different SO version and also Windows 10 with Internet Explorer and Chrome. It's shocking that this works well to you... :s 

Link to comment
Share on other sites

Hi Marc,

What browser are you using? Do you have any plugin enabled?

I've tried even with private browsing and also happens with any browser... and this is happening to all my visitors, so I don't understand why it's working for you. As I told you, from MacOS, Windows and all kind of browsers.

This is the file that doesn't work:

https://www.fmsite.net/files/file/1165-actualización-fm-2022-temporada-21-22/

Link to comment
Share on other sites

7 hours ago, Marc Stridgen said:

I was using edge. As a courtesy however, I have just tested edge, firefox, and chrome. All result in the file "Actualización juan_clarinet 21-22.fmf"

If you log out and test this, what are you getting then?

Yes I tried that. I have also tried private navigation too.

Don't know what else try... I dont understand how it is working to you. Also checked mod_security logs and it's clean 😕 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...